aboutsummaryrefslogtreecommitdiff
path: root/graphics/sekrit-twc-zimg
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-09-14 22:45:18 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-09-14 22:45:18 +0000
commita19a4d58ca03df531014e9ae3bd726402ad03743 (patch)
treea168cbc749799b0180d003abcec23f26ff8cc66a /graphics/sekrit-twc-zimg
parent719076a220d704c365135ed875088f08ac1ec795 (diff)
downloadports-a19a4d58ca03df531014e9ae3bd726402ad03743.tar.gz
ports-a19a4d58ca03df531014e9ae3bd726402ad03743.zip
graphics/sekrit-twc-zimg: update to 3.0.1
Notes
Notes: svn path=/head/; revision=548686
Diffstat (limited to 'graphics/sekrit-twc-zimg')
-rw-r--r--graphics/sekrit-twc-zimg/Makefile2
-rw-r--r--graphics/sekrit-twc-zimg/distinfo6
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-neon33
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-no-extra-deps29
4 files changed, 53 insertions, 17 deletions
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index 738beb2f07f8..fd8f633cc380 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -2,7 +2,7 @@
PORTNAME= zimg
DISTVERSIONPREFIX= release-
-DISTVERSION= 2.9.3
+DISTVERSION= 3.0.1
CATEGORIES= graphics
PKGNAMEPREFIX= ${GH_ACCOUNT}-
diff --git a/graphics/sekrit-twc-zimg/distinfo b/graphics/sekrit-twc-zimg/distinfo
index 693dee81380f..8745d2de6055 100644
--- a/graphics/sekrit-twc-zimg/distinfo
+++ b/graphics/sekrit-twc-zimg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583124602
-SHA256 (sekrit-twc-zimg-release-2.9.3_GH0.tar.gz) = a15c0483fbe945ffe695a1a989bc43b3381c8bf33e2d1760464ec21d32cdf30b
-SIZE (sekrit-twc-zimg-release-2.9.3_GH0.tar.gz) = 266236
+TIMESTAMP = 1598190477
+SHA256 (sekrit-twc-zimg-release-3.0.1_GH0.tar.gz) = c50a0922f4adac4efad77427d13520ed89b8366eef0ef2fa379572951afcc73f
+SIZE (sekrit-twc-zimg-release-3.0.1_GH0.tar.gz) = 326304
diff --git a/graphics/sekrit-twc-zimg/files/patch-neon b/graphics/sekrit-twc-zimg/files/patch-neon
new file mode 100644
index 000000000000..48fac8f35f8a
--- /dev/null
+++ b/graphics/sekrit-twc-zimg/files/patch-neon
@@ -0,0 +1,33 @@
+Detect NEON and VFPv4 on armv7
+
+--- src/zimg/common/arm/cpuinfo_arm.cpp.orig 2020-08-23 13:47:57 UTC
++++ src/zimg/common/arm/cpuinfo_arm.cpp
+@@ -8,6 +8,19 @@
+ #elif defined(__linux__)
+ #include <sys/auxv.h>
+ #include <asm/hwcap.h>
++#elif defined(__FreeBSD__)
++ #include <sys/auxv.h>
++ static unsigned long getauxval(unsigned long type)
++ {
++ /* Only AT_HWCAP* return unsigned long */
++ if (type != AT_HWCAP && type != AT_HWCAP2) {
++ return 0;
++ }
++
++ unsigned long ret = 0;
++ elf_aux_info(type, &ret, sizeof(ret));
++ return ret;
++ }
+ #endif
+
+ #include "cpuinfo_arm.h"
+@@ -28,7 +41,7 @@ ARMCapabilities do_query_arm_capabilities() noexcept
+ #elif defined(_WIN32)
+ caps.neon = IsProcessorFeaturePresent(PF_ARM_NEON_INSTRUCTIONS_AVAILABLE);
+ caps.vfpv4 = IsProcessorFeaturePresent(PF_ARM_FMAC_INSTRUCTIONS_AVAILABLE);
+-#elif defined(__linux__)
++#elif defined(__linux__) || defined(__FreeBSD__)
+ long hwcaps = getauxval(AT_HWCAP);
+ caps.neon = !!(hwcaps & HWCAP_NEON);
+ caps.vfpv4 = !!(hwcaps & HWCAP_VFPv4);
diff --git a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
index ad28dec4d3d8..f176ab6b0344 100644
--- a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
+++ b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
@@ -1,6 +1,6 @@
---- Makefile.am.orig 2017-12-21 02:35:58 UTC
+--- Makefile.am.orig 2020-08-23 13:47:57 UTC
+++ Makefile.am
-@@ -314,8 +313,7 @@ test_unit_test_CPPFLAGS = \
+@@ -357,8 +357,7 @@ test_unit_test_CPPFLAGS = \
$(AM_CPPFLAGS) \
-I$(srcdir)/src/zimg \
-I$(srcdir)/test \
@@ -10,7 +10,7 @@
test_unit_test_SOURCES = \
test/main.cpp \
-@@ -324,9 +322,6 @@ test_unit_test_SOURCES = \
+@@ -367,9 +366,6 @@ test_unit_test_SOURCES = \
test/colorspace/gamma_test.cpp \
test/depth/depth_convert_test.cpp \
test/depth/dither_test.cpp \
@@ -19,24 +19,27 @@
- test/extra/sha1/sha1.h \
test/graph/audit_buffer.cpp \
test/graph/audit_buffer.h \
- test/graph/copy_filter_test.cpp \
-@@ -368,7 +363,7 @@ test_unit_test_SOURCES += \
- endif # X86SIMD_AVX512
+ test/graph/filter_validator.cpp \
+@@ -426,7 +422,7 @@ test/extra/googletest/build/lib/libgtest.a: .FAKE
+ .FAKE:
test_unit_test_LDADD = \
-- test/extra/googletest/googletest/lib/libgtest.la \
+- test/extra/googletest/build/lib/libgtest.a \
+ -lgtest -lmd -lpthread \
test/libmusl_m.la \
libzimg_internal.la
endif # UNIT_TEST
---- configure.ac.orig 2016-05-08 20:08:38 UTC
+--- configure.ac.orig 2020-08-23 13:47:57 UTC
+++ configure.ac
-@@ -30,8 +30,6 @@ AS_IF([test "x$enable_unit_test" = "xyes
- [i?86], [CFLAGS="$CFLAGS -mfpmath=sse -msse2" CXXFLAGS="$CXXFLAGS -mfpmath=sse -msse2"],
- [x86_64], [],
+@@ -45,11 +45,6 @@ AS_IF([test "x$enable_unit_test" = "xyes"],
+ [i?86], [CFLAGS="$CFLAGS -mfpmath=sse -msse2" CXXFLAGS="$CXXFLAGS -mfpmath=sse -msse2"],
+ [x86_64], [],
[AC_MSG_WARN([Could not determine how to enable IEEE-754 compliance on host. Tests may fail.])])
-- AC_CONFIG_SUBDIRS(test/extra/googletest/googletest)
-- AC_SUBST([CONFIG_SUBDIRS], [test/extra/googletest/googletest])
+-
+- AC_CHECK_PROG([CMAKE], [cmake], [cmake])
+- AS_MKDIR_P([test/extra/googletest/build])
+- AS_IF([(cd "test/extra/googletest/build" && $CMAKE -Dgtest_disable_pthreads=ON "$ac_abs_confdir/test/extra/googletest")],
+- [], [AC_MSG_ERROR([CMake error])])
])