aboutsummaryrefslogtreecommitdiff
path: root/graphics/shotwell
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2013-05-21 02:12:51 +0000
committerDavid Thiel <lx@FreeBSD.org>2013-05-21 02:12:51 +0000
commit8bf216ae2f5f1582c1b841f724ff9907e1aac9f4 (patch)
tree6188b9e4bd2406b1a5d6f7a4686508beec56a55d /graphics/shotwell
parent3f7ce9f4c7159606933074dc449add42a4888258 (diff)
downloadports-8bf216ae2f5f1582c1b841f724ff9907e1aac9f4.tar.gz
ports-8bf216ae2f5f1582c1b841f724ff9907e1aac9f4.zip
Unbreak build.
PR: ports/177913 Submitted by: KATO Tsuguru
Notes
Notes: svn path=/head/; revision=318636
Diffstat (limited to 'graphics/shotwell')
-rw-r--r--graphics/shotwell/Makefile9
-rw-r--r--graphics/shotwell/files/patch-src__Dialogs.vala20
-rw-r--r--graphics/shotwell/files/patch-src__DirectoryMonitor.vala22
-rw-r--r--graphics/shotwell/files/patch-src__EditingTools.vala32
-rw-r--r--graphics/shotwell/files/patch-src__Photo.vala129
-rw-r--r--graphics/shotwell/files/patch-src__Printing.vala38
-rw-r--r--graphics/shotwell/files/patch-src__VideoSupport.vala32
-rw-r--r--graphics/shotwell/files/patch-src__db__PhotoTable.vala22
-rw-r--r--graphics/shotwell/files/patch-src__sidebar__Tree.vala22
-rw-r--r--graphics/shotwell/files/patch-src__util__file.vala12
10 files changed, 336 insertions, 2 deletions
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 6d9a4d4bc789..d867cd84643c 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -13,8 +13,7 @@ COMMENT= Open source photo manager for GNOME
LICENSE= LGPL21
BUILD_DEPENDS= vala>=0.12.0:${PORTSDIR}/lang/vala
-LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
gee:${PORTSDIR}/devel/libgee06 \
json-glib-1.0:${PORTSDIR}/devel/json-glib \
soup-2.4:${PORTSDIR}/devel/libsoup \
@@ -28,6 +27,7 @@ LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
USE_BZIP2= yes
USES= gettext
USE_GNOME= gnomehier gconf2 gtk20 desktopfileutils librsvg2
+USE_SQLITE= 3
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
@@ -47,12 +47,17 @@ post-patch:
post-configure:
@${REINPLACE_CMD} -E \
-e 's|share/shotwell|${DATADIR_REL}|g ; \
+ s|--fatal-warnings||g ; \
s|%%GCONF_CONFIG_SOURCE%%|${GCONF_CONFIG_SOURCE}|g' \
${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -E \
-e 's|\-n ||g' \
${WRKSRC}/configure.mk
+
+ @${REINPLACE_CMD} -E \
+ -e 's|--fatal-warnings||g' \
+ ${WRKSRC}/plugins/Makefile.plugin.mk
# attempt at a DATADIR safe port
@${REINPLACE_CMD} -E \
-e 's|\.get_child\("share")\.get_child\("shotwell")|${SHOTWELL_DATADIR}|' \
diff --git a/graphics/shotwell/files/patch-src__Dialogs.vala b/graphics/shotwell/files/patch-src__Dialogs.vala
new file mode 100644
index 000000000000..bc6caede23ea
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__Dialogs.vala
@@ -0,0 +1,20 @@
+--- src/Dialogs.vala.orig
++++ src/Dialogs.vala
+@@ -419,7 +419,7 @@
+ ok_button.sensitive = (pixels_entry.get_text_length() > 0) && (int.parse(pixels_entry.get_text()) > 0);
+ }
+
+- private void on_pixels_insert_text(string text, int length, void *position) {
++ private void on_pixels_insert_text(string text, int length, ref int position) {
+ // This is necessary because SignalHandler.block_by_func() is not properly bound
+ if (in_insert)
+ return;
+@@ -438,7 +438,7 @@
+ }
+
+ if (new_text.length > 0)
+- pixels_entry.insert_text(new_text, (int) new_text.length, position);
++ pixels_entry.insert_text(new_text, (int) new_text.length, ref position);
+
+ Signal.stop_emission_by_name(pixels_entry, "insert-text");
+
diff --git a/graphics/shotwell/files/patch-src__DirectoryMonitor.vala b/graphics/shotwell/files/patch-src__DirectoryMonitor.vala
new file mode 100644
index 000000000000..aadc50c2fde3
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__DirectoryMonitor.vala
@@ -0,0 +1,22 @@
+--- src/DirectoryMonitor.vala.orig
++++ src/DirectoryMonitor.vala
+@@ -276,8 +276,7 @@
+
+ // get all the interesting matchable items from the supplied FileInfo
+ int64 match_size = match.get_size();
+- TimeVal match_time;
+- match.get_modification_time(out match_time);
++ TimeVal match_time = match.get_modification_time();
+
+ foreach (File file in map.keys) {
+ FileInfo info = map.get(file);
+@@ -290,8 +289,7 @@
+ if (match_size != info.get_size())
+ continue;
+
+- TimeVal time;
+- info.get_modification_time(out time);
++ TimeVal time = info.get_modification_time();
+
+ if (time.tv_sec != match_time.tv_sec)
+ continue;
diff --git a/graphics/shotwell/files/patch-src__EditingTools.vala b/graphics/shotwell/files/patch-src__EditingTools.vala
new file mode 100644
index 000000000000..4c2dc2e5a7ff
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__EditingTools.vala
@@ -0,0 +1,32 @@
+--- src/EditingTools.vala.orig
++++ src/EditingTools.vala
+@@ -773,15 +773,15 @@
+ return false;
+ }
+
+- private void on_width_insert_text(string text, int length, void *position) {
+- on_entry_insert_text(crop_tool_window.custom_width_entry, text, length, position);
++ private void on_width_insert_text(string text, int length, ref int position) {
++ on_entry_insert_text(crop_tool_window.custom_width_entry, text, length, ref position);
+ }
+
+- private void on_height_insert_text(string text, int length, void *position) {
+- on_entry_insert_text(crop_tool_window.custom_height_entry, text, length, position);
++ private void on_height_insert_text(string text, int length, ref int position) {
++ on_entry_insert_text(crop_tool_window.custom_height_entry, text, length, ref position);
+ }
+
+- private void on_entry_insert_text(Gtk.Entry sender, string text, int length, void *position) {
++ private void on_entry_insert_text(Gtk.Entry sender, string text, int length, ref int position) {
+ if (entry_insert_in_progress)
+ return;
+
+@@ -799,7 +799,7 @@
+ }
+
+ if (new_text.length > 0)
+- sender.insert_text(new_text, (int) new_text.length, position);
++ sender.insert_text(new_text, (int) new_text.length, ref position);
+
+ Signal.stop_emission_by_name(sender, "insert-text");
+
diff --git a/graphics/shotwell/files/patch-src__Photo.vala b/graphics/shotwell/files/patch-src__Photo.vala
new file mode 100644
index 000000000000..a02f96da22d0
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__Photo.vala
@@ -0,0 +1,129 @@
+--- src/Photo.vala.orig
++++ src/Photo.vala
+@@ -273,7 +273,7 @@
+ }
+ }
+
+- private struct BackingReaders {
++ private class BackingReaders {
+ public PhotoFileReader master;
+ public PhotoFileReader developer;
+ public PhotoFileReader editable;
+@@ -281,9 +281,9 @@
+
+ // because fetching individual items from the database is high-overhead, store all of
+ // the photo row in memory
+- private PhotoRow row;
++ protected PhotoRow row;
+ private BackingPhotoRow editable = new BackingPhotoRow();
+- private BackingReaders readers = BackingReaders();
++ private BackingReaders readers = new BackingReaders();
+ private PixelTransformer transformer = null;
+ private PixelTransformationBundle adjustments = null;
+ // because file_title is determined by data in row, it should only be accessed when row is locked
+@@ -301,7 +301,7 @@
+
+ // This pointer is used to determine which BackingPhotoRow in the PhotoRow to be using at
+ // any time. It should only be accessed -- read or write -- when row is locked.
+- private BackingPhotoRow? backing_photo_row = null;
++ protected BackingPhotoRow? backing_photo_row = null;
+
+ // This is fired when the photo's editable file is replaced. The image it generates may or
+ // may not be the same; the altered signal is best for that. null is passed if the editable
+@@ -553,8 +553,7 @@
+ File file = File.new_for_path(bpr.filepath);
+ FileInfo info = file.query_info(DirectoryMonitor.SUPPLIED_ATTRIBUTES,
+ FileQueryInfoFlags.NOFOLLOW_SYMLINKS, null);
+- TimeVal timestamp;
+- info.get_modification_time(out timestamp);
++ TimeVal timestamp = info.get_modification_time();
+
+ PhotoFileInterrogator interrogator = new PhotoFileInterrogator(
+ file, PhotoFileSniffer.Options.GET_ALL);
+@@ -992,8 +991,7 @@
+ return ImportResult.UNSUPPORTED_FORMAT;
+ }
+
+- TimeVal timestamp;
+- info.get_modification_time(out timestamp);
++ TimeVal timestamp = info.get_modification_time();
+
+ // if all MD5s supplied, don't sniff for them
+ if (params.exif_md5 != null && params.thumbnail_md5 != null && params.full_md5 != null)
+@@ -1148,8 +1146,7 @@
+ return null;
+ }
+
+- TimeVal modification_time = TimeVal();
+- info.get_modification_time(out modification_time);
++ TimeVal modification_time = info.get_modification_time();
+
+ backing.filepath = file.get_path();
+ backing.timestamp = modification_time.tv_sec;
+@@ -1196,7 +1193,7 @@
+ }
+
+ private class ReimportRawDevelopmentStateImpl : ReimportRawDevelopmentState {
+- class DevToReimport {
++ public class DevToReimport {
+ public BackingPhotoRow backing = new BackingPhotoRow();
+ public PhotoMetadata? metadata;
+
+@@ -1483,8 +1480,7 @@
+
+ // Use this only if the master file's modification time has been changed (i.e. touched)
+ public void set_master_timestamp(FileInfo info) {
+- TimeVal modification;
+- info.get_modification_time(out modification);
++ TimeVal modification = info.get_modification_time();
+
+ try {
+ lock (row) {
+@@ -1508,8 +1504,7 @@
+
+ // Use this only if the editable file's modification time has been changed (i.e. touched)
+ public void update_editable_modification_time(FileInfo info) throws DatabaseError {
+- TimeVal modification;
+- info.get_modification_time(out modification);
++ TimeVal modification = info.get_modification_time();
+
+ bool altered = false;
+ lock (row) {
+@@ -2067,8 +2062,7 @@
+ error("Unable to read file information for %s: %s", to_string(), err.message);
+ }
+
+- TimeVal timestamp = TimeVal();
+- info.get_modification_time(out timestamp);
++ TimeVal timestamp = info.get_modification_time();
+
+ // interrogate file for photo information
+ PhotoFileInterrogator interrogator = new PhotoFileInterrogator(file);
+@@ -2679,7 +2673,7 @@
+ }
+
+ // All instances are against the coordinate system of the unrotated photo.
+- private void add_raw_redeye_instance(RedeyeInstance redeye) {
++ public void add_raw_redeye_instance(RedeyeInstance redeye) {
+ KeyValueMap map = get_transformation("redeye");
+ if (map == null) {
+ map = new KeyValueMap("redeye");
+@@ -3443,8 +3437,7 @@
+ return;
+ }
+
+- TimeVal timestamp;
+- info.get_modification_time(out timestamp);
++ TimeVal timestamp = info.get_modification_time();
+
+ BackingPhotoTable.get_instance().update_attributes(editable_id, timestamp.tv_sec,
+ info.get_size());
+@@ -4567,7 +4560,7 @@
+ import_keywords = null;
+ }
+
+- protected override void notify_altered(Alteration alteration) {
++ public override void notify_altered(Alteration alteration) {
+ // generate new thumbnails in the background
+ if (!block_thumbnail_generation && alteration.has_subject("image"))
+ thumbnail_scheduler.at_priority_idle(Priority.LOW);
diff --git a/graphics/shotwell/files/patch-src__Printing.vala b/graphics/shotwell/files/patch-src__Printing.vala
new file mode 100644
index 000000000000..a39971d3a3de
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__Printing.vala
@@ -0,0 +1,38 @@
+--- src/Printing.vala.orig
++++ src/Printing.vala
+@@ -536,7 +536,7 @@
+ }
+
+ private void on_ppi_entry_insert_text(Gtk.Editable editable, string text, int length,
+- void *position) {
++ ref int position) {
+ Gtk.Entry sender = (Gtk.Entry) editable;
+
+ if (is_text_insertion_in_progress)
+@@ -554,7 +554,7 @@
+ }
+
+ if (new_text.length > 0)
+- sender.insert_text(new_text, (int) new_text.length, position);
++ sender.insert_text(new_text, (int) new_text.length, ref position);
+
+ Signal.stop_emission_by_name(sender, "insert-text");
+
+@@ -616,7 +616,7 @@
+ return Measurement(double.parse(custom_height_entry.get_text()), get_user_unit_choice());
+ }
+
+- private void on_entry_insert_text(Gtk.Editable editable, string text, int length, void *position) {
++ private void on_entry_insert_text(Gtk.Editable editable, string text, int length, ref int position) {
+ Gtk.Entry sender = (Gtk.Entry) editable;
+
+ if (is_text_insertion_in_progress)
+@@ -640,7 +640,7 @@
+ }
+
+ if (new_text.length > 0)
+- sender.insert_text(new_text, (int) new_text.length, position);
++ sender.insert_text(new_text, (int) new_text.length, ref position);
+
+ Signal.stop_emission_by_name(sender, "insert-text");
+
diff --git a/graphics/shotwell/files/patch-src__VideoSupport.vala b/graphics/shotwell/files/patch-src__VideoSupport.vala
new file mode 100644
index 000000000000..d8a070f6b7b6
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__VideoSupport.vala
@@ -0,0 +1,32 @@
+--- src/VideoSupport.vala.orig
++++ src/VideoSupport.vala
+@@ -83,8 +83,7 @@
+ return ImportResult.UNSUPPORTED_FORMAT;
+ }
+
+- TimeVal timestamp;
+- info.get_modification_time(out timestamp);
++ TimeVal timestamp = info.get_modification_time();
+
+ // make sure params has a valid md5
+ assert(params.md5 != null);
+@@ -720,8 +719,7 @@
+ }
+
+ public void set_master_timestamp(FileInfo info) {
+- TimeVal time_val;
+- info.get_modification_time(out time_val);
++ TimeVal time_val = info.get_modification_time();
+
+ try {
+ lock (backing_row) {
+@@ -1068,8 +1066,7 @@
+ if (video.get_filesize() != info.get_size())
+ return;
+
+- TimeVal modification;
+- info.get_modification_time(out modification);
++ TimeVal modification = info.get_modification_time();
+
+ if (video.get_timestamp() == modification.tv_sec)
+ matching_master.add(video);
diff --git a/graphics/shotwell/files/patch-src__db__PhotoTable.vala b/graphics/shotwell/files/patch-src__db__PhotoTable.vala
new file mode 100644
index 000000000000..6ab92dd9c6c1
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__db__PhotoTable.vala
@@ -0,0 +1,22 @@
+--- src/db/PhotoTable.vala.orig
++++ src/db/PhotoTable.vala
+@@ -1034,8 +1034,7 @@
+ if (filesize != info.get_size())
+ return false;
+
+- TimeVal modification;
+- info.get_modification_time(out modification);
++ TimeVal modification = info.get_modification_time();
+
+ return timestamp == modification.tv_sec;
+ }
+@@ -1044,8 +1043,7 @@
+ if (filesize != info.get_size())
+ return false;
+
+- TimeVal modification;
+- info.get_modification_time(out modification);
++ TimeVal modification = info.get_modification_time();
+
+ return timestamp != modification.tv_sec;
+ }
diff --git a/graphics/shotwell/files/patch-src__sidebar__Tree.vala b/graphics/shotwell/files/patch-src__sidebar__Tree.vala
new file mode 100644
index 000000000000..93103a3d81cc
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__sidebar__Tree.vala
@@ -0,0 +1,22 @@
+--- src/sidebar/Tree.vala.orig
++++ src/sidebar/Tree.vala
+@@ -545,7 +545,8 @@
+ if (only_children)
+ return;
+
+- store.remove(wrapper.get_iter());
++ Gtk.TreeIter iter = wrapper.get_iter();
++ store.remove(ref iter);
+
+ if (selected_wrapper == wrapper)
+ selected_wrapper = null;
+@@ -637,7 +638,8 @@
+ bool selected = (get_current_path().compare(wrapper.get_path()) == 0);
+
+ // remove from current position in tree
+- store.remove(wrapper.get_iter());
++ Gtk.TreeIter iter = wrapper.get_iter();
++ store.remove(ref iter);
+
+ Sidebar.Entry? parent = branch.get_parent(entry);
+ assert(parent != null);
diff --git a/graphics/shotwell/files/patch-src__util__file.vala b/graphics/shotwell/files/patch-src__util__file.vala
new file mode 100644
index 000000000000..180d44ba78ce
--- /dev/null
+++ b/graphics/shotwell/files/patch-src__util__file.vala
@@ -0,0 +1,12 @@
+--- src/util/file.vala.orig
++++ src/util/file.vala
+@@ -155,8 +155,7 @@
+ FileInfo info = file.query_info(FILE_ATTRIBUTE_TIME_MODIFIED, FileQueryInfoFlags.NOFOLLOW_SYMLINKS,
+ null);
+
+- TimeVal timestamp = TimeVal();
+- info.get_modification_time(out timestamp);
++ TimeVal timestamp = info.get_modification_time();
+
+ return timestamp.tv_sec;
+ }