aboutsummaryrefslogtreecommitdiff
path: root/graphics/simage
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/simage
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'graphics/simage')
-rw-r--r--graphics/simage/Makefile3
-rw-r--r--graphics/simage/files/patch-simage_png.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/graphics/simage/Makefile b/graphics/simage/Makefile
index 8307ea4c11e5..6f3b1405bc30 100644
--- a/graphics/simage/Makefile
+++ b/graphics/simage/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simage
PORTVERSION= 1.7.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://ftp.coin3d.org/coin/src/all/
@@ -18,7 +19,7 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
jasper.4:${PORTSDIR}/graphics/jasper \
jpeg.11:${PORTSDIR}/graphics/jpeg \
gif.5:${PORTSDIR}/graphics/giflib \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool
diff --git a/graphics/simage/files/patch-simage_png.c b/graphics/simage/files/patch-simage_png.c
new file mode 100644
index 000000000000..b0dc15caad22
--- /dev/null
+++ b/graphics/simage/files/patch-simage_png.c
@@ -0,0 +1,11 @@
+--- src/simage_png.c.orig 2010-02-26 16:47:31.000000000 +0100
++++ src/simage_png.c 2012-05-05 07:44:14.000000000 +0200
+@@ -323,7 +323,7 @@
+ /* Set error handling. REQUIRED if you aren't supplying your own
+ * error hadnling functions in the png_create_write_struct() call.
+ */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* If we get here, we had a problem reading the file */
+ fclose(fp);
+ png_destroy_write_struct(&png_ptr, (png_infopp)info_ptr);