aboutsummaryrefslogtreecommitdiff
path: root/graphics/snx101util
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2005-01-08 15:44:03 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2005-01-08 15:44:03 +0000
commitf88eb7747972a05970308960221bccc834724b85 (patch)
tree5a7152bd220c5d728c1c8a631d25df1ea9d71d2e /graphics/snx101util
parentc510dbc5c37db11397d3d89968749119a63cf48b (diff)
downloadports-f88eb7747972a05970308960221bccc834724b85.tar.gz
ports-f88eb7747972a05970308960221bccc834724b85.zip
Add snx101util, image capture programs for Webcam based SN9C101
Notes
Notes: svn path=/head/; revision=125811
Diffstat (limited to 'graphics/snx101util')
-rw-r--r--graphics/snx101util/Makefile39
-rw-r--r--graphics/snx101util/distinfo2
-rw-r--r--graphics/snx101util/pkg-descr19
3 files changed, 60 insertions, 0 deletions
diff --git a/graphics/snx101util/Makefile b/graphics/snx101util/Makefile
new file mode 100644
index 000000000000..e262fa305dc0
--- /dev/null
+++ b/graphics/snx101util/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: snx101util
+# Date created: 23 November 2004
+# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snx101util
+PORTVERSION= 0.2
+CATEGORIES= graphics
+MASTER_SITES= http://www2.starcat.ne.jp/~takam/bsd/
+
+MAINTAINER= yoichi@FreeBSD.org
+COMMENT= Image capture programs for Webcam based SN9C101
+
+.if defined(WITHOUT_X11)
+COMPONENTS= snx101shot
+.else
+USE_GNOME= imlib gtk12
+COMPONENTS= snx101shot snx101view
+.endif
+
+MAN1= ${COMPONENTS:S/$/.1/}
+MANCOMPRESSED= yes
+PLIST_FILES= ${COMPONENTS:S/^/bin\//}
+
+MAKE_ARGS+= MANDIR=${MANPREFIX}/man/man
+
+do-build:
+.for component in ${COMPONENTS}
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} Makefile.${component} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
+
+do-install:
+.for component in ${COMPONENTS}
+ @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} Makefile.${component} ${MAKE_ARGS} ${INSTALL_TARGET})
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/snx101util/distinfo b/graphics/snx101util/distinfo
new file mode 100644
index 000000000000..f013866ef39e
--- /dev/null
+++ b/graphics/snx101util/distinfo
@@ -0,0 +1,2 @@
+MD5 (snx101util-0.2.tar.gz) = 75dfe859594f00cb2695f815a768fbaf
+SIZE (snx101util-0.2.tar.gz) = 9983
diff --git a/graphics/snx101util/pkg-descr b/graphics/snx101util/pkg-descr
new file mode 100644
index 000000000000..cc659f802220
--- /dev/null
+++ b/graphics/snx101util/pkg-descr
@@ -0,0 +1,19 @@
+ USB Webcam based sonix SN9C101 chip Utility Programs 0.2 for NetBSD/FreeBSD
+
+1. What is it?
+ They are image capture programs for Webcam based SN9C101 via ugen(4)
+ for NetBSD/FreeBSD.
+
+ snx101shot ... simple image capture program ( output stdout PPM file )
+ snx101view ... sequential image viewer program
+
+2. What is supported USB camera on SN9C101 ?
+
+ Vendor Device Product Name
+ ------ ------ ------------
+ 0x0c45 0x6005 Tama Electronic Corp. Z-102/Z-104
+ 0x0c45 0x6005 SWEEX USB Mini Webcam JA000030
+ 0x0c45 0x6005 V-Gear MiniCam2
+ 0x0c45 0x6005 (no name)
+
+WWW: http://www2.starcat.ne.jp/~takam/bsd/NetBSD.html#sonix