aboutsummaryrefslogtreecommitdiff
path: root/graphics/sswf
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2005-10-17 08:47:32 +0000
committerEric Anholt <anholt@FreeBSD.org>2005-10-17 08:47:32 +0000
commitc0039ba7ab9151b76e2492e4dcddb0c7f779e561 (patch)
treeea3e4805b826edb5ade4db573bab24c06d545315 /graphics/sswf
parentd4ef594a6c80a474a96065c2c8b3eb1b82a88a20 (diff)
downloadports-c0039ba7ab9151b76e2492e4dcddb0c7f779e561.tar.gz
ports-c0039ba7ab9151b76e2492e4dcddb0c7f779e561.zip
New port: sswf, a tool to build Flash animation files from sourcecode, including
support for ActionScript.
Notes
Notes: svn path=/head/; revision=145629
Diffstat (limited to 'graphics/sswf')
-rw-r--r--graphics/sswf/Makefile28
-rw-r--r--graphics/sswf/distinfo2
-rw-r--r--graphics/sswf/pkg-descr5
-rw-r--r--graphics/sswf/pkg-plist124
4 files changed, 159 insertions, 0 deletions
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
new file mode 100644
index 000000000000..b13e762c61b9
--- /dev/null
+++ b/graphics/sswf/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: sswf
+# Date created: Oct 17, 2005
+# Whom: anhot
+#
+# $FreeBSD$
+#
+
+PORTNAME= sswf
+PORTVERSION= 1.7.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sswf
+DISTNAME= sswf-${PORTVERSION}-src
+
+MAINTAINER= anholt@FreeBSD.org
+COMMENT= A library and script language tool to create Flash movies
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+WRKSRC= ${WRKDIR}/sswf-${PORTVERSION}
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/sswf/distinfo b/graphics/sswf/distinfo
new file mode 100644
index 000000000000..3d34df4d1d2b
--- /dev/null
+++ b/graphics/sswf/distinfo
@@ -0,0 +1,2 @@
+MD5 (sswf-1.7.2-src.tar.gz) = a17ea97605b4373ab5eebd6f44e8b844
+SIZE (sswf-1.7.2-src.tar.gz) = 2770842
diff --git a/graphics/sswf/pkg-descr b/graphics/sswf/pkg-descr
new file mode 100644
index 000000000000..902cd62c172d
--- /dev/null
+++ b/graphics/sswf/pkg-descr
@@ -0,0 +1,5 @@
+A C++ Library and a script language tool to create Flash (SWF) movies up to
+version 7. Supports nearly all the Macromedia Flash tags. Includes detailled
+docs and a tool to convert your system fonts to a Flash movie.
+
+WWW: http://sourceforge.net/projects/sswf
diff --git a/graphics/sswf/pkg-plist b/graphics/sswf/pkg-plist
new file mode 100644
index 000000000000..61c9e8b8d234
--- /dev/null
+++ b/graphics/sswf/pkg-plist
@@ -0,0 +1,124 @@
+bin/ft2sswf
+bin/sswf
+bin/swf_dump
+include/sswf/libsswf-config.h
+include/sswf/libsswf-version.h
+include/sswf/libsswf.h
+lib/libsswf-1.7.2.so
+lib/libsswf.a
+lib/libsswf.so
+%%DATADIR%%/AUTHORS.txt
+%%DATADIR%%/CHANGES.txt
+%%DATADIR%%/INSTALL-IRIX.txt
+%%DATADIR%%/INSTALL-MACOSX.txt
+%%DATADIR%%/INSTALL-RPM.txt
+%%DATADIR%%/INSTALL-SLACKWARE.txt
+%%DATADIR%%/INSTALL.txt
+%%DATADIR%%/LICENSE.txt
+%%DATADIR%%/LINKS.txt
+%%DATADIR%%/NOTES.txt
+%%DATADIR%%/TODO.txt
+%%DATADIR%%/samples/README.txt
+%%DATADIR%%/samples/check_version/makefile
+%%DATADIR%%/samples/check_version/version.c++
+%%DATADIR%%/samples/dyn-button/button.html
+%%DATADIR%%/samples/dyn-button/button.sswf
+%%DATADIR%%/samples/dyn-button/clicked.html
+%%DATADIR%%/samples/dyn-button/run
+%%DATADIR%%/samples/dyn-button/run.bat
+%%DATADIR%%/samples/functions/find-sswf.sh
+%%DATADIR%%/samples/lanuit-mp3/README.txt
+%%DATADIR%%/samples/lanuit-mp3/lanuit.html
+%%DATADIR%%/samples/lanuit-mp3/lanuit.mp3
+%%DATADIR%%/samples/lanuit-mp3/lanuit.sswf
+%%DATADIR%%/samples/lanuit-mp3/run
+%%DATADIR%%/samples/lanuit-mp3/run.bat
+%%DATADIR%%/samples/libya/LICENSE.txt
+%%DATADIR%%/samples/libya/akakus.html
+%%DATADIR%%/samples/libya/akakus_icon.tga
+%%DATADIR%%/samples/libya/albayda.html
+%%DATADIR%%/samples/libya/albayda_icon.tga
+%%DATADIR%%/samples/libya/ghadames.html
+%%DATADIR%%/samples/libya/ghadames_icon.tga
+%%DATADIR%%/samples/libya/gharyan.html
+%%DATADIR%%/samples/libya/gharyan_icon.tga
+%%DATADIR%%/samples/libya/ghat.html
+%%DATADIR%%/samples/libya/ghat_icon.tga
+%%DATADIR%%/samples/libya/leptis.html
+%%DATADIR%%/samples/libya/leptis_icon.tga
+%%DATADIR%%/samples/libya/libya.html
+%%DATADIR%%/samples/libya/libya.sswf
+%%DATADIR%%/samples/libya/libya_map.tga
+%%DATADIR%%/samples/libya/libya_map_mask.tga
+%%DATADIR%%/samples/libya/morzuk.html
+%%DATADIR%%/samples/libya/morzuk_icon.tga
+%%DATADIR%%/samples/libya/pack
+%%DATADIR%%/samples/libya/run
+%%DATADIR%%/samples/libya/run.bat
+%%DATADIR%%/samples/libya/sabratha.html
+%%DATADIR%%/samples/libya/sabratha_icon.tga
+%%DATADIR%%/samples/libya/tokra.html
+%%DATADIR%%/samples/libya/tokra_icon.tga
+%%DATADIR%%/samples/libya/tripoli.html
+%%DATADIR%%/samples/libya/tripoli_icon.tga
+%%DATADIR%%/samples/logo/logo.html
+%%DATADIR%%/samples/logo/logo.png
+%%DATADIR%%/samples/logo/logo.sswf
+%%DATADIR%%/samples/logo/run
+%%DATADIR%%/samples/logo/run.bat
+%%DATADIR%%/samples/morph/morph.html
+%%DATADIR%%/samples/morph/morph.sswf
+%%DATADIR%%/samples/morph/run
+%%DATADIR%%/samples/morph/run.bat
+%%DATADIR%%/samples/new-anim/new.html
+%%DATADIR%%/samples/new-anim/new.sswf
+%%DATADIR%%/samples/new-anim/run
+%%DATADIR%%/samples/new-anim/run.bat
+%%DATADIR%%/samples/news-samples/bounce.c++
+%%DATADIR%%/samples/news-samples/bounce.html
+%%DATADIR%%/samples/news-samples/icon.png
+%%DATADIR%%/samples/news-samples/makefile
+%%DATADIR%%/samples/news-samples/morph.c++
+%%DATADIR%%/samples/news-samples/morph.html
+%%DATADIR%%/samples/news-samples/news.html
+%%DATADIR%%/samples/news-samples/once.c++
+%%DATADIR%%/samples/news-samples/once.html
+%%DATADIR%%/samples/news-samples/rotate.c++
+%%DATADIR%%/samples/news-samples/rotate.html
+%%DATADIR%%/samples/news-samples/script.c++
+%%DATADIR%%/samples/news-samples/script.html
+%%DATADIR%%/samples/news-samples/simple.c++
+%%DATADIR%%/samples/news-samples/simple.html
+%%DATADIR%%/samples/news-samples/sprite.c++
+%%DATADIR%%/samples/news-samples/sprite.html
+%%DATADIR%%/samples/news-samples/typescript
+%%DATADIR%%/samples/scroller/run
+%%DATADIR%%/samples/scroller/run.bat
+%%DATADIR%%/samples/scroller/scroller.html
+%%DATADIR%%/samples/scroller/scroller.sswf
+%%DATADIR%%/samples/showfont/README.txt
+%%DATADIR%%/samples/showfont/amakefile
+%%DATADIR%%/samples/showfont/showfont.c++
+%%DATADIR%%/samples/showfont/showfont.tsswf
+%%DATADIR%%/samples/showfont/showfont.xhtml
+%%DATADIR%%/samples/sun-flower/run
+%%DATADIR%%/samples/sun-flower/run.bat
+%%DATADIR%%/samples/sun-flower/sun_flower.html
+%%DATADIR%%/samples/sun-flower/sun_flower.jpg
+%%DATADIR%%/samples/sun-flower/sun_flower.sswf
+%%DATADIR%%/samples/sun-flower/sun_flower_mask.tga
+%%DATADIR%%/samples/trail/run
+%%DATADIR%%/samples/trail/run.bat
+%%DATADIR%%/samples/trail/trail.html
+%%DATADIR%%/samples/trail/trail.sswf
+%%DATADIR%%/samples/web-site-anim/anim.html
+%%DATADIR%%/samples/web-site-anim/anim.sswf
+%%DATADIR%%/samples/web-site-anim/run
+%%DATADIR%%/samples/web-site-anim/run.bat
+%%DATADIR%%/samples/web-site-anim/sswf.wav
+%%DATADIR%%/scripts/colors.sswf
+%%DATADIR%%/scripts/flags.sswf
+%%DATADIR%%/scripts/fonts/font-blue_highway-condensed.sswf
+%%DATADIR%%/scripts/fonts/font-fotinos.sswf
+%%DATADIR%%/scripts/fonts/larabie-font_read_me.txt
+%%DATADIR%%/scripts/origin.sswf