aboutsummaryrefslogtreecommitdiff
path: root/graphics/structuresynth
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-07 17:37:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-07 17:37:55 +0000
commit7b6791190c2ee47f58b1209b529259d1ab705538 (patch)
tree1657cbaae1099d7bd40eb6bccdd4609e41862974 /graphics/structuresynth
parentef04b8cf9f1175c90c4a4330e5e586599af54ae2 (diff)
downloadports-7b6791190c2ee47f58b1209b529259d1ab705538.tar.gz
ports-7b6791190c2ee47f58b1209b529259d1ab705538.zip
- Update to 1.0.0
Notes
Notes: svn path=/head/; revision=239094
Diffstat (limited to 'graphics/structuresynth')
-rw-r--r--graphics/structuresynth/Makefile29
-rw-r--r--graphics/structuresynth/distinfo6
-rw-r--r--graphics/structuresynth/pkg-plist32
3 files changed, 45 insertions, 22 deletions
diff --git a/graphics/structuresynth/Makefile b/graphics/structuresynth/Makefile
index a3240338b87f..eaf64576671d 100644
--- a/graphics/structuresynth/Makefile
+++ b/graphics/structuresynth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= structuresynth
-PORTVERSION= 0.9.0
+PORTVERSION= 1.0.0
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= StructureSynth-Source-v${PORTVERSION}
@@ -17,11 +17,12 @@ COMMENT= Rule-based 3D structure generator
USE_ZIP= yes
USE_QT_VER= 4
QT_COMPONENTS= qmake_build corelib gui opengl moc_build rcc_build xml script
-
-WRKSRC= ${WRKDIR}/structuresynth
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/structure-synth
post-extract:
- @${MV} ${WRKDIR}/"Structure Synth Source" ${WRKDIR}/structuresynth
+ @${MV} "${WRKDIR}/Structure Synth Source Code" ${WRKSRC}
+ @${RM} -rf ${WRKSRC}/Examples/DontDeploy
post-patch:
@${REINPLACE_CMD} -e '/examplesDir/ s|"Examples"|"${DATADIR}/Examples"|; \
@@ -29,16 +30,18 @@ post-patch:
${WRKSRC}/StructureSynth/GUI/MainWindow.cpp
do-configure:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -project
- @${ECHO_CMD} "QT+=opengl xml script" >> ${WRKSRC}/structuresynth.pro
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
- -spec ${QMAKESPEC} structuresynth.pro
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} -project \
+ -after "CONFIG+=opengl" -after "QT+=xml opengl script"
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/structuresynth ${PREFIX}/bin/${PORTNAME}
- ${MKDIR} ${DATADIR}/Examples
- ${INSTALL_DATA} ${WRKSRC}/Examples/*.es ${DATADIR}/Examples
- ${MKDIR} ${DATADIR}/Misc
- ${INSTALL_DATA} ${WRKSRC}/Misc/* ${DATADIR}/Misc
+ ${INSTALL_PROGRAM} ${WRKSRC}/structure-synth ${PREFIX}/bin/
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "Examples Misc" ${DATADIR}/
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/structure-synth.desktop \
+ ${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/images/fileicons/StructureSynth-256.png \
+ ${PREFIX}/share/pixmaps/structure-synth.png
.include <bsd.port.mk>
diff --git a/graphics/structuresynth/distinfo b/graphics/structuresynth/distinfo
index 295005dae5bc..386c3448eff3 100644
--- a/graphics/structuresynth/distinfo
+++ b/graphics/structuresynth/distinfo
@@ -1,3 +1,3 @@
-MD5 (StructureSynth-Source-v0.9.0.zip) = f8bcbbaf8d8f2a53ac4aa088205bd7a1
-SHA256 (StructureSynth-Source-v0.9.0.zip) = 63a3d331a69ad619493407a43902cd4ff8e1dfdf50e6bff99995d2683ceef4b2
-SIZE (StructureSynth-Source-v0.9.0.zip) = 1321829
+MD5 (StructureSynth-Source-v1.0.0.zip) = eb0d727aeced8bc7b671c2dc3e903bca
+SHA256 (StructureSynth-Source-v1.0.0.zip) = 6d3460a10e8a99e62799dc60e3b14d55355312c52920f391916a090551829916
+SIZE (StructureSynth-Source-v1.0.0.zip) = 1888000
diff --git a/graphics/structuresynth/pkg-plist b/graphics/structuresynth/pkg-plist
index 2888824f298a..57ddd13357ad 100644
--- a/graphics/structuresynth/pkg-plist
+++ b/graphics/structuresynth/pkg-plist
@@ -1,33 +1,53 @@
-bin/structuresynth
+bin/structure-synth
+share/applications/structure-synth.desktop
+share/pixmaps/structure-synth.png
%%DATADIR%%/Examples/Arc Sphere.es
%%DATADIR%%/Examples/Ball.es
%%DATADIR%%/Examples/BinaryKite.es
-%%DATADIR%%/Examples/Boxes II.es
+%%DATADIR%%/Examples/CSG test.es
%%DATADIR%%/Examples/City of Glass.es
%%DATADIR%%/Examples/Default.es
%%DATADIR%%/Examples/Frame In Frame.es
%%DATADIR%%/Examples/Grinder.es
-%%DATADIR%%/Examples/Invader.es
%%DATADIR%%/Examples/Jugend2D.es
%%DATADIR%%/Examples/Menger.es
%%DATADIR%%/Examples/MeshTest.es
%%DATADIR%%/Examples/Mondrian.es
%%DATADIR%%/Examples/Nabla.es
+%%DATADIR%%/Examples/NablaSystem.es
+%%DATADIR%%/Examples/NineWorthies.es
+%%DATADIR%%/Examples/Nouveau.es
+%%DATADIR%%/Examples/Nouveau2.es
%%DATADIR%%/Examples/Octopod II.es
%%DATADIR%%/Examples/RoundTree.es
%%DATADIR%%/Examples/SpiralTree2D.es
+%%DATADIR%%/Examples/Thingy.es
%%DATADIR%%/Examples/Torus2.es
%%DATADIR%%/Examples/Torus3.es
%%DATADIR%%/Examples/Trees 3d.es
%%DATADIR%%/Examples/Tube.es
+%%DATADIR%%/Examples/Tutorials/Blend.es
+%%DATADIR%%/Examples/Tutorials/Preprocessor.es
+%%DATADIR%%/Examples/Tutorials/PreprocessorGUI.es
+%%DATADIR%%/Examples/Tutorials/Primitives.es
+%%DATADIR%%/Examples/Tutorials/RandomColor.es
+%%DATADIR%%/Examples/Tutorials/TriangleComposites.es
+%%DATADIR%%/Misc/Blender_Importer_2.py
+%%DATADIR%%/Misc/Blender_Importer_2.rendertemplate
+%%DATADIR%%/Misc/SunFlow-Monochrome.rendertemplate
+%%DATADIR%%/Misc/Sunflow-Colored.rendertemplate
+%%DATADIR%%/Misc/Sunflow-Meta-Neon22.rendertemplate
+%%DATADIR%%/Misc/Sunflow-Textured.rendertemplate
+%%DATADIR%%/Misc/Sunflow-Ultimate-Groovelock.rendertemplate
+%%DATADIR%%/Misc/Sunflow-Ward.rendertemplate
%%DATADIR%%/Misc/about.html
%%DATADIR%%/Misc/icon.jpg
%%DATADIR%%/Misc/povray.rendertemplate
+%%DATADIR%%/Misc/povray2.rendertemplate
%%DATADIR%%/Misc/renderman.rendertemplate
%%DATADIR%%/Misc/splash.png
-%%DATADIR%%/Misc/sunflow.rendertemplate
-%%DATADIR%%/Misc/sunflowcolored.rendertemplate
-%%DATADIR%%/Misc/sunflowmulticolored.rendertemplate
@dirrm %%DATADIR%%/Misc
+@dirrm %%DATADIR%%/Examples/Tutorials
@dirrm %%DATADIR%%/Examples
@dirrm %%DATADIR%%
+@dirrmtry share/applications