aboutsummaryrefslogtreecommitdiff
path: root/graphics/swftools
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:55:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:55:44 +0000
commit6cc631883a260588d850147a5b631638906e4aa1 (patch)
treee57b4e1212d9428053d0e7c7c096ba555fa8e197 /graphics/swftools
parent75629ba61351dc6d045a65f57ffc9e3301db56b2 (diff)
downloadports-6cc631883a260588d850147a5b631638906e4aa1.tar.gz
ports-6cc631883a260588d850147a5b631638906e4aa1.zip
Update to version 0.6.2
PR: ports/72530 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=119001
Diffstat (limited to 'graphics/swftools')
-rw-r--r--graphics/swftools/Makefile33
-rw-r--r--graphics/swftools/distinfo4
-rw-r--r--graphics/swftools/files/patch-configure76
-rw-r--r--graphics/swftools/files/patch-lib::modules::swffont.c12
4 files changed, 24 insertions, 101 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index b7ec7c261ea5..894b14ff4c96 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= swftools
-PORTVERSION= 0.6.1
+PORTVERSION= 0.6.2
CATEGORIES= graphics
MASTER_SITES= http://www.quiss.org/swftools/
@@ -17,26 +17,37 @@ COMMENT= SWF manipulation and generation utilities
LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
t1.5:${PORTSDIR}/devel/t1lib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- freetype.9:${PORTSDIR}/print/freetype2
-
-FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
USE_REINPLACE= yes
USE_BISON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- FREETYPE_CONFIG="${FREETYPE_CONFIG}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+MAN1= font2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 swfbbox.1 swfc.1 \
+ swfcombine.1 swfdump.1 swfextract.1 swfstrings.1 wav2swf.1
-MAN1= font2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 swfbbox.1 swfc.1 \
- swfcombine.1 swfdump.1 swfextract.1 swfstrings.1 wav2swf.1
+CPPFLAGS= `pkg-config --cflags-only-I fontconfig freetype2` \
+ -I${LOCALBASE}/include
+LDFLAGS= `pkg-config --libs-only-L fontconfig freetype2` \
+ -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's| -O | |g ; \
s|/usr/local/include|${LOCALBASE}/include|g ; \
- s|/usr/local/lib|${LOCALBASE}/lib|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|;make|;\$$\(MAKE\)|g' ${WRKSRC}/lib/Makefile.in
+ s|/usr/local/lib|${LOCALBASE}/lib|g ; \
+ s|HAVE_FONTCONFIG_H|HAVE_FONTCONFIG_FONTCONFIG_H|g ; \
+ s| fontconfig\.h| fontconfig/fontconfig.h|g ; \
+ s|<fontconfig\.h>|<fontconfig/fontconfig.h>|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|HAVE_FONTCONFIG_H|HAVE_FONTCONFIG_FONTCONFIG_H|g' ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} -e \
+ 's|;make|;\$$\(MAKE\)|g' ${WRKSRC}/lib/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|HAVE_FONTCONFIG_H|HAVE_FONTCONFIG_FONTCONFIG_H|g ; \
+ s|<fontconfig\.h>|<fontconfig/fontconfig.h>|g' ${WRKSRC}/pdf2swf/SWFOutputDev.cc
.include <bsd.port.mk>
diff --git a/graphics/swftools/distinfo b/graphics/swftools/distinfo
index bd3151666265..78cbc3a1d0ca 100644
--- a/graphics/swftools/distinfo
+++ b/graphics/swftools/distinfo
@@ -1,2 +1,2 @@
-MD5 (swftools-0.6.1.tar.gz) = ed12cdf72deed5b67fc2dc64b9f5330a
-SIZE (swftools-0.6.1.tar.gz) = 1410115
+MD5 (swftools-0.6.2.tar.gz) = 40286d8fac4c3b03e3a009d27d41f1ae
+SIZE (swftools-0.6.2.tar.gz) = 1482362
diff --git a/graphics/swftools/files/patch-configure b/graphics/swftools/files/patch-configure
deleted file mode 100644
index 7efa27f1f142..000000000000
--- a/graphics/swftools/files/patch-configure
+++ /dev/null
@@ -1,76 +0,0 @@
---- configure.orig Sat Aug 21 03:34:59 2004
-+++ configure Sat Aug 21 12:46:50 2004
-@@ -10247,7 +10247,7 @@
- fi
-
-
--for ac_header in freetype/freetype.h
-+for ac_header in ft2build.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
-@@ -10413,45 +10413,26 @@
- echo $ECHO_N "checking whether we can compile the freetype test program... $ECHO_C" >&6
-
- cat > conftest.c << EOF
--#include <freetype/freetype.h>
--#include <freetype/ftglyph.h>
--#include <freetype/ftsnames.h>
--#include <freetype/ttnameid.h>
--#include <freetype/ftoutln.h>
--
--int main()
--{
-- FT_Library ftlibrary;
-- FT_Face face;
-- FT_Error error;
-- FT_ULong charcode;
-- FT_UInt gindex;
-- FT_Glyph glyph;
-- FT_BBox bbox;
-- FT_Matrix matrix;
-- FT_UInt i;
-- char* name = 0;
-- char italic, bold;
--
-- FT_Init_FreeType(&ftlibrary);
-- FT_New_Face(ftlibrary, "filename", 0, &face);
-- i = face->num_glyphs - 1;
-- italic = face->style_flags&FT_STYLE_FLAG_ITALIC;
-- bold = face->style_flags&FT_STYLE_FLAG_BOLD;
-- FT_Get_Postscript_Name(face);
-- FT_Get_Char_Index(face, 33);
-- FT_Get_First_Char(face, &i);
-- FT_Get_Next_Char(face, 33, &i);
-- if(FT_HAS_GLYPH_NAMES(face)) {
-- FT_Get_Glyph_Name(face, 33, name, 127);
-- }
-- FT_Load_Glyph(face, 33, FT_LOAD_NO_BITMAP|FT_LOAD_NO_SCALE);
-- FT_Get_Glyph(face->glyph, &glyph);
-- FT_Glyph_Get_CBox(glyph, ft_glyph_bbox_unscaled, &bbox);
-- FT_Done_Glyph(glyph);
-- FT_Done_Face(face);
-- FT_Done_FreeType(ftlibrary);
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
-+#include <stdio.h>
-+#include <stdlib.h>
-+
-+int
-+main()
-+{
-+ FT_Library library;
-+ FT_Error error;
-+
-+ error = FT_Init_FreeType(&library);
-+
-+ if (error)
-+ return 1;
-+ else
-+ {
-+ FT_Done_FreeType(library);
- return 0;
-+ }
- }
- EOF
-
diff --git a/graphics/swftools/files/patch-lib::modules::swffont.c b/graphics/swftools/files/patch-lib::modules::swffont.c
deleted file mode 100644
index 52c486195be9..000000000000
--- a/graphics/swftools/files/patch-lib::modules::swffont.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib/modules/swffont.c.orig Sat Aug 14 16:19:02 2004
-+++ lib/modules/swffont.c Sun Aug 15 02:16:02 2004
-@@ -32,7 +32,8 @@
-
- #ifdef HAVE_FREETYPE
-
--#include <freetype/freetype.h>
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
- #include <freetype/ftglyph.h>
- #include <freetype/ftsizes.h>
- #include <freetype/ftsnames.h>