aboutsummaryrefslogtreecommitdiff
path: root/graphics/synfigstudio
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2018-01-09 15:11:09 +0000
committerBen Woods <woodsb02@FreeBSD.org>2018-01-09 15:11:09 +0000
commita483e05641d8cd5f53782ab97419c982638aa34e (patch)
tree8de67bf49659e773838e5326904cd5e9e5746791 /graphics/synfigstudio
parentcc3174aef26fa049860b2eb710f1b44b040273e3 (diff)
downloadports-a483e05641d8cd5f53782ab97419c982638aa34e.tar.gz
ports-a483e05641d8cd5f53782ab97419c982638aa34e.zip
graphics/synfigstudio: Unbreak build
Reported by: Ian Trudel <ian.trudel@gmail.com>
Notes
Notes: svn path=/head/; revision=458532
Diffstat (limited to 'graphics/synfigstudio')
-rw-r--r--graphics/synfigstudio/Makefile40
1 files changed, 35 insertions, 5 deletions
diff --git a/graphics/synfigstudio/Makefile b/graphics/synfigstudio/Makefile
index d827223393c3..b02a4e1a6e52 100644
--- a/graphics/synfigstudio/Makefile
+++ b/graphics/synfigstudio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= synfigstudio
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics multimedia
MASTER_SITES= SF/synfig/releases/${PORTVERSION}/source
@@ -12,10 +12,6 @@ COMMENT= Vector-based 2D animation software package
LICENSE= GPLv2+
-BROKEN= missing header
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2018-01-27
-
BUILD_DEPENDS= etl>=0.04.19_1:devel/etl
LIB_DEPENDS= libsynfig.so:devel/synfig
RUN_DEPENDS= xdg-open:devel/xdg-utils
@@ -56,6 +52,40 @@ post-patch:
s|sk_SK|sk| ; \
s|sv_SE|sv|' \
${WRKSRC}/po/LINGUAS
+ @${REINPLACE_CMD} -e \
+ 's|^#include <sigc++/hide.h>$$|#include <sigc++/sigc++.h>| ; \
+ s|^#include <sigc++/object.h>$$|#include <sigc++/sigc++.h>| ; \
+ s|^#include <sigc++/retype.h>$$|#include <sigc++/sigc++.h>|' \
+ ${WRKSRC}/src/gui/canvasview.cpp \
+ ${WRKSRC}/src/gui/compview.cpp \
+ ${WRKSRC}/src/gui/docks/dock_children.cpp \
+ ${WRKSRC}/src/gui/docks/dock_curves.cpp \
+ ${WRKSRC}/src/gui/docks/dock_history.cpp \
+ ${WRKSRC}/src/gui/docks/dock_keyframes.cpp \
+ ${WRKSRC}/src/gui/docks/dock_layergroups.cpp \
+ ${WRKSRC}/src/gui/docks/dock_layers.cpp \
+ ${WRKSRC}/src/gui/docks/dock_metadata.cpp \
+ ${WRKSRC}/src/gui/docks/dock_params.cpp \
+ ${WRKSRC}/src/gui/docks/dock_timetrack.cpp \
+ ${WRKSRC}/src/gui/docks/dock_toolbox.cpp \
+ ${WRKSRC}/src/gui/docks/dockable.cpp \
+ ${WRKSRC}/src/gui/docks/dockdialog.cpp \
+ ${WRKSRC}/src/gui/docks/dockmanager.h \
+ ${WRKSRC}/src/gui/duck.h \
+ ${WRKSRC}/src/gui/duckmatic.cpp \
+ ${WRKSRC}/src/gui/duckmatic.h \
+ ${WRKSRC}/src/gui/instance.cpp \
+ ${WRKSRC}/src/gui/instance.h \
+ ${WRKSRC}/src/gui/states/state_stroke.h \
+ ${WRKSRC}/src/gui/states/state_zoom.cpp \
+ ${WRKSRC}/src/gui/widgets/widget_curves.cpp \
+ ${WRKSRC}/src/gui/workarea.cpp \
+ ${WRKSRC}/src/gui/workarearenderer/workarearenderer.h \
+ ${WRKSRC}/src/synfigapp/action_system.h \
+ ${WRKSRC}/src/synfigapp/canvasinterface.h \
+ ${WRKSRC}/src/synfigapp/instance.h \
+ ${WRKSRC}/src/synfigapp/main.h \
+ ${WRKSRC}/src/synfigapp/uimanager.h
pre-build:
# FIX LC_MESSAGES