aboutsummaryrefslogtreecommitdiff
path: root/graphics/telak
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-06-16 10:00:35 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-06-16 10:00:35 +0000
commitea34d2a2e751de635cbf0bd9032dac11fd5b5503 (patch)
tree79f1449d99c46d8092637575a816d6af59f9e930 /graphics/telak
parenta3eb7d8c56afff29cea8afbc3acc8ba077bf6f95 (diff)
downloadports-ea34d2a2e751de635cbf0bd9032dac11fd5b5503.tar.gz
ports-ea34d2a2e751de635cbf0bd9032dac11fd5b5503.zip
Update to 0.5
Notes
Notes: svn path=/head/; revision=165556
Diffstat (limited to 'graphics/telak')
-rw-r--r--graphics/telak/Makefile7
-rw-r--r--graphics/telak/distinfo6
-rw-r--r--graphics/telak/files/patch-Makefile6
-rw-r--r--graphics/telak/files/patch-parse.c10
-rw-r--r--graphics/telak/files/patch-telak.c18
5 files changed, 10 insertions, 37 deletions
diff --git a/graphics/telak/Makefile b/graphics/telak/Makefile
index 91ae45ae7e4a..c6efc7cba8a4 100644
--- a/graphics/telak/Makefile
+++ b/graphics/telak/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= telak
-PORTVERSION= 0.4
+PORTVERSION= 0.5
CATEGORIES= graphics
-MASTER_SITES= http://critical.ch/distfiles/ \
+MASTER_SITES= http://julien.danjou.info/telak/ \
+ http://critical.ch/distfiles/ \
http://energy.critical.ch/distfiles/
MAINTAINER= ehaupt@FreeBSD.org
@@ -23,7 +24,7 @@ USE_X_PREFIX= yes
USE_GETOPT_LONG=yes
ALL_TARGET= ${PORTNAME}
-MAKE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV= CC="${CC}" LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/telak
MAN1= telak.1
diff --git a/graphics/telak/distinfo b/graphics/telak/distinfo
index 9cab1e4e8936..5ff5d077cbf6 100644
--- a/graphics/telak/distinfo
+++ b/graphics/telak/distinfo
@@ -1,3 +1,3 @@
-MD5 (telak-0.4.tar.gz) = ab8d56f191d3c5215a04af846c32c575
-SHA256 (telak-0.4.tar.gz) = 5772280ae078a0d055726d18fe13af3c047a2c1f17e7f14fc255dfb870be96e5
-SIZE (telak-0.4.tar.gz) = 13975
+MD5 (telak-0.5.tar.gz) = f952b8f51ad5b0f57b6fa000e2dc66bb
+SHA256 (telak-0.5.tar.gz) = aaa98bc9866348cb3e66337aa3aad2e6492f48f9bd57a658eb0e0df74e1a6687
+SIZE (telak-0.5.tar.gz) = 18269
diff --git a/graphics/telak/files/patch-Makefile b/graphics/telak/files/patch-Makefile
index 165b2982d37b..d57c258bfbaa 100644
--- a/graphics/telak/files/patch-Makefile
+++ b/graphics/telak/files/patch-Makefile
@@ -1,9 +1,9 @@
---- Makefile.orig Thu Apr 28 22:15:06 2005
-+++ Makefile Wed Sep 14 01:04:46 2005
+--- Makefile.orig Tue Jun 6 20:23:36 2006
++++ Makefile Fri Jun 16 10:59:49 2006
@@ -1,8 +1,8 @@
VERSION = $(shell grep '^Version' ChangeLog | head -n 1 | cut -d' ' -f2 | tr -d ' ')
BIN = telak
- O = telak.o fetch.o image.o parse.o
+ O = telak.o fetch.o image.o parse.o toon.o
-LDFLAGS = $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt
-CFLAGS = -W -Wall $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\"" -g
+LDFLAGS += -L$(LOCALBASE)/lib $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt
diff --git a/graphics/telak/files/patch-parse.c b/graphics/telak/files/patch-parse.c
deleted file mode 100644
index 83ae83b7f700..000000000000
--- a/graphics/telak/files/patch-parse.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- parse.c.orig Tue Sep 13 22:05:22 2005
-+++ parse.c Tue Sep 13 22:05:39 2005
-@@ -17,6 +17,7 @@
- #include <sys/types.h>
- #include <pwd.h>
- #include <time.h>
-+#include <sys/time.h>
-
- #include "telak.h"
- #include "image.h"
diff --git a/graphics/telak/files/patch-telak.c b/graphics/telak/files/patch-telak.c
deleted file mode 100644
index e1fa7f367c6d..000000000000
--- a/graphics/telak/files/patch-telak.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- telak.c.orig Wed Sep 14 01:08:51 2005
-+++ telak.c Wed Sep 14 01:08:52 2005
-@@ -91,7 +91,6 @@
- Atom SWM_VROOT = XInternAtom(display, "__SWM_VROOT", False);
- Atom NAUTILUS_DESKTOP_WINDOW_ID =
- XInternAtom(display, "NAUTILUS_DESKTOP_WINDOW_ID", False);
-- win = DefaultRootWindow(display);
-
- Window unused, *windows = 0;
- unsigned int count;
-@@ -101,6 +100,7 @@
- unsigned long nitems, bytes_after_return;
- unsigned char *virtual_root_window;
-
-+ win = DefaultRootWindow(display);
- if(XGetWindowProperty(display, win, NAUTILUS_DESKTOP_WINDOW_ID,
- 0, 1, False, XA_WINDOW, &type, &format,
- &nitems, &bytes_after_return,