aboutsummaryrefslogtreecommitdiff
path: root/graphics/tif22pnm
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-07 12:53:49 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-07 12:53:49 +0000
commit11a219d683957f81de8e7bdca68f5764e4df1993 (patch)
tree2cea44bafa04180cda65b59430ff0235c680d86e /graphics/tif22pnm
parentf98ceafb151bab97b4ccf6b08ccff64b3ac934fa (diff)
downloadports-11a219d683957f81de8e7bdca68f5764e4df1993.tar.gz
ports-11a219d683957f81de8e7bdca68f5764e4df1993.zip
add tif22pnm 0.06
Converts TIFF- sampled images to PNM image
Notes
Notes: svn path=/head/; revision=72689
Diffstat (limited to 'graphics/tif22pnm')
-rw-r--r--graphics/tif22pnm/Makefile30
-rw-r--r--graphics/tif22pnm/distinfo1
-rw-r--r--graphics/tif22pnm/pkg-comment1
-rw-r--r--graphics/tif22pnm/pkg-descr4
-rw-r--r--graphics/tif22pnm/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
new file mode 100644
index 000000000000..b06be320867b
--- /dev/null
+++ b/graphics/tif22pnm/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: tif22pnm
+# Date created: Jan 7, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tif22pnm
+PORTVERSION= 0.06
+CATEGORIES= graphics
+MASTER_SITES= http://www.inf.bme.hu/~pts/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libtiff-ldir=${LOCALBASE}/lib \
+ --with-libtiff-idir=${LOCALBASE}/include
+
+do-build:
+ @(cd ${WRKSRC} ; ${LOCALBASE}/bin/bash do.sh compile)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tif22pnm ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/tif22pnm/distinfo b/graphics/tif22pnm/distinfo
new file mode 100644
index 000000000000..f7269239ea79
--- /dev/null
+++ b/graphics/tif22pnm/distinfo
@@ -0,0 +1 @@
+MD5 (tif22pnm-0.06.tar.gz) = b2ddae1e8aecd05a9f4276c4dc162a67
diff --git a/graphics/tif22pnm/pkg-comment b/graphics/tif22pnm/pkg-comment
new file mode 100644
index 000000000000..6aaa7ea8d1b3
--- /dev/null
+++ b/graphics/tif22pnm/pkg-comment
@@ -0,0 +1 @@
+Converts TIFF- sampled images to PNM image
diff --git a/graphics/tif22pnm/pkg-descr b/graphics/tif22pnm/pkg-descr
new file mode 100644
index 000000000000..4a746eadc13b
--- /dev/null
+++ b/graphics/tif22pnm/pkg-descr
@@ -0,0 +1,4 @@
+tif22pnm is a commandline utility that converts TIFF- sampled images to PNM
+images, using the libtiff library, but not using NetPBM. It is similar to
+tifftopnm utility in the NetPBM distribution, but handles a wider range of
+TIFF files and is able to output the alpha channel as a PBM or PGM file.
diff --git a/graphics/tif22pnm/pkg-plist b/graphics/tif22pnm/pkg-plist
new file mode 100644
index 000000000000..934973e2c0bd
--- /dev/null
+++ b/graphics/tif22pnm/pkg-plist
@@ -0,0 +1 @@
+bin/tif22pnm