aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiff/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-12-01 07:49:16 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-12-01 07:49:16 +0000
commit56706af05f4908e8a68297e0a857b416cb277cc5 (patch)
tree58e384fd07cefff04dd7a6e13d1688ce8e6e1ff6 /graphics/tiff/Makefile
parent1946179601238645a2e1ade35bcfadb45616cc8a (diff)
downloadports-56706af05f4908e8a68297e0a857b416cb277cc5.tar.gz
ports-56706af05f4908e8a68297e0a857b416cb277cc5.zip
Decouple tiff and tiff34. tiff34 now installs its headers into
${PREFIX}/include/tiff34, it no longer renames them.
Notes
Notes: svn path=/head/; revision=8924
Diffstat (limited to 'graphics/tiff/Makefile')
-rw-r--r--graphics/tiff/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index 1f4b2b61e646..7f17ec4f4498 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -1,19 +1,13 @@
-# New ports collection makefile for: tiff34
-# Version required: 3.4beta35
+# New ports collection makefile for: tiff
+# Version required: 3.4
# Date created: 8 October 1996
# Whom: Richard Hwang <rhwang@bigpanda.com>
# Mikhail Teterin <mi@aldan.ziplink.net>
# Jun-ichiro itojun Itoh <itojun@itojun.org>
#
-# $Id: Makefile,v 1.3 1997/05/26 02:16:32 asami Exp $
+# $Id: Makefile,v 1.4 1997/11/05 09:34:56 tg Exp $
#
-# NOTE:
-# To get rid of rumored incompatibility between libtiff3.3 and 3.4
-# (can somebody confirm it?) installation will be done as libtiff34.a,
-# not libtiff.a. The port is made so that there's no overwrite
-# for headers, libraries, and documents. (there may be overwrite of manuals)
-
DISTNAME= tiff-v3.4
PKGNAME= tiff-3.4
CATEGORIES= graphics
@@ -25,10 +19,10 @@ MAINTAINER= itojun@itojun.org
LIB_DEPENDS= jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg
-WRKSRC= ${WRKDIR}/tiff-v3.4
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-ZIP --with-JPEG --with-DIR_BIN=${PREFIX}/bin \
- --with-DIR_LIB=${PREFIX}/lib --with-DIR_INC=${PREFIX}/include \
+ --with-DIR_LIB=${PREFIX}/lib \
+ --with-DIR_INC=${PREFIX}/include/tiff34 \
--with-CC="${CC}" --with-GCOPTS="${CFLAGS}" \
--with-DIRS_LIBINC=${PREFIX}/include \
--with-DIR_GZLIB=/usr/lib \
@@ -66,7 +60,7 @@ MAN3= TIFFCheckTile.3t TIFFClose.3t TIFFComputeStrip.3t TIFFComputeTile.3t \
TIFFmemset.3t TIFFquery.3t TIFFrealloc.3t TIFFsize.3t TIFFstrip.3t \
TIFFswab.3t TIFFtile.3t libtiff.3t
-DOCDIR= ${PREFIX}/share/doc/tiff34
+DOCDIR= ${PREFIX}/share/doc/tiff
post-install:
.if !defined(NOPORTDOCS)
@@ -74,7 +68,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/html/*.html ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/html/images/* ${DOCDIR}/images
.endif
- perl -pi -e 's/\"tiff.h\"/\"tiff34\.h\"/g;' ${PREFIX}/include/tiffio34.h
${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>