aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-06-26 18:41:49 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-06-26 18:41:49 +0000
commitadcbbbb487369db73e77ac4c5ea8332295578356 (patch)
tree568175ec328e1cc486ff05d785aeafc94227b94f /graphics/tiff
parent180681de13492718524f9997c32ae16d881ba563 (diff)
downloadports-adcbbbb487369db73e77ac4c5ea8332295578356.tar.gz
ports-adcbbbb487369db73e77ac4c5ea8332295578356.zip
Update to 4.0.4
Notes
Notes: svn path=/head/; revision=390660
Diffstat (limited to 'graphics/tiff')
-rw-r--r--graphics/tiff/Makefile3
-rw-r--r--graphics/tiff/distinfo4
-rw-r--r--graphics/tiff/files/patch-Makefile.in8
-rw-r--r--graphics/tiff/files/patch-tools_tiffdither.c70
-rw-r--r--graphics/tiff/pkg-plist5
5 files changed, 10 insertions, 80 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index da6c5ae5b0c4..5409fa1b5fe9 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tiff
-DISTVERSION= 4.0.4beta
-PORTREVISION= 1
+PORTVERSION= 4.0.4
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
http://download.osgeo.org/libtiff/
diff --git a/graphics/tiff/distinfo b/graphics/tiff/distinfo
index cc4f307cad91..878f27151352 100644
--- a/graphics/tiff/distinfo
+++ b/graphics/tiff/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tiff-4.0.4beta.tar.gz) = 5bd6c8e9be4ec318f6beb0c3f28b9ee31bd8b615195a00e0acc3eb5d08b26c1b
-SIZE (tiff-4.0.4beta.tar.gz) = 2098962
+SHA256 (tiff-4.0.4.tar.gz) = 8cb1d90c96f61cdfc0bcf036acc251c9dbe6320334da941c7a83cfe1576ef890
+SIZE (tiff-4.0.4.tar.gz) = 2100766
diff --git a/graphics/tiff/files/patch-Makefile.in b/graphics/tiff/files/patch-Makefile.in
index f055fcd7e404..3e417c6525a4 100644
--- a/graphics/tiff/files/patch-Makefile.in
+++ b/graphics/tiff/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2012-09-22 18:08:18.000000000 +0200
-+++ Makefile.in 2012-10-13 19:35:28.000000000 +0200
-@@ -375,7 +375,7 @@
+--- Makefile.in.orig 2015-06-21 19:07:53 UTC
++++ Makefile.in
+@@ -434,7 +434,7 @@ EXTRA_DIST = \
dist_doc_DATA = $(docfiles)
SUBDIRS = port libtiff tools build contrib test man html
@@ -9,7 +9,7 @@
pkgconfig_DATA = libtiff-4.pc
all: all-recursive
-@@ -427,19 +427,6 @@
+@@ -485,19 +485,6 @@ distclean-libtool:
-rm -f libtool config.lt
install-dist_docDATA: $(dist_doc_DATA)
@$(NORMAL_INSTALL)
diff --git a/graphics/tiff/files/patch-tools_tiffdither.c b/graphics/tiff/files/patch-tools_tiffdither.c
deleted file mode 100644
index fc8b4d5bb989..000000000000
--- a/graphics/tiff/files/patch-tools_tiffdither.c
+++ /dev/null
@@ -1,70 +0,0 @@
---- tools/tiffdither.c.orig 2013-05-02 14:44:29 UTC
-+++ tools/tiffdither.c
-@@ -39,6 +39,7 @@
- #endif
-
- #include "tiffio.h"
-+#include "tiffiop.h"
-
- #define streq(a,b) (strcmp(a,b) == 0)
- #define strneq(a,b,n) (strncmp(a,b,n) == 0)
-@@ -56,7 +57,7 @@ static void usage(void);
- * Floyd-Steinberg error propragation with threshold.
- * This code is stolen from tiffmedian.
- */
--static void
-+static int
- fsdither(TIFF* in, TIFF* out)
- {
- unsigned char *outline, *inputline, *inptr;
-@@ -68,14 +69,19 @@ fsdither(TIFF* in, TIFF* out)
- int lastline, lastpixel;
- int bit;
- tsize_t outlinesize;
-+ int errcode = 0;
-
- imax = imagelength - 1;
- jmax = imagewidth - 1;
- inputline = (unsigned char *)_TIFFmalloc(TIFFScanlineSize(in));
-- thisline = (short *)_TIFFmalloc(imagewidth * sizeof (short));
-- nextline = (short *)_TIFFmalloc(imagewidth * sizeof (short));
-+ thisline = (short *)_TIFFmalloc(TIFFSafeMultiply(tmsize_t, imagewidth, sizeof (short)));
-+ nextline = (short *)_TIFFmalloc(TIFFSafeMultiply(tmsize_t, imagewidth, sizeof (short)));
- outlinesize = TIFFScanlineSize(out);
- outline = (unsigned char *) _TIFFmalloc(outlinesize);
-+ if (! (inputline && thisline && nextline && outline)) {
-+ fprintf(stderr, "Out of memory.\n");
-+ goto skip_on_error;
-+ }
-
- /*
- * Get first line
-@@ -93,7 +99,7 @@ fsdither(TIFF* in, TIFF* out)
- nextline = tmpptr;
- lastline = (i == imax);
- if (TIFFReadScanline(in, inputline, i, 0) <= 0)
-- break;
-+ goto skip_on_error;
- inptr = inputline;
- nextptr = nextline;
- for (j = 0; j < imagewidth; ++j)
-@@ -131,13 +137,18 @@ fsdither(TIFF* in, TIFF* out)
- }
- }
- if (TIFFWriteScanline(out, outline, i-1, 0) < 0)
-- break;
-+ goto skip_on_error;
- }
-+ goto exit_label;
-+
- skip_on_error:
-+ errcode = 1;
-+ exit_label:
- _TIFFfree(inputline);
- _TIFFfree(thisline);
- _TIFFfree(nextline);
- _TIFFfree(outline);
-+ return errcode;
- }
-
- static uint16 compression = COMPRESSION_PACKBITS;
diff --git a/graphics/tiff/pkg-plist b/graphics/tiff/pkg-plist
index 34d7d5f216d7..2f30ad389b40 100644
--- a/graphics/tiff/pkg-plist
+++ b/graphics/tiff/pkg-plist
@@ -30,11 +30,11 @@ lib/libtiff.a
lib/libtiff.so
lib/libtiff.so.4
lib/libtiff.so.5
-lib/libtiff.so.5.2.1
+lib/libtiff.so.5.2.2
lib/libtiffxx.a
lib/libtiffxx.so
lib/libtiffxx.so.5
-lib/libtiffxx.so.5.2.1
+lib/libtiffxx.so.5.2.2
libdata/pkgconfig/libtiff-4.pc
man/man1/bmp2tiff.1.gz
man/man1/fax2ps.1.gz
@@ -302,4 +302,5 @@ man/man3/libtiff.3tiff.gz
%%PORTDOCS%%%%DOCSDIR%%/v4.0.1.html
%%PORTDOCS%%%%DOCSDIR%%/v4.0.2.html
%%PORTDOCS%%%%DOCSDIR%%/v4.0.3.html
+%%PORTDOCS%%%%DOCSDIR%%/v4.0.4.html
%%PORTDOCS%%%%DOCSDIR%%/v4.0.4beta.html