aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiffgt/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-02 05:29:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-02 05:30:31 +0000
commitb87a50522c7292380dacc26591e535ea6591234e (patch)
tree1cfab2c66737f80c79074337fe0a7cca7004ca97 /graphics/tiffgt/Makefile
parent5ad25e88592d312a76159538a85469195a41bbc8 (diff)
downloadports-b87a50522c7292380dacc26591e535ea6591234e.tar.gz
ports-b87a50522c7292380dacc26591e535ea6591234e.zip
graphics/tiffgt: Update version 4.3.0=>4.4.0
Diffstat (limited to 'graphics/tiffgt/Makefile')
-rw-r--r--graphics/tiffgt/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/graphics/tiffgt/Makefile b/graphics/tiffgt/Makefile
index b29f215690e3..7e7e798dc328 100644
--- a/graphics/tiffgt/Makefile
+++ b/graphics/tiffgt/Makefile
@@ -1,6 +1,5 @@
PORTNAME= tiffgt
-DISTVERSION= 4.3.0
-PORTREVISION= 1
+DISTVERSION= 4.4.0
CATEGORIES= graphics
MASTER_SITES= https://download.osgeo.org/libtiff/
DISTNAME= tiff-${DISTVERSION}
@@ -20,13 +19,17 @@ USES= cpe gl jpeg libtool pathfix xorg
CPE_PRODUCT= libtiff
CPE_VERSION= ${DISTVERSION:C/[a-z]+//}
CPE_UPDATE= ${DISTVERSION:C/[0-9.]+//}
-USE_XORG= sm ice xmu xi x11
-USE_GL= glut glu gl
+USE_GL= gl glu glut
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
+USE_XORG= ice sm x11 xi xmu
+
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-jpeg-include-dir=${LOCALBASE}/include \
- --with-jpeg-lib-dir=${LOCALBASE}/lib --with-x
-PLIST_FILES= bin/tiffgt man/man1/tiffgt.1.gz
+ --with-jpeg-lib-dir=${LOCALBASE}/lib \
+ --with-x
+
+PLIST_FILES= bin/tiffgt \
+ man/man1/tiffgt.1.gz
pre-configure:
${REINPLACE_CMD} -e 's|^docfiles|no-docfiles|' \