aboutsummaryrefslogtreecommitdiff
path: root/graphics/timg/Makefile
diff options
context:
space:
mode:
authorZsolt Udvari <uzsolt@uzsolt.hu>2023-07-23 17:04:28 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-07-24 11:31:22 +0000
commita3001778c69f01b8a8317ee28d9cc4480aabaecc (patch)
tree680c3a745e647f912202829e98bdc71c514800d3 /graphics/timg/Makefile
parentf4ca272a1e429660e9389d493f4a3eb77e7c420c (diff)
downloadports-a3001778c69f01b8a8317ee28d9cc4480aabaecc.tar.gz
ports-a3001778c69f01b8a8317ee28d9cc4480aabaecc.zip
graphics/timg: update to 1.5.1
ChangeLog: https://github.com/hzeller/timg/releases/tag/v1.5.1 PR: 272677 Reported by: uzsolt@uzsolt.hu (maintainer)
Diffstat (limited to 'graphics/timg/Makefile')
-rw-r--r--graphics/timg/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/timg/Makefile b/graphics/timg/Makefile
index 7d272909fd26..359f529acda3 100644
--- a/graphics/timg/Makefile
+++ b/graphics/timg/Makefile
@@ -1,7 +1,6 @@
PORTNAME= timg
-PORTVERSION= 1.4.5
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+DISTVERSION= 1.5.1
CATEGORIES= graphics
MAINTAINER= uzsolt@uzsolt.hu
@@ -9,13 +8,16 @@ COMMENT= Terminal Image and Video Viewer
WWW= https://github.com/hzeller/timg
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= pkgconf>0:devel/pkgconf \
ffmpeg>0:multimedia/ffmpeg
LIB_DEPENDS= libavutil.so:multimedia/ffmpeg \
+ libdeflate.so:archivers/libdeflate \
libexif.so:graphics/libexif \
libGraphicsMagick.so:graphics/GraphicsMagick \
libpng.so:graphics/png \
+ libsixel.so:graphics/libsixel \
libturbojpeg.so:graphics/libjpeg-turbo
USES= cmake compiler:c++11-lang
@@ -24,8 +26,8 @@ GH_ACCOUNT= hzeller
# timg requires libavutil, contained in multimedia/ffmpeg
# isn't splitted libavcodec, libavutil, etc.
-CMAKE_ON+= WITH_VIDEO_DECODING WITH_VIDEO_DEVICE
-CMAKE_OFF+= TIMG_VERSION_FROM_GIT WITH_OPENSLIDE_SUPPORT
+CMAKE_ON= WITH_VIDEO_DECODING WITH_VIDEO_DEVICE
+CMAKE_OFF= TIMG_VERSION_FROM_GIT WITH_OPENSLIDE_SUPPORT
PLIST_FILES= bin/timg share/man/man1/timg.1.gz