aboutsummaryrefslogtreecommitdiff
path: root/graphics/urt/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2013-01-21 03:31:56 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2013-01-21 03:31:56 +0000
commit94e79576fb3fd5c3ee23528447c8e3b86ebb0732 (patch)
tree1ca61ccecdef07dc319d9d8b9554b16d9042628e /graphics/urt/Makefile
parent3abe9dab550a0f91677a4f61aaf1b6dc52acd906 (diff)
downloadports-94e79576fb3fd5c3ee23528447c8e3b86ebb0732.tar.gz
ports-94e79576fb3fd5c3ee23528447c8e3b86ebb0732.zip
- Fix build with clang.
- Add MAKE_JOBS_SAFE. - Trim header. - Convert to optionsNG. PR: ports/172717 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=310738
Diffstat (limited to 'graphics/urt/Makefile')
-rw-r--r--graphics/urt/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/graphics/urt/Makefile b/graphics/urt/Makefile
index d50e361d5007..37b78d1f8d02 100644
--- a/graphics/urt/Makefile
+++ b/graphics/urt/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: urt
-# Date created: Jan 5 1997
-# Whom: cfs@ing.puc.cl (original)
-#
+# Created by: cfs@ing.puc.cl (original)
# $FreeBSD$
-#
PORTNAME= urt
PORTVERSION= 3.1b1
@@ -20,19 +16,21 @@ PATCH_DIST_STRIP=-p1
MAINTAINER= ports@FreeBSD.org
COMMENT= Toolkit and library for raster image processing
-LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
+LIB_DEPENDS= netpbm:${PORTSDIR}/graphics/netpbm
+
+OPTIONS_DEFINE= DOCS EXAMPLES
NO_WRKSUBDIR= yes
-USE_GCC= any
USE_XORG= x11 xext
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
CONFIGURE_ARGS= config/urt
-MAKEFILE= makefile
USE_GMAKE= yes
+MAKEFILE= makefile
ALL_TARGET= # none
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
MAN1= aliastorle.1 applymap.1 avg4.1 crop.1 cubitorle.1 dvirle.1 \
fant.1 getx11.1 giftorle.1 graytorle.1 into.1 mcut.1 mergechan.1\
@@ -61,14 +59,16 @@ MAN3= buildmap.3 bwdithermap.3 colorquant.3 dither.3 ditherbw.3 \
MAN5= rle.5
MLINKS= rle.5 RLE.5
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKDIR}/doc && ${FIND} . | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKDIR} && ${FIND} img | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}/img
+ @(cd ${WRKSRC}/img && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/img)
.endif
.include <bsd.port.mk>