aboutsummaryrefslogtreecommitdiff
path: root/graphics/vapoursynth-fmtconv
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-12-11 21:23:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-12-11 21:23:26 +0000
commit706df85f38f05cd715cee2b2863b74f7fd5636fa (patch)
tree3f96b23ca6ba5254d9d9489e457fd06a3f85699c /graphics/vapoursynth-fmtconv
parentaf6431718f7f3878a4eca21f455fa76ad2dbf393 (diff)
downloadports-706df85f38f05cd715cee2b2863b74f7fd5636fa.tar.gz
ports-706df85f38f05cd715cee2b2863b74f7fd5636fa.zip
graphics/vapoursynth-fmtconv: update to r22
Changes: https://github.com/EleonoreMizo/fmtconv/releases/tag/r22 Reported by: GitHub (watch releases)
Notes
Notes: svn path=/head/; revision=519841
Diffstat (limited to 'graphics/vapoursynth-fmtconv')
-rw-r--r--graphics/vapoursynth-fmtconv/Makefile9
-rw-r--r--graphics/vapoursynth-fmtconv/distinfo6
-rw-r--r--graphics/vapoursynth-fmtconv/files/patch-src_conc_Interlocked.hpp63
3 files changed, 7 insertions, 71 deletions
diff --git a/graphics/vapoursynth-fmtconv/Makefile b/graphics/vapoursynth-fmtconv/Makefile
index d157b0e2f5e1..2a9af3ea8dea 100644
--- a/graphics/vapoursynth-fmtconv/Makefile
+++ b/graphics/vapoursynth-fmtconv/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fmtconv
-PORTVERSION= r21
+PORTVERSION= r22
CATEGORIES= graphics
PKGNAMEPREFIX= vapoursynth-
@@ -12,9 +12,6 @@ LICENSE= WTFPL
BUILD_DEPENDS= ${LOCALBASE}/include/vapoursynth/VapourSynth.h:multimedia/vapoursynth
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= https://github.com/EleonoreMizo/fmtconv/issues/8
-
USE_GITHUB= yes
GH_ACCOUNT= EleonoreMizo
@@ -37,7 +34,9 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's/x86_64/&|amd64/' \
${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e 's/-O3 //' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e 's/ -O3//' \
+ -e 's/ -latomic//' \
+ ${WRKSRC}/Makefile.am
post-install:
(cd ${PATCH_WRKSRC}/doc && ${COPYTREE_SHARE} \
diff --git a/graphics/vapoursynth-fmtconv/distinfo b/graphics/vapoursynth-fmtconv/distinfo
index 2a50ff35c415..61d69449e112 100644
--- a/graphics/vapoursynth-fmtconv/distinfo
+++ b/graphics/vapoursynth-fmtconv/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575810155
-SHA256 (EleonoreMizo-fmtconv-r21_GH0.tar.gz) = 0f6726b694f6e8c6d0330c91e68bb3136ddf2d2b53d4448cade9a73c3e3f8ce3
-SIZE (EleonoreMizo-fmtconv-r21_GH0.tar.gz) = 233543
+TIMESTAMP = 1576074577
+SHA256 (EleonoreMizo-fmtconv-r22_GH0.tar.gz) = 0b524b9e2ba9ebb8e5798265679daeef7bd9c568629b0c33d7b27a8a3a51c8f9
+SIZE (EleonoreMizo-fmtconv-r22_GH0.tar.gz) = 236034
diff --git a/graphics/vapoursynth-fmtconv/files/patch-src_conc_Interlocked.hpp b/graphics/vapoursynth-fmtconv/files/patch-src_conc_Interlocked.hpp
deleted file mode 100644
index bdb0048307b5..000000000000
--- a/graphics/vapoursynth-fmtconv/files/patch-src_conc_Interlocked.hpp
+++ /dev/null
@@ -1,63 +0,0 @@
-https://github.com/EleonoreMizo/fmtconv/pull/9
-
---- src/conc/Interlocked.hpp.orig 2016-03-25 15:06:59 UTC
-+++ src/conc/Interlocked.hpp
-@@ -100,10 +100,6 @@ int32_t Interlocked::cas (int32_t volatile &dest, int3
- ::LONG (comp)
- ));
-
--#elif defined (__linux__)
--
-- return (__sync_val_compare_and_swap (&dest, comp, excg));
--
- #elif defined (__APPLE__)
-
- return (::OSAtomicCompareAndSwap32Barrier (
-@@ -112,6 +108,10 @@ int32_t Interlocked::cas (int32_t volatile &dest, int3
- const_cast <int32_t *> (reinterpret_cast <int32_t volatile *> (&dest))
- ) ? comp : excg);
-
-+#elif defined (__GNUC__)
-+
-+ return (__sync_val_compare_and_swap (&dest, comp, excg));
-+
- #else
-
- #error Unknown platform
-@@ -214,10 +214,6 @@ int64_t Interlocked::cas (int64_t volatile &dest, int6
-
- return (old);
-
--#elif defined (__linux__)
--
-- return (__sync_val_compare_and_swap (&dest, comp, excg));
--
- #elif defined (__APPLE__)
-
- return (::OSAtomicCompareAndSwap64Barrier (
-@@ -226,6 +222,10 @@ int64_t Interlocked::cas (int64_t volatile &dest, int6
- const_cast <int64_t *> (reinterpret_cast <int64_t volatile *> (&dest))
- ) ? comp : excg);
-
-+#elif defined (__GNUC__)
-+
-+ return (__sync_val_compare_and_swap (&dest, comp, excg));
-+
- #else
-
- #error Unknown platform
-@@ -355,9 +355,13 @@ void Interlocked::cas (Data128 &old, volatile Data128
-
- #endif
-
--#elif defined (__linux__)
-+#elif defined (__GNUC__)
-
- old = __sync_val_compare_and_swap (&dest, comp, excg);
-+
-+#else
-+
-+ #error Unknown platform
-
- #endif
- }