aboutsummaryrefslogtreecommitdiff
path: root/graphics/vigra
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-08-17 16:27:24 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-08-17 16:27:24 +0000
commit41e60477bdfd199f4fa53ac14af9a86349cff50b (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /graphics/vigra
parentb60960981b1bb72f389b3e4f7f448117d4d07528 (diff)
downloadports-41e60477bdfd199f4fa53ac14af9a86349cff50b.tar.gz
ports-41e60477bdfd199f4fa53ac14af9a86349cff50b.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=324851
Diffstat (limited to 'graphics/vigra')
-rw-r--r--graphics/vigra/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index 8b10a591f3ac..eb17de357069 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -44,7 +44,7 @@ CMAKE_ARGS+= -DWITH_OPENEXR=0
.if ${PORT_OPTIONS:MNUMPY}
CONFLICTS_BUILD= python3*
CMAKE_ARGS+= -DWITH_VIGRANUMPY=1
-USE_GCC= 4.6+
+USE_GCC= yes
USE_FORTRAN= yes
USE_PYTHON= 2.6-2.7
BUILD_DEPENDS+= nosetests:${PORTSDIR}/devel/py-nose
@@ -92,8 +92,8 @@ pre-everything::
.if ${PORT_OPTIONS:MNUMPY}
@${ECHO} ""
@${ECHO} "* BEWARE!"
- @${ECHO} "* Using py-NumPY implies Fortran and GCC4.6+ as hard dependencies"
- @${ECHO} "* and require to all ports, depended on vigra, set USE_GCC=4.6+"
+ @${ECHO} "* Using py-NumPY implies Fortran and GCC 4.6+ as hard dependencies"
+ @${ECHO} "* and require all ports, depending on vigra, to set USE_GCC=yes"
@${ECHO} ""
.endif