aboutsummaryrefslogtreecommitdiff
path: root/graphics/vigra
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-06-01 17:09:31 +0000
committerDima Panov <fluffy@FreeBSD.org>2020-06-01 17:09:31 +0000
commitea91bcdb1eac6c02e5b078e8c04d6d584434a880 (patch)
treeba56fe0aa647ae94fdddcb019a2a9641168384ee /graphics/vigra
parentbef1fb5a4c0ef156ff51c4104fab351a3263ed98 (diff)
downloadports-ea91bcdb1eac6c02e5b078e8c04d6d584434a880.tar.gz
ports-ea91bcdb1eac6c02e5b078e8c04d6d584434a880.zip
graphics/vigra: get rid of hardcoded python2.7 dependency
tested with python 3.6/3.7/3.8, no consumer issues detected PR: 244371 Reported by: VVD <vvd@unislabs.com>
Notes
Notes: svn path=/head/; revision=537494
Diffstat (limited to 'graphics/vigra')
-rw-r--r--graphics/vigra/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index 8ddffff76afc..99b532127dd4 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -4,7 +4,7 @@
PORTNAME= vigra
DISTVERSIONPREFIX=v
DISTVERSION= 1.11.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MAINTAINER= ports@FreeBSD.org
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libHalf.so:graphics/ilmbase \
libsz.so:science/szip
-USES= cmake compiler:c++14-lang python:2.7,run shebangfix
+USES= cmake compiler:c++14-lang python:run shebangfix
USE_GITHUB= yes
GH_ACCOUNT= ukoethe
GH_TAGNAME= 8acd73a
@@ -40,7 +40,7 @@ OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr
NUMPY_DESC= NumPy mathematical computing (USE Fortran/GCC47+)
NUMPY_CMAKE_BOOL= WITH_VIGRANUMPY
-NUMPY_USES= compiler:gcc-c++11-lib python:2.7,build
+NUMPY_USES= compiler:gcc-c++11-lib python:build
NUMPY_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYNUMPY}
NUMPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \