aboutsummaryrefslogtreecommitdiff
path: root/graphics/volpack/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-14 12:38:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-14 12:38:41 +0000
commit58f0413cab5170d0aec356ea4e8ad174a7c45425 (patch)
treef9058bdb440a9b9c092644890464580316ad7cb2 /graphics/volpack/Makefile
parentdd1e294d254234d27b9fa579fe8731c04c68c6ad (diff)
downloadports-58f0413cab5170d0aec356ea4e8ad174a7c45425.tar.gz
ports-58f0413cab5170d0aec356ea4e8ad174a7c45425.zip
Unbreak parallel builds (-jX) on recent -CURRENT, where our make(1) is
bmake(1) now. The build fails because bmake(1) treats MFLAGS variable slightly differently: while by default its value would be '-j X', our old make(1) allows to set it from the makefile or environment, bmake(1) will append to it instead. Pass the empty value via MAKE_ARGS to make every make(1) happy, and thus fix parallel builds (once again).
Notes
Notes: svn path=/head/; revision=324710
Diffstat (limited to 'graphics/volpack/Makefile')
-rw-r--r--graphics/volpack/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/graphics/volpack/Makefile b/graphics/volpack/Makefile
index 3815df02c80a..feed66e71356 100644
--- a/graphics/volpack/Makefile
+++ b/graphics/volpack/Makefile
@@ -13,8 +13,7 @@ COMMENT= Portable software library for volume rendering
LICENSE= BSD
GNU_CONFIGURE= yes
-
-MAKE_JOBS_UNSAFE=yes
+MAKE_ARGS= MFLAGS="" # required for bmake(1) and -jX builds
PLIST_FILES= lib/libvolpack.a \
include/volpack.h