aboutsummaryrefslogtreecommitdiff
path: root/graphics/white_dune/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-01-19 13:26:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-01-19 13:26:38 +0000
commit2f322e9162b98694362e0a8c148e8789f125d6b6 (patch)
tree3f84eda50384f7ff7e3df5c4812ccf254dba9ceb /graphics/white_dune/Makefile
parentabe2b1fc47ac9a2e81eee2151deb3c36d1f57580 (diff)
downloadports-2f322e9162b98694362e0a8c148e8789f125d6b6.tar.gz
ports-2f322e9162b98694362e0a8c148e8789f125d6b6.zip
- Update to 0.30pl5
- Grant maintainership to submitter PR: ports/153823 Submitted by: Stas Timokhin <devel@stasyan.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=267996
Diffstat (limited to 'graphics/white_dune/Makefile')
-rw-r--r--graphics/white_dune/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/graphics/white_dune/Makefile b/graphics/white_dune/Makefile
index fea4a94cbfd1..41efdbced48f 100644
--- a/graphics/white_dune/Makefile
+++ b/graphics/white_dune/Makefile
@@ -8,18 +8,21 @@
PORTNAME= white_dune
PORTVERSION= ${DISTVERSION:S/pl/./}
-DISTVERSION= 0.28pl14
-PORTREVISION= 4
+DISTVERSION= 0.30pl5
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://vrml.cip.ica.uni-stuttgart.de/dune/ CENKES
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= devel@stasyan.com
COMMENT= Graphical VRML97 Editor and animation tool
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_XORG= xft
USE_MOTIF= yes
USE_GL= gl glu glut
USE_SDL= sdl
@@ -32,7 +35,7 @@ CONFIGURE_ARGS= --with-optimization \
--with-vrml97am1url="${DOCSDIR}/vrml97Amendment1" \
--with-x3ddrafturl="${DOCSDIR}/x3dDraft" \
--with-scriptednodesurl="${DOCSDIR}/scriptedNodes"
-CPPFLAGS= `${SDL_CONFIG} --cflags` -DUSBHID_UCR_DATA -DUSBHID_NEW
+CPPFLAGS= `${SDL_CONFIG} --cflags` -DUSBHID_UCR_DATA -DUSBHID_NEW -D__FREEBSD__
LDFLAGS= `${SDL_CONFIG} --libs`
ALL_TARGET= dune
@@ -46,10 +49,4 @@ do-install:
@cd ${WRKSRC}/docs/&&${COPYTREE_SHARE} . ${DOCSDIR}/
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800064
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>