aboutsummaryrefslogtreecommitdiff
path: root/graphics/white_dune
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-08 10:41:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-08 10:41:30 +0000
commit2730c8a3dcd82845271c9dbb832f982bbacff7ab (patch)
tree1642e533cdc6183365ccba20544974f74946044a /graphics/white_dune
parent4e50fe70614b6cbe88ee0c6606cd7336356c42d0 (diff)
downloadports-2730c8a3dcd82845271c9dbb832f982bbacff7ab.tar.gz
ports-2730c8a3dcd82845271c9dbb832f982bbacff7ab.zip
PERL -> REINPLACE_CMD
PR: 39938 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Notes
Notes: svn path=/head/; revision=62647
Diffstat (limited to 'graphics/white_dune')
-rw-r--r--graphics/white_dune/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/white_dune/Makefile b/graphics/white_dune/Makefile
index 4614e452f447..8d13a532af89 100644
--- a/graphics/white_dune/Makefile
+++ b/graphics/white_dune/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg
+USE_REINPLACE= yes
USE_BISON= yes
USE_MESA= yes
USE_MOTIF= yes
@@ -27,9 +28,9 @@ MAN1= dune.1
post-patch:
@${GREP} -lR "malloc.h" ${WRKSRC} | ${XARGS} \
- ${PERL} -pi -e "s/malloc\.h/stdlib.h/g"
- @${PERL} -pi -e "s/values\.h/limits.h/g" ${WRKSRC}/stdafx.h
- @${PERL} -pi -e "s/alloca\.h/stdlib.h/g" ${WRKSRC}/NodeNurbsSurface.cpp
+ ${REINPLACE_CMD} -e "s/malloc\.h/stdlib.h/g"
+ @${REINPLACE_CMD} -e "s/values\.h/limits.h/g" ${WRKSRC}/stdafx.h
+ @${REINPLACE_CMD} -e "s/alloca\.h/stdlib.h/g" ${WRKSRC}/NodeNurbsSurface.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dune ${PREFIX}/bin