aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpdf4
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-02-28 03:26:43 +0000
committerCy Schubert <cy@FreeBSD.org>2019-02-28 03:26:43 +0000
commitd966c0325c78a4dec6ba6a9f1e0210d477121155 (patch)
treeb99f84ae15421b2fbfc4bd52327ebe28621faa75 /graphics/xpdf4
parent99357ea4a5e2358b0a82d88d5aec560a6303555b (diff)
downloadports-d966c0325c78a4dec6ba6a9f1e0210d477121155.tar.gz
ports-d966c0325c78a4dec6ba6a9f1e0210d477121155.zip
Rework and reimplementation of previous GUI option.
PR: 235895
Notes
Notes: svn path=/head/; revision=494124
Diffstat (limited to 'graphics/xpdf4')
-rw-r--r--graphics/xpdf4/Makefile15
-rw-r--r--graphics/xpdf4/pkg-plist6
2 files changed, 13 insertions, 8 deletions
diff --git a/graphics/xpdf4/Makefile b/graphics/xpdf4/Makefile
index f699fb8ee37f..2cc4678da3e3 100644
--- a/graphics/xpdf4/Makefile
+++ b/graphics/xpdf4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= xpdf
PORTVERSION= 4.01
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics print
MASTER_SITES= https://xpdfreader-dl.s3.amazonaws.com/
@@ -22,15 +23,13 @@ CONFLICTS_INSTALL+= xpdf3-* xpdf4-*
.endif
USES= compiler:c++11-lang cmake localbase:ldflags \
- desktop-file-utils qt:5
+ desktop-file-utils
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png
BUILD_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/d050000l.pfb:print/gsfonts
RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/d050000l.pfb:print/gsfonts
MANPREFIX= ${PREFIX}/share/xpdf
SUB_FILES= xpdf-man.conf
-USE_QT= buildtools_build concurrent core gui network printsupport \
- qmake_build svg widgets
CMAKE_ARGS+= -DOPI_SUPPORT:BOOL=ON -DCMAKE_DISABLE_FIND_PACKAGE_Qt4:BOOL=ON \
-DUSE_LCMS:BOOL=OFF -DSYSTEM_XPDFRC=${PREFIX}/etc/xpdfrc \
-DCMAKE_INSTALL_PREFIX=${PREFIX} \
@@ -41,8 +40,8 @@ CMAKE_ARGS+= -DOPI_SUPPORT:BOOL=ON -DCMAKE_DISABLE_FIND_PACKAGE_Qt4:BOOL=ON \
PLIST_SUB= DESKTOPDIR="${DESKTOPDIR}"
-OPTIONS_DEFINE= TYPE1 LIBPAPER PRINT
-OPTIONS_DEFAULT= TYPE1 PRINT
+OPTIONS_DEFINE= TYPE1 LIBPAPER PRINT GUI
+OPTIONS_DEFAULT= TYPE1 PRINT GUI
OPTIONS_SUB= yes
TYPE1_CMAKE_BOOL= TYPE1
@@ -52,6 +51,12 @@ TYPE1_RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/d050000l.pfb:print/gsfon
LIBPAPER_CMAKE_BOOL= USE_LIBPAPER
LIBPAPER_LIB_DEPENDS= libpaper.so:print/libpaper
+GUI_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Widgets=1
+GUI_DESC= QT5 interface
+GUI_CMAKE_ARGS+= -DNO_TEXT_SELECT:BOOL=OFF
+GUI_USES= qt:5
+GUI_USE= QT=buildtools_build,qmake_build,concurrent,core,gui,widgets,printsupport,svg,network,printsupport
+
PRINT_CMAKE_ON= -DXPDFWIDGET_PRINTING:BOOL=ON -DCUPS:BOOL=ON
PRINT_CMAKE_OFF= -DXPDFWIDGET_PRINTING:BOOL=OFF -DCUPS:BOOL=OFF
PRINT_DESC= Print support (CUPS dependency)
diff --git a/graphics/xpdf4/pkg-plist b/graphics/xpdf4/pkg-plist
index 128aefb74017..af0e34c16f90 100644
--- a/graphics/xpdf4/pkg-plist
+++ b/graphics/xpdf4/pkg-plist
@@ -7,8 +7,8 @@ libexec/xpdf/pdftopng
libexec/xpdf/pdftoppm
libexec/xpdf/pdftops
libexec/xpdf/pdftotext
-libexec/xpdf/xpdf
-bin/xpdf
+%%GUI%%libexec/xpdf/xpdf
+%%GUI%%bin/xpdf
%%DESKTOPDIR%%/xpdf.desktop
etc/man.d/xpdf.conf
%%DATADIR%%/man/man1/pdfdetach.1.gz
@@ -20,6 +20,6 @@ etc/man.d/xpdf.conf
%%DATADIR%%/man/man1/pdftoppm.1.gz
%%DATADIR%%/man/man1/pdftops.1.gz
%%DATADIR%%/man/man1/pdftotext.1.gz
-%%DATADIR%%/man/man1/xpdf.1.gz
+%%GUI%%%%DATADIR%%/man/man1/xpdf.1.gz
%%DATADIR%%/man/man5/xpdfrc.5.gz
@sample etc/xpdfrc.sample