aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpx/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-06 23:17:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-06 23:17:35 +0000
commit0d8fb748bb7167dbc5ef25bb698356323241ba9e (patch)
treed38b9b3d73ef04f9ba8809d7b641b8a3a5ad8079 /graphics/xpx/Makefile
parentd20a301338359a4e92c11049224662a0c6da4ce1 (diff)
downloadports-0d8fb748bb7167dbc5ef25bb698356323241ba9e.tar.gz
ports-0d8fb748bb7167dbc5ef25bb698356323241ba9e.zip
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=408324
Diffstat (limited to 'graphics/xpx/Makefile')
-rw-r--r--graphics/xpx/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/xpx/Makefile b/graphics/xpx/Makefile
index 0eb033cfdc1d..a593598fd081 100644
--- a/graphics/xpx/Makefile
+++ b/graphics/xpx/Makefile
@@ -17,9 +17,12 @@ USES= imake:notall
USE_XORG= x11 xext
DOCSDIR= ${PREFIX}/share/doc/ja/${PORTNAME}
+
PORTDOCS= xpx.doc xpxrc.eg
PLIST_FILES= bin/xpx
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|myname|my_name|g' ${WRKSRC}/magtoppm.c
@${REINPLACE_CMD} -e '/edit_mode/d' ${WRKSRC}/work.h
@@ -27,8 +30,8 @@ post-patch:
pre-configure:
@(cd ${CONFIGURE_WRKSRC}; ${SH} configure)
-post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor