aboutsummaryrefslogtreecommitdiff
path: root/graphics/xv
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-08-27 18:27:45 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-08-27 18:27:45 +0000
commita9004e4e654e08bb0780f91d03a8396cc9034917 (patch)
tree40d7a61f817a8be13f503e3a392bb7daa42de637 /graphics/xv
parent58337fe7a8e4c9a29a74368879bc9865d13b76bd (diff)
downloadports-a9004e4e654e08bb0780f91d03a8396cc9034917.tar.gz
ports-a9004e4e654e08bb0780f91d03a8396cc9034917.zip
Make Shigeyuki FUKUSHIMA the new maintainer (was ports@freebsd.org).
Add Japanese enhancements (including some Japanese file formats). Update or add various patches, including PNG, multi-page TIFF, and PDF. PR: 7751 Submitted by: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
Notes
Notes: svn path=/head/; revision=12886
Diffstat (limited to 'graphics/xv')
-rw-r--r--graphics/xv/Makefile42
-rw-r--r--graphics/xv/distinfo16
-rw-r--r--graphics/xv/files/patch-ac126
-rw-r--r--graphics/xv/files/patch-ad32
-rw-r--r--graphics/xv/pkg-descr12
-rw-r--r--graphics/xv/pkg-plist14
6 files changed, 186 insertions, 56 deletions
diff --git a/graphics/xv/Makefile b/graphics/xv/Makefile
index a037caa1824b..5eb6480fa4e5 100644
--- a/graphics/xv/Makefile
+++ b/graphics/xv/Makefile
@@ -3,21 +3,26 @@
# Date created: 30 October 1994
# Whom: smace
#
-# $Id: Makefile,v 1.18 1998/04/23 21:06:28 vanilla Exp $
+# $Id: Makefile,v 1.19 1998/05/04 20:23:32 jseger Exp $
#
DISTNAME= xv-3.10a
CATEGORIES= graphics x11
MASTER_SITES= ftp://ftp.cis.upenn.edu/pub/xv/ \
- ftp://ftp.kuis.kyoto-u.ac.jp/X11/contrib/clients/xv/ \
- ftp://ftp.tohoku.ac.jp/pub/X/app/xv/
+ ftp://ftp.airlab.cs.ritsumei.ac.jp/pub/X/xv-jp-extension/working/ \
+ http://www.freebsd.org/~mph/distfiles/xv/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- xv310a-magpic2-PhotoCD-patch.tar.gz # only from Japan
+ xv310a-jp-extension-rev5.3.3.tar.gz \
+ croppad.patch grabpatch jp-ext-bzip2.patch longname.patch \
+ mp-tiff-patch pdf.patch png-1.2d-fix.patch png-1.2d.patch
+DIST_SUBDIR= xv
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} \
+ xv310a-jp-extension-rev5.3.3.tar.gz
PATCH_SITES= ftp://ftp.cis.upenn.edu/pub/xv/
PATCHFILES= xv-3.10a.JPEG-patch xv-3.10a.TIFF-patch
-MAINTAINER= ports@FreeBSD.ORG
+MAINTAINER= shige@kuis.kyoto-u.ac.jp
LIB_DEPENDS= jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
tiff34\\.1:${PORTSDIR}/graphics/tiff34 \
@@ -25,14 +30,37 @@ LIB_DEPENDS= jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
USE_IMAKE= yes
+XVDIST= ${DISTDIR}/${DIST_SUBDIR}
+
pre-patch:
- @${PATCH} ${PATCH_ARGS} -p1 < ${WRKDIR}/Patch.magpic2.PhotoCD.XV310a
+ @${PATCH} ${PATCH_ARGS} -p1 < ${WRKDIR}/xv-jp-extension/Patch.xv310a-ext-5.3.3
+
+post-patch:
+ @${PATCH} ${PATCH_ARGS} -p0 < ${XVDIST}/croppad.patch
+ @${PATCH} ${PATCH_ARGS} -p0 < ${XVDIST}/grabpatch
+ @${PATCH} ${PATCH_ARGS} -p1 < ${XVDIST}/longname.patch
+ @${PATCH} ${PATCH_ARGS} -p0 < ${XVDIST}/mp-tiff-patch
+ @${PATCH} ${PATCH_ARGS} -p1 < ${XVDIST}/pdf.patch
+ @${PATCH} ${PATCH_ARGS} -p1 < ${XVDIST}/png-1.2d.patch
+ @${PATCH} ${PATCH_ARGS} -p1 < ${XVDIST}/png-1.2d-fix.patch
+ @${PATCH} ${PATCH_ARGS} -p1 < ${XVDIST}/jp-ext-bzip2.patch
post-install:
+.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/xv
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xv
-.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/README.PNG ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/docs/epsf.ps ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/docs/xpm.ps ${PREFIX}/share/doc/xv
${INSTALL_DATA} ${WRKSRC}/docs/xvdocs.ps ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/docs/xvtitle.ps ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/docs/help ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/docs/bmp.doc ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/docs/gif* ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/../xv-jp-extension/CHANGELOG.* ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/../xv-jp-extension/README.PhotoCD ${PREFIX}/share/doc/xv
+ ${INSTALL_DATA} ${WRKSRC}/../xv-jp-extension/README.xv310a-ext-5.3.3 ${PREFIX}/share/doc/xv/README.xv310a-ext-5.3.3.ja
+ ${INSTALL_DATA} ${WRKSRC}/../xv-jp-extension/magic.add ${PREFIX}/share/doc/xv
.endif
.include <bsd.port.mk>
diff --git a/graphics/xv/distinfo b/graphics/xv/distinfo
index e5df05ca88dd..8bfba94466e3 100644
--- a/graphics/xv/distinfo
+++ b/graphics/xv/distinfo
@@ -1,4 +1,12 @@
-MD5 (xv-3.10a.tar.gz) = 2d4fbeec1561304362781cc8e2f7f72d
-MD5 (xv310a-magpic2-PhotoCD-patch.tar.gz) = d7e2797f14220778b6ac67e59dea3c35
-MD5 (xv-3.10a.JPEG-patch) = bd3ac79fa805319f583ccd382bdc825d
-MD5 (xv-3.10a.TIFF-patch) = 305f2f0273368bb6e029c3f212a14249
+MD5 (xv/xv-3.10a.tar.gz) = 2d4fbeec1561304362781cc8e2f7f72d
+MD5 (xv/xv310a-jp-extension-rev5.3.3.tar.gz) = 60654c008c493cf42bbf46442d63f444
+MD5 (xv/croppad.patch) = 75c44ef08903167ef19a89a8e9c4fd74
+MD5 (xv/grabpatch) = fd9b9e735a1ed68e3792d904f1df422a
+MD5 (xv/jp-ext-bzip2.patch) = 543f6747bf85ad9d9a9837a9d1e821fa
+MD5 (xv/longname.patch) = 04f2f162a2f66c8eca6bd6e2e1e9777d
+MD5 (xv/mp-tiff-patch) = 012a8562ed300db3174cfee95b13d18c
+MD5 (xv/pdf.patch) = 3c8806b4ce221f268f1cc257201ca0b7
+MD5 (xv/png-1.2d-fix.patch) = 672f2f82c94828d91b6929ed87139937
+MD5 (xv/png-1.2d.patch) = 8c2126618f1f9925fbb60499581d58c5
+MD5 (xv/xv-3.10a.JPEG-patch) = bd3ac79fa805319f583ccd382bdc825d
+MD5 (xv/xv-3.10a.TIFF-patch) = 305f2f0273368bb6e029c3f212a14249
diff --git a/graphics/xv/files/patch-ac b/graphics/xv/files/patch-ac
index 58bb772b9053..8222f54f6a6b 100644
--- a/graphics/xv/files/patch-ac
+++ b/graphics/xv/files/patch-ac
@@ -1,38 +1,88 @@
-*** /tmp/T0a03151 Mon Feb 13 18:35:11 1995
---- config.h Mon Feb 13 18:34:49 1995
-***************
-*** 13,18 ****
- * definition appropriately. (use 'which gunzip' to find if you have gunzip,
- * and where it lives)
- */
-! #undef USE_GUNZIP
-
- #ifdef USE_GUNZIP
---- 13,18 ----
- * definition appropriately. (use 'which gunzip' to find if you have gunzip,
- * and where it lives)
- */
-! #define USE_GUNZIP
-
- #ifdef USE_GUNZIP
-***************
-*** 88,96 ****
- * should not need to be changed
- */
-
-! /* #define GS_PATH "/usr/local/bin/gs" */
-! /* #define GS_LIB "." */
-! /* #define GS_DEV "ppmraw" */
-
-
- /***************************************************************************
---- 88,96 ----
- * should not need to be changed
- */
-
-! #define GS_PATH "/usr/local/bin/gs"
-! #define GS_LIB "/usr/local/lib/ghostscript"
-! #define GS_DEV "ppmraw"
-
-
- /***************************************************************************
+--- config.h.orig Thu Aug 27 04:50:47 1998
++++ config.h Thu Aug 27 04:51:05 1998
+@@ -13,7 +13,7 @@
+ * definition appropriately. (use 'which gunzip' to find if you have gunzip,
+ * and where it lives)
+ */
+-#undef USE_GUNZIP
++#define USE_GUNZIP
+
+ #ifdef USE_GUNZIP
+ # ifdef VMS
+@@ -103,9 +103,9 @@
+ * should not need to be changed
+ */
+
+-/* #define GS_PATH "/usr/local/bin/gs" */
+-/* #define GS_LIB "." */
+-/* #define GS_DEV "ppmraw" */
++#define GS_PATH "/usr/local/bin/gs"
++#define GS_LIB "/usr/local/lib/ghostscript"
++#define GS_DEV "ppmraw"
+
+
+ /***************************************************************************
+@@ -159,7 +159,7 @@
+ * in the following line.
+ */
+
+-#undef MACBINARY
++#define MACBINARY
+
+
+ /***************************************************************************
+@@ -175,8 +175,8 @@
+ * is read-only), change 'undef' to 'define' the VIRTUAL_TD line.
+ */
+
+-#undef AUTO_EXPAND
+-#undef VIRTUAL_TD
++#define AUTO_EXPAND
++#define VIRTUAL_TD
+
+ #if !defined(AUTO_EXPAND) && defined(VIRTUAL_TD)
+ # undef VIRTUAL_TD
+@@ -190,7 +190,7 @@
+ * Shunauzer, change 'undef' to 'define' in the following line.
+ */
+
+-#undef VS_ADJUST
++#define VS_ADJUST
+
+
+ /***************************************************************************
+@@ -259,7 +259,7 @@
+ * magic number or suffix in "~/.xv_mgcsfx" .
+ * To enable this feature, change 'undef' to 'define' in the following line.
+ */
+-#undef HAVE_MGCSFX
++#define HAVE_MGCSFX
+
+ #ifdef HAVE_MGCSFX
+ /*
+@@ -285,14 +285,14 @@
+ * WARNING : If you decide to use preprocessor, you must not write
+ * '# <comment>' style comment in startup file. Because,
+ * preprocessor can't recognize. */
+-# undef USE_MGCSFX_PREPROCESSOR
++# define USE_MGCSFX_PREPROCESSOR
+
+ # ifdef USE_MGCSFX_PREPROCESSOR
+ /*
+ * This is used like "system("MGCSFX_PREPROCESSOR MGCSFX_RC > tmp_name");",
+ * and read tmp_name instead of MGCSFX_RC.
+ */
+-# define MGCSFX_PREPROCESSOR "/usr/lib/cpp"
++# define MGCSFX_PREPROCESSOR "/usr/bin/cpp"
+ /* # define MGCSFX_PREPROCESSOR "cc -E" */
+
+ # endif /* USE_MGCSFX_PREPROCESSOR */
+@@ -320,7 +320,7 @@
+ * 'undef' to 'define' in the following line.
+ */
+
+-#undef TV_MULTILINGUAL
++#define TV_MULTILINGUAL
+
+ #define TV_DEFAULT_CODESET TV_EUC_JAPAN
+
diff --git a/graphics/xv/files/patch-ad b/graphics/xv/files/patch-ad
index 9013389700cd..72fb0c1bf26b 100644
--- a/graphics/xv/files/patch-ad
+++ b/graphics/xv/files/patch-ad
@@ -1,5 +1,5 @@
---- ./Imakefile.org Fri Jan 13 12:24:01 1995
-+++ ./Imakefile Wed Jul 5 03:32:57 1995
+--- Imakefile.orig Thu Aug 27 04:53:33 1998
++++ Imakefile Thu Aug 27 04:54:22 1998
@@ -6,13 +6,15 @@
/* if, for whatever reason, you're unable to get the JPEG library to compile
* on your machine, *COMMENT OUT* the following line
@@ -18,7 +18,7 @@
/* if, for whatever reason, you're unable to get the PDS/VICAR support
-@@ -119,16 +121,30 @@
+@@ -124,16 +126,30 @@
JPEG = -DDOJPEG
JPEGDIR = jpeg
LIBJPEG = $(JPEGDIR)/libjpeg.a
@@ -49,7 +49,7 @@
#ifdef HavePDS
PDS = -DDOPDS
#endif
-@@ -142,8 +158,8 @@
+@@ -149,8 +165,8 @@
#endif
@@ -60,3 +60,27 @@
DEFINES= $(SCO) $(UNIX) $(NODIRENT) $(VPRINTF) $(TIMERS) \
$(HPUX7) $(JPEG) $(TIFF) $(PDS) $(DXWM) $(RAND) \
+@@ -254,10 +270,10 @@
+ #endif
+
+
+-NormalProgramTarget(xv,$(OBJS1),$(DEPLIBS),$(LOCAL_LIBRARIES),)
+-NormalProgramTarget(bggen,$(OBJS2),$(DEPLIBS),$(LOCAL_LIBRARIES),)
+-NormalProgramTarget(xcmap,$(OBJS4),$(DEPLIBS),$(LOCAL_LIBRARIES),)
+-NormalProgramTarget(xvpictoppm,$(OBJS5),$(DEPLIBS),$(LOCAL_LIBRARIES),)
++NormalProgramTarget(xv,$(OBJS1),$(DEPLIBS),$(LOCAL_LIBRARIES),-lxpg4)
++NormalProgramTarget(bggen,$(OBJS2),$(DEPLIBS),$(LOCAL_LIBRARIES),-lxpg4)
++NormalProgramTarget(xcmap,$(OBJS4),$(DEPLIBS),$(LOCAL_LIBRARIES),-lxpg4)
++NormalProgramTarget(xvpictoppm,$(OBJS5),$(DEPLIBS),$(LOCAL_LIBRARIES),-lxpg4)
+
+
+ InstallProgram(xv,$(BINDIR))
+@@ -266,7 +282,7 @@
+ InstallProgram(xvpictoppm,$(BINDIR))
+
+ #ifdef HavePDS
+-NormalProgramTarget(vdcomp,$(OBJS3),$(DEPLIBS),$(LOCAL_LIBRARIES),)
++NormalProgramTarget(vdcomp,$(OBJS3),$(DEPLIBS),$(LOCAL_LIBRARIES),-lxpg4)
+ InstallProgram(vdcomp,$(BINDIR))
+ #endif
+
diff --git a/graphics/xv/pkg-descr b/graphics/xv/pkg-descr
index 75641db7c9a1..320e2df93d85 100644
--- a/graphics/xv/pkg-descr
+++ b/graphics/xv/pkg-descr
@@ -1,8 +1,14 @@
-xv is an X11 program that displays images in the GIF,
+Xv is an X11 program that displays images in the GIF,
JPEG, TIFF, PBM, PGM, PPM, X11 bitmap, Utah Raster Toolkit
RLE, PDS/VICAR, Sun Rasterfile, BMP, XPM, PCX, IRIS RGB,
-possibly PostScript, and PM formats on workstations and
-terminals running the X Window System, Version 11.
+possibly PostScript, Portable Networking Format(PNG) and
+PM formats on workstations and terminals running the
+X Window System, Version 11.
+And more xv japanese extensions patch supports images in
+the MAKI, MAG, PIC, Pi PIC2, PhotoCD. And this patch also
+supports archived image files. Supported archivers are
+arc, arj, lzh, tar, tar+compress, tar+gzip, tar+bzip2, zip,
+and zoo.
Note that this program is shareware except for personal use only.
Please read the documentation in the directory
diff --git a/graphics/xv/pkg-plist b/graphics/xv/pkg-plist
index e4089f5a183b..95bb1ff367a3 100644
--- a/graphics/xv/pkg-plist
+++ b/graphics/xv/pkg-plist
@@ -9,5 +9,19 @@ man/man1/vdcomp.1.gz
man/man1/xcmap.1.gz
man/man1/xvpictoppm.1.gz
share/doc/xv/README
+share/doc/xv/README.PNG
+share/doc/xv/epsf.ps
+share/doc/xv/xpm.ps
share/doc/xv/xvdocs.ps
+share/doc/xv/xvtitle.ps
+share/doc/xv/help
+share/doc/xv/bmp.doc
+share/doc/xv/gif.ack
+share/doc/xv/gif.aspect
+share/doc/xv/gif87.doc
+share/doc/xv/gif89.doc
+share/doc/xv/CHANGELOG.jp-ext
+share/doc/xv/README.PhotoCD
+share/doc/xv/README.xv310a-ext-5.3.3.ja
+share/doc/xv/magic.add
@dirrm share/doc/xv