aboutsummaryrefslogtreecommitdiff
path: root/graphics/xzgv
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-01-06 18:35:39 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-01-06 18:35:39 +0000
commitfe349811157d7b7f83d0e967cf9da945d1eb15f5 (patch)
tree24a97611e05a418d1104d1cedddf740078a93ee6 /graphics/xzgv
parente27520e59924888f900102e5b28281fad1f8a042 (diff)
downloadports-fe349811157d7b7f83d0e967cf9da945d1eb15f5.tar.gz
ports-fe349811157d7b7f83d0e967cf9da945d1eb15f5.zip
Resurrected and updated port: graphics/xzgv
- submitter becomes maintainer PR: 234136 Submitted by: m.ne@gmx.net
Notes
Notes: svn path=/head/; revision=489518
Diffstat (limited to 'graphics/xzgv')
-rw-r--r--graphics/xzgv/Makefile37
-rw-r--r--graphics/xzgv/distinfo3
-rw-r--r--graphics/xzgv/files/patch-Makefile35
-rw-r--r--graphics/xzgv/files/patch-doc_Makefile17
-rw-r--r--graphics/xzgv/pkg-descr9
5 files changed, 101 insertions, 0 deletions
diff --git a/graphics/xzgv/Makefile b/graphics/xzgv/Makefile
new file mode 100644
index 000000000000..31a2d934f1cf
--- /dev/null
+++ b/graphics/xzgv/Makefile
@@ -0,0 +1,37 @@
+# Created by: Norio Suzuki <nosuzuki@e-mail.ne.jp>
+# $FreeBSD$
+
+PORTNAME= xzgv
+PORTVERSION= 0.9.2
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= m.ne@gmx.net
+COMMENT= Image viewer with thumbnail-based file selector for X
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= gawk:lang/gawk
+LIB_DEPENDS= libexif.so:graphics/libexif \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+USES= gmake gnome pkgconfig
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_IMLIB= yes
+USE_XORG= x11
+
+LDFLAGS+= -L${LOCALBASE}/lib -lX11 -lm
+PLIST_FILES= bin/xzgv man/man1/xzgv.1.gz
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^CC|#CC|g ; \
+ s|^CFLAGS|#CFLAGS|g ; \
+ s|^PREFIX|#PREFIX|g' ${WRKSRC}/config.mk
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xzgv ${STAGEDIR}${LOCALBASE}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/doc/xzgv.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/graphics/xzgv/distinfo b/graphics/xzgv/distinfo
new file mode 100644
index 000000000000..14dd96b45b7b
--- /dev/null
+++ b/graphics/xzgv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542161783
+SHA256 (xzgv-0.9.2.tar.gz) = 25a240bb8c4a85c3979ce1a39c81c859724b490c1fd83dd4e3ef1db053ee819e
+SIZE (xzgv-0.9.2.tar.gz) = 162077
diff --git a/graphics/xzgv/files/patch-Makefile b/graphics/xzgv/files/patch-Makefile
new file mode 100644
index 000000000000..cfe0d460ebfb
--- /dev/null
+++ b/graphics/xzgv/files/patch-Makefile
@@ -0,0 +1,35 @@
+--- Makefile.orig 2009-04-30 21:58:36 UTC
++++ Makefile
+@@ -32,8 +32,8 @@ src: xzgv
+ xzgv:
+ cd src && $(MAKE) xzgv
+
+-src/install-info: src/install-info.c
+- cd src && $(MAKE) install-info
++#src/install-info: src/install-info.c
++# cd src && $(MAKE) install-info
+
+ man: doc/xzgv.1
+
+@@ -57,13 +57,16 @@ realclean:
+ cd doc && $(MAKE) realclean
+ $(RM) *~
+
+-install: all
+- cd src && $(MAKE) install
+- cd doc && $(MAKE) install
++#install: all
++# cd src && $(MAKE) install
++# cd doc && $(MAKE) install
++install:
++# cd src && $(MAKE) install
++# cd doc && $(MAKE) install
+
+ uninstall:
+- cd src && $(MAKE) uninstall
+- cd doc && $(MAKE) uninstall
++# cd src && $(MAKE) uninstall
++# cd doc && $(MAKE) uninstall
+
+
+ # The stuff below makes the distribution tgz.
diff --git a/graphics/xzgv/files/patch-doc_Makefile b/graphics/xzgv/files/patch-doc_Makefile
new file mode 100644
index 000000000000..b808faf2eb49
--- /dev/null
+++ b/graphics/xzgv/files/patch-doc_Makefile
@@ -0,0 +1,17 @@
+--- doc/Makefile.orig 2007-12-23 20:49:03 UTC
++++ doc/Makefile
+@@ -36,10 +36,10 @@ xzgv.1: xzgv.texi makeman.awk
+ installdirs:
+ /bin/sh ../mkinstalldirs $(INFODIR) $(MANDIR)
+
+-install: installdirs
+- install xzgv.1 $(MANDIR)
+- install -m 644 xzgv.info.gz $(INFODIR)
+- install-info --infodir=$(INFODIR) xzgv.info.gz
++install:
++# install xzgv.1 $(MANDIR)
++# install -m 644 xzgv.info.gz $(INFODIR)
++# install-info --infodir=$(INFODIR) xzgv.info.gz
+
+ uninstall:
+ $(RM) $(MANDIR)/xzgv.1
diff --git a/graphics/xzgv/pkg-descr b/graphics/xzgv/pkg-descr
new file mode 100644
index 000000000000..d26538a4e891
--- /dev/null
+++ b/graphics/xzgv/pkg-descr
@@ -0,0 +1,9 @@
+This is an image file viewer with thumbnail-based file selector. it uses GTK+
+and Imlib libraries and support most image file formats. The thumbnail file is
+compatible with xv and Gimp.
+
+In contrast to other image file viewers for X, xzgv uses only one window and
+can fit a large image to the size of the window without changing the aspect
+ratio.
+
+WWW: https://sourceforge.net/projects/xzgv/