aboutsummaryrefslogtreecommitdiff
path: root/graphics/zbar/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-11-18 10:05:48 +0000
committerJohn Marino <marino@FreeBSD.org>2013-11-18 10:05:48 +0000
commit07996bc4dd8db3e24588f8def2ece7d9ee250438 (patch)
treee8cf8263a20479b04402bbdf767eaa519a264463 /graphics/zbar/Makefile
parentf971cfdbe1b62662fda67cc937f58b45e60bb55e (diff)
downloadports-07996bc4dd8db3e24588f8def2ece7d9ee250438.tar.gz
ports-07996bc4dd8db3e24588f8def2ece7d9ee250438.zip
graphics/zbar: Unbreak on F10 and DragonFly
PR: ports/183572 Submitted by: marino Approved by: Oliver Heesakkers (maintainer, modified)
Notes
Notes: svn path=/head/; revision=334167
Diffstat (limited to 'graphics/zbar/Makefile')
-rw-r--r--graphics/zbar/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/graphics/zbar/Makefile b/graphics/zbar/Makefile
index 8ac2cc142e1a..3d682c1b7730 100644
--- a/graphics/zbar/Makefile
+++ b/graphics/zbar/Makefile
@@ -12,10 +12,14 @@ COMMENT= ZBar barcode reader
LICENSE= LGPL21
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= iconv gmake pkgconfig
+CONFIGURE_ARGS= --with-jpeg=yes
+
OPTIONS_DEFINE= X11 IMAGEMAGICK V4L PYTHON GTK2 QT4
OPTIONS_DEFAULT= X11 IMAGEMAGICK
V4L_DESC= Build zbarcam video scanner
@@ -23,13 +27,6 @@ V4L_DESC= Build zbarcam video scanner
NO_STAGE= yes
.include <bsd.port.options.mk>
-.if exists(${LOCALBASE}/lib/libjpeg.so)
-CONFIGURE_ARGS+= --with-jpeg=yes
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
-.else
-CONFIGURE_ARGS+= --with-jpeg=no
-.endif
-
.if ${PORT_OPTIONS:MX11}
USE_XORG= ice sm x11 xau xcb xdmcp xext xv
CONFIGURE_ARGS+= --with-x=yes