aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 12:40:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 12:40:58 +0000
commit9e3beea26a4c007b4af8e641a2b3761ec67bd0e3 (patch)
tree1e84a5977d8f5aa9e6089bcfd1d638f71459519b /graphics/zphoto
parent22141e7cc17d2d424c3bd0486c11ab0b8a12765a (diff)
downloadports-9e3beea26a4c007b4af8e641a2b3761ec67bd0e3.tar.gz
ports-9e3beea26a4c007b4af8e641a2b3761ec67bd0e3.zip
Convert to new options framework
Remove wxgtk option which is broken with all support version of wxgtk
Notes
Notes: svn path=/head/; revision=348981
Diffstat (limited to 'graphics/zphoto')
-rw-r--r--graphics/zphoto/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index c9ce81169ea2..aa762b1daf6c 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -11,11 +11,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= umeno@rr.iij4u.or.jp
COMMENT= Zooming photo album generator
-LIB_DEPENDS= ming.5:${PORTSDIR}/graphics/ming \
- popt.0:${PORTSDIR}/devel/popt
-.if !defined (WITHOUT_ZIP)
-RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
-.endif
+OPTIONS_DEFINE= ZIP
+OPTIONS_DEFAULT= ZIP
+ZIP_DESC= Enable zip support
+
+LIB_DEPENDS= libming.so:${PORTSDIR}/graphics/ming \
+ libpopt.so:${PORTSDIR}/devel/popt
+
+ZIP_RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+ZIP_CONFIGURE_OFF= --disable-zip
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-avifile
@@ -23,18 +27,8 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
USE_EFL= imlib2
-.if defined (WITH_WXGTK2)
-USE_WX= 2.4
-WX_CONF_ARGS= absolute
PLIST_FILES+= bin/wxzphoto
-.else
-CONFIGURE_ARGS+= --disable-wx
-.endif
-.if defined (WITHOUT_ZIP)
-CONFIGURE_ARGS+= --disable-zip
-.endif
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= build
NO_STAGE= yes