aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-13 22:26:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-13 22:26:40 +0000
commit1bd68a3fa56879b9f31ea97a726ead61adf7d2db (patch)
tree35e70e0f877062148c40fe83c5ea031bdefdbbb8 /graphics
parent1087a13739404eda0a95d69c3c22914287238aa4 (diff)
downloadports-1bd68a3fa56879b9f31ea97a726ead61adf7d2db.tar.gz
ports-1bd68a3fa56879b9f31ea97a726ead61adf7d2db.zip
Add dvipng, a DVI to PNG converter.
PR: ports/60191 Submitted by: o_sleep <o_sleep@babbleheaven.com>
Notes
Notes: svn path=/head/; revision=95751
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/dvipng/Makefile29
-rw-r--r--graphics/dvipng/distinfo1
-rw-r--r--graphics/dvipng/pkg-descr4
-rw-r--r--graphics/dvipng/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b6e632347362..f5f7fd3efddb 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -48,6 +48,7 @@
SUBDIR += dri-devel
SUBDIR += drm-kmod
SUBDIR += duhdraw
+ SUBDIR += dvipng
SUBDIR += dynamechs
SUBDIR += ecg2png
SUBDIR += electriceyes
diff --git a/graphics/dvipng/Makefile b/graphics/dvipng/Makefile
new file mode 100644
index 000000000000..e669d8a95cf7
--- /dev/null
+++ b/graphics/dvipng/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: dvipng
+# Date created: Dec 9, 2003
+# Whom: o_sleep
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvipng
+PORTVERSION= 0.8
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= preview-latex
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= DVI to PNG Converter
+
+BUILD_DEPENDS= kpsepath:${PORTSDIR}/print/teTeX
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+
+INFO= dvipng
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/graphics/dvipng/distinfo b/graphics/dvipng/distinfo
new file mode 100644
index 000000000000..e8f47afb1240
--- /dev/null
+++ b/graphics/dvipng/distinfo
@@ -0,0 +1 @@
+MD5 (dvipng-0.8.tar.gz) = c0b3deaa46cf22b59a65596578103322
diff --git a/graphics/dvipng/pkg-descr b/graphics/dvipng/pkg-descr
new file mode 100644
index 000000000000..0f70df30144b
--- /dev/null
+++ b/graphics/dvipng/pkg-descr
@@ -0,0 +1,4 @@
+This program makes PNG graphics from DVI files as obtained from TeX
+and its relatives.
+
+WWW: http://sourceforge.net/projects/preview-latex/
diff --git a/graphics/dvipng/pkg-plist b/graphics/dvipng/pkg-plist
new file mode 100644
index 000000000000..ab50bf90e140
--- /dev/null
+++ b/graphics/dvipng/pkg-plist
@@ -0,0 +1 @@
+bin/dvipng