aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-03-11 03:08:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-03-11 03:08:18 +0000
commit1c4bdf320f69abc270252df860c3ec0491423a62 (patch)
tree4ece4e66fd83a53ed1f3a4773836eb6f0fdec1ee /graphics
parente3c27085839bd8a58988470c3d54fb36713307dd (diff)
downloadports-1c4bdf320f69abc270252df860c3ec0491423a62.tar.gz
ports-1c4bdf320f69abc270252df860c3ec0491423a62.zip
Upgrade to 0.7a.
Notes
Notes: svn path=/head/; revision=10106
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpdf/Makefile10
-rw-r--r--graphics/xpdf/distinfo2
-rw-r--r--graphics/xpdf/files/patch-aa20
-rw-r--r--graphics/xpdf/files/patch-ab88
-rw-r--r--graphics/xpdf/pkg-descr1
5 files changed, 28 insertions, 93 deletions
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index 3145e6c9cb29..40c8d6eccb0c 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -1,17 +1,21 @@
# New ports collection makefile for: xpdf
-# Version required: 0.7
+# Version required: 0.7a
# Date created: 02 Feb 1996
# Whom: chuckr@glue.umd.edu
#
-# $Id: Makefile,v 1.10 1997/06/03 07:15:50 asami Exp $
+# $Id: Makefile,v 1.11 1997/10/24 16:51:59 chuckr Exp $
#
-DISTNAME= xpdf-0.7
+DISTNAME= xpdf-0.7a
CATEGORIES= graphics print
MASTER_SITES= ftp://ftp.aimnet.com/pub/users/derekn/xpdf/
MAINTAINER= chuckr@glue.umd.edu
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gzip
USE_X11= yes
MAN1= xpdf.1 pdftops.1 pdftotext.1
diff --git a/graphics/xpdf/distinfo b/graphics/xpdf/distinfo
index 6ac7fc619575..13858a25004a 100644
--- a/graphics/xpdf/distinfo
+++ b/graphics/xpdf/distinfo
@@ -1 +1 @@
-MD5 (xpdf-0.7.tar.gz) = a871cade04c8c9e55ff7e45c5ff49b4b
+MD5 (xpdf-0.7a.tar.gz) = 3b6ed5783d1f7c53a3983d404ec5c818
diff --git a/graphics/xpdf/files/patch-aa b/graphics/xpdf/files/patch-aa
new file mode 100644
index 000000000000..dd7106b61ad3
--- /dev/null
+++ b/graphics/xpdf/files/patch-aa
@@ -0,0 +1,20 @@
+--- configure.orig Tue Mar 10 10:06:40 1998
++++ configure Tue Mar 10 10:06:56 1998
+@@ -710,7 +710,7 @@
+ if test "$ac_test_CFLAGS" = set; then
+ CFLAGS="$ac_save_CFLAGS"
+ elif test $ac_cv_prog_cc_g = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="-O2 -m486 -pipe"
+ else
+ CFLAGS="-O2"
+ fi
+@@ -842,7 +842,7 @@
+ if test "$ac_test_CXXFLAGS" = set; then
+ CXXFLAGS="$ac_save_CXXFLAGS"
+ elif test $ac_cv_prog_cxx_g = yes; then
+- CXXFLAGS="-g -O2"
++ CXXFLAGS="-O2 -m486 -pipe"
+ else
+ CXXFLAGS="-O2"
+ fi
diff --git a/graphics/xpdf/files/patch-ab b/graphics/xpdf/files/patch-ab
deleted file mode 100644
index af6e93e9663f..000000000000
--- a/graphics/xpdf/files/patch-ab
+++ /dev/null
@@ -1,88 +0,0 @@
-*** Makefile.config.orig Fri May 30 03:29:08 1997
---- Makefile.config Fri May 30 03:31:38 1997
-***************
-*** 44,50 ****
- #------------------------------------------------------------------------
-
- # Binaries and man pages will be installed here:
-! PREFIX = /usr/local
-
- # SCO puts stuff here:
- #PREFIX = /u
---- 44,50 ----
- #------------------------------------------------------------------------
-
- # Binaries and man pages will be installed here:
-! PREFIX ?= /usr/X11R6
-
- # SCO puts stuff here:
- #PREFIX = /u
-*************** EXE =
-*** 149,155 ****
- #CFLAGS2 = -O2 -Wall -DNO_XPM
-
- # If you're using g++ 2.7.x, you'll want to use -Wno-unused:
-! CFLAGS2 = -O2 -Wall -Wno-unused -DNO_XPM
-
- # For Linux/FreeBSD/NetBSD/BSDI systems using XFree86:
- #CFLAGS2 = -O2 -Wall -I/usr/X11R6/include -Wno-unused
---- 149,155 ----
- #CFLAGS2 = -O2 -Wall -DNO_XPM
-
- # If you're using g++ 2.7.x, you'll want to use -Wno-unused:
-! CFLAGS2 = -O2 -m486 -pipe -Wall -Wno-unused -I${X11BASE}/include
-
- # For Linux/FreeBSD/NetBSD/BSDI systems using XFree86:
- #CFLAGS2 = -O2 -Wall -I/usr/X11R6/include -Wno-unused
-*************** CXXFLAGS2 = $(CFLAGS2)
-*** 197,209 ****
- #------------------------------------------------------------------------
-
- # For most systems, just grab the X library:
-! XLIBS = -lX11
-
- # For Linux/FreeBSD/NetBSD/BSDI systems using XFree86:
- #XLIBS = -L/usr/X11R6/lib -lX11
-
- # For official FreeBSD port (using the FreeBSD makefiles):
-! #XLIBS = -L$(X11BASE)/lib -lX11
-
- # Some BSDI systems may need -lipc (?):
- #XLIBS = -L/usr/X11R6/lib -lX11 -lipc
---- 197,209 ----
- #------------------------------------------------------------------------
-
- # For most systems, just grab the X library:
-! #XLIBS = -lX11
-
- # For Linux/FreeBSD/NetBSD/BSDI systems using XFree86:
- #XLIBS = -L/usr/X11R6/lib -lX11
-
- # For official FreeBSD port (using the FreeBSD makefiles):
-! XLIBS = -L$(X11BASE)/lib -lX11
-
- # Some BSDI systems may need -lipc (?):
- #XLIBS = -L/usr/X11R6/lib -lX11 -lipc
-*************** XLIBS = -lX11
-*** 242,251 ****
- #------------------------------------------------------------------------
-
- # This is needed for the color icon:
-! #XPMLIB = -lXpm
-
- # Use this if you don't have libXpm (and also define NO_XPM in CFLAGS2):
-! XPMLIB =
-
- #------------------------------------------------------------------------
- # C++ compilation rule.
---- 242,251 ----
- #------------------------------------------------------------------------
-
- # This is needed for the color icon:
-! XPMLIB = -lXpm
-
- # Use this if you don't have libXpm (and also define NO_XPM in CFLAGS2):
-! #XPMLIB =
-
- #------------------------------------------------------------------------
- # C++ compilation rule.
diff --git a/graphics/xpdf/pkg-descr b/graphics/xpdf/pkg-descr
index 74f5394a6719..da1e48e4d940 100644
--- a/graphics/xpdf/pkg-descr
+++ b/graphics/xpdf/pkg-descr
@@ -5,4 +5,3 @@ PDF software.) Xpdf runs under UNIX and the X Window System.
Xpdf is designed to be small and efficient. It does not use the Motif
or Xt libraries. It uses standard X fonts. Xpdf is quite usable on a
486-66 PC running FreeBSD.
-