aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 06:09:47 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 06:09:47 +0000
commit26620b919510c8af4b9bb47e44d764dd9f5989d9 (patch)
treeda3cebd0bf12c253690151dd6136af1d6494173b /graphics
parent3fba6f604d82add50fb46b4f4e38f0be9ccfda44 (diff)
downloadports-26620b919510c8af4b9bb47e44d764dd9f5989d9.tar.gz
ports-26620b919510c8af4b9bb47e44d764dd9f5989d9.zip
graphics/libgltext: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgltext/Makefile4
-rw-r--r--graphics/libgltext/files/patch-configure13
2 files changed, 16 insertions, 1 deletions
diff --git a/graphics/libgltext/Makefile b/graphics/libgltext/Makefile
index 5c46ee1bf97f..cc5c3da5d36d 100644
--- a/graphics/libgltext/Makefile
+++ b/graphics/libgltext/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfreetype.so:print/freetype2
-USES= gl gmake localbase libtool xorg
+USES= gl gmake localbase libtool pkgconfig xorg
USE_GL= gl glu
USE_XORG= x11 xmu
GNU_CONFIGURE= yes
@@ -26,6 +26,8 @@ OPTIONS_SUB= yes
EXAMPLES_DESC= Compile examples, need libglut
EXAMPLES_USE= GL=glut
+BINARY_ALIAS= freetype-config=true
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/${PORTNAME}-${PORTVERSION}.so \
${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so.0
diff --git a/graphics/libgltext/files/patch-configure b/graphics/libgltext/files/patch-configure
new file mode 100644
index 000000000000..b294659ab456
--- /dev/null
+++ b/graphics/libgltext/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2021-08-07 06:08:17 UTC
++++ configure
+@@ -8610,8 +8610,8 @@ if test "$FT_CONFIG" = "" ; then
+ echo "$as_me: error: freetype not found" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+-FT_FLAGS=`freetype-config --cflags`
+-FT_LIBS=`freetype-config --libs`
++FT_FLAGS=`pkg-config freetype2 --cflags`
++FT_LIBS=`pkg-config freetype2 --libs`
+ CXXFLAGS="$FT_FLAGS $CXXFLAGS"
+ LIBS="$FT_LIBS $LIBS"
+