aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-18 18:33:10 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-18 18:33:10 +0000
commit2796833d8e2e52b3dce20ec06743988c0a557282 (patch)
tree867cfae59ed785dd0ca4ab30cb0a2749b6645ed9 /graphics
parent45413829745e2b7207d3789ecf60b12e8aca60ad (diff)
downloadports-2796833d8e2e52b3dce20ec06743988c0a557282.tar.gz
ports-2796833d8e2e52b3dce20ec06743988c0a557282.zip
Impressive is a program that displays PDF presentation slides with style.
Smooth alpha-blended slide transitions are provided for the sake of eye candy, but in addition to this, Impressive offers some unique tools that are very useful for presentations. WWW: http://impressive.sourceforge.net/ PR: 143840 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=250040
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/impressive/Makefile44
-rw-r--r--graphics/impressive/distinfo3
-rw-r--r--graphics/impressive/pkg-descr6
4 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 83f473eac665..94f04a40ccb0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -337,6 +337,7 @@
SUBDIR += imlib2
SUBDIR += imlib2_loaders
SUBDIR += import-pictures
+ SUBDIR += impressive
SUBDIR += inkscape
SUBDIR += intergif
SUBDIR += inventor
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
new file mode 100644
index 000000000000..becb2e9ce7f1
--- /dev/null
+++ b/graphics/impressive/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: impressive
+# Date created: 2010-02-10
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= impressive
+PORTVERSION= 0.10.2
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/Impressive/${PORTVERSION}/
+DISTNAME= Impressive-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= The stylish way of giving presentations
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/wrapper.py:${PORTSDIR}/graphics/py-opengl \
+ ${PYTHON_SITELIBDIR}/pygame/surfarray.py:${PORTSDIR}/devel/py-game \
+ ${PYTHON_SITELIBDIR}/PIL/ImageGL.py:${PORTSDIR}/graphics/py-imaging \
+ xpdf:${PORTSDIR}/graphics/xpdf \
+ pdftk:${PORTSDIR}/print/pdftk \
+ xdg-open:${PORTSDIR}/devel/xdg-utils \
+ mplayer:${PORTSDIR}/multimedia/mplayer
+
+USE_PYTHON= yes
+USE_GHOSTSCRIPT_RUN= yes
+NO_BUILD= yes
+PLIST_FILES= bin/${PORTNAME}
+
+MAN1= ${PORTNAME}.1
+
+PORTDOCS= ${PORTNAME}.html demo.pdf license.txt
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/impressive/distinfo b/graphics/impressive/distinfo
new file mode 100644
index 000000000000..e98f19fec864
--- /dev/null
+++ b/graphics/impressive/distinfo
@@ -0,0 +1,3 @@
+MD5 (Impressive-0.10.2.tar.gz) = 492eda5e3e09beb2f6dc997ed94f5349
+SHA256 (Impressive-0.10.2.tar.gz) = a0a4ff5a29f6d96f3da0c244b170c9143ed780be0d578b87eccc17041234c3df
+SIZE (Impressive-0.10.2.tar.gz) = 137193
diff --git a/graphics/impressive/pkg-descr b/graphics/impressive/pkg-descr
new file mode 100644
index 000000000000..f3af0e46fed9
--- /dev/null
+++ b/graphics/impressive/pkg-descr
@@ -0,0 +1,6 @@
+Impressive is a program that displays PDF presentation slides with style.
+Smooth alpha-blended slide transitions are provided for the sake of eye
+candy, but in addition to this, Impressive offers some unique tools that
+are very useful for presentations.
+
+WWW: http://impressive.sourceforge.net/