aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-17 20:07:24 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-09-27 17:21:36 +0000
commit3a2feaf0b266278e059c4eac36102b55e312312d (patch)
treef6d9f2e5f6bbbca93bc944dd7d4da352e390b451 /graphics
parentb10a4cc1b8b70d7b9d23efefbabaea513a187874 (diff)
downloadports-3a2feaf0b266278e059c4eac36102b55e312312d.tar.gz
ports-3a2feaf0b266278e059c4eac36102b55e312312d.zip
graphics/librsvg2-rust: update to 2.52.0
Changes: https://gitlab.gnome.org/GNOME/librsvg/-/blob/2.52.0/NEWS PR: 258561 Exp-run by: antoine Approved by: tcberner
Diffstat (limited to 'graphics')
-rw-r--r--graphics/librsvg2-rust/Makefile3
-rw-r--r--graphics/librsvg2-rust/distinfo6
-rw-r--r--graphics/librsvg2-rust/files/patch-powerpc62
-rw-r--r--graphics/librsvg2-rust/pkg-plist17
4 files changed, 15 insertions, 73 deletions
diff --git a/graphics/librsvg2-rust/Makefile b/graphics/librsvg2-rust/Makefile
index b71c5727e7fa..efced9676ac0 100644
--- a/graphics/librsvg2-rust/Makefile
+++ b/graphics/librsvg2-rust/Makefile
@@ -1,8 +1,7 @@
# Created by: Ade Lovett <ade@FreeBSD.org>
PORTNAME= librsvg
-PORTVERSION= 2.50.3
-PORTREVISION= 6
+PORTVERSION= 2.52.0
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX= 2-rust
diff --git a/graphics/librsvg2-rust/distinfo b/graphics/librsvg2-rust/distinfo
index 64cd76b91536..5fdea4e9dcbd 100644
--- a/graphics/librsvg2-rust/distinfo
+++ b/graphics/librsvg2-rust/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1612074594
-SHA256 (gnome2/librsvg-2.50.3.tar.xz) = a4298a98e3a95fdd73c858c17d4dd018525fb09dbb13bbd668a0c2243989e958
-SIZE (gnome2/librsvg-2.50.3.tar.xz) = 18868408
+TIMESTAMP = 1631578579
+SHA256 (gnome2/librsvg-2.52.0.tar.xz) = bd821fb3e16494b61f5185addd23b726b064f203122b3ab4b3d5d7a44e6bf393
+SIZE (gnome2/librsvg-2.52.0.tar.xz) = 23196792
diff --git a/graphics/librsvg2-rust/files/patch-powerpc b/graphics/librsvg2-rust/files/patch-powerpc
deleted file mode 100644
index 79df27fcf5ca..000000000000
--- a/graphics/librsvg2-rust/files/patch-powerpc
+++ /dev/null
@@ -1,62 +0,0 @@
---- vendor/libc/src/unix/bsd/freebsdlike/freebsd/mod.rs.orig 2020-03-17 20:35:43 UTC
-+++ vendor/libc/src/unix/bsd/freebsdlike/freebsd/mod.rs
-@@ -1486,6 +1486,9 @@ cfg_if! {
- } else if #[cfg(target_arch = "powerpc64")] {
- mod powerpc64;
- pub use self::powerpc64::*;
-+ } else if #[cfg(target_arch = "powerpc")] {
-+ mod powerpc;
-+ pub use self::powerpc::*;
- } else {
- // Unknown target_arch
- }
---- vendor/libc/src/unix/bsd/freebsdlike/freebsd/powerpc.rs.orig 2021-06-23 22:40:24 UTC
-+++ vendor/libc/src/unix/bsd/freebsdlike/freebsd/powerpc.rs
-@@ -0,0 +1,47 @@
-+pub type c_char = u8;
-+pub type c_long = i32;
-+pub type c_ulong = u32;
-+pub type wchar_t = i32;
-+pub type time_t = i64;
-+pub type suseconds_t = i32;
-+pub type register_t = i32;
-+
-+s! {
-+ pub struct stat {
-+ pub st_dev: ::dev_t,
-+ pub st_ino: ::ino_t,
-+ pub st_mode: ::mode_t,
-+ pub st_nlink: ::nlink_t,
-+ pub st_uid: ::uid_t,
-+ pub st_gid: ::gid_t,
-+ pub st_rdev: ::dev_t,
-+ pub st_atime: ::time_t,
-+ pub st_atime_nsec: ::c_long,
-+ pub st_mtime: ::time_t,
-+ pub st_mtime_nsec: ::c_long,
-+ pub st_ctime: ::time_t,
-+ pub st_ctime_nsec: ::c_long,
-+ pub st_size: ::off_t,
-+ pub st_blocks: ::blkcnt_t,
-+ pub st_blksize: ::blksize_t,
-+ pub st_flags: ::fflags_t,
-+ pub st_gen: u32,
-+ pub st_lspare: i32,
-+ pub st_birthtime: ::time_t,
-+ pub st_birthtime_nsec: ::c_long,
-+ }
-+}
-+
-+// should be pub(crate), but that requires Rust 1.18.0
-+cfg_if! {
-+ if #[cfg(libc_const_size_of)] {
-+ #[doc(hidden)]
-+ pub const _ALIGNBYTES: usize = ::mem::size_of::<::c_int>() - 1;
-+ } else {
-+ #[doc(hidden)]
-+ pub const _ALIGNBYTES: usize = 4 - 1;
-+ }
-+}
-+
-+pub const MAP_32BIT: ::c_int = 0x00080000;
-+pub const MINSIGSTKSZ: ::size_t = 2048; // 512 * 4
diff --git a/graphics/librsvg2-rust/pkg-plist b/graphics/librsvg2-rust/pkg-plist
index 24d1923167b2..a3e0f508e379 100644
--- a/graphics/librsvg2-rust/pkg-plist
+++ b/graphics/librsvg2-rust/pkg-plist
@@ -1,39 +1,44 @@
bin/rsvg-convert
-include/librsvg-2.0/librsvg/librsvg-features.h
include/librsvg-2.0/librsvg/rsvg-cairo.h
+include/librsvg-2.0/librsvg/rsvg-features.h
+include/librsvg-2.0/librsvg/rsvg-version.h
include/librsvg-2.0/librsvg/rsvg.h
lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders/libpixbufloader-svg.so
lib/girepository-1.0/Rsvg-2.0.typelib
lib/librsvg-2.so
lib/librsvg-2.so.2
-lib/librsvg-2.so.2.47.0
+lib/librsvg-2.so.2.48.0
libdata/pkgconfig/librsvg-2.0.pc
man/man1/rsvg-convert.1.gz
share/doc/rsvg-2.0/RsvgHandle.html
share/doc/rsvg-2.0/annotation-glossary.html
share/doc/rsvg-2.0/api-index-full.html
share/doc/rsvg-2.0/ch01.html
+share/doc/rsvg-2.0/ch01s02.html
+share/doc/rsvg-2.0/ch01s03.html
share/doc/rsvg-2.0/ch02.html
+share/doc/rsvg-2.0/ch03.html
share/doc/rsvg-2.0/home.png
share/doc/rsvg-2.0/index.html
share/doc/rsvg-2.0/left-insensitive.png
share/doc/rsvg-2.0/left.png
share/doc/rsvg-2.0/licence.html
+share/doc/rsvg-2.0/migrating-to-geometry-apis.html
share/doc/rsvg-2.0/object-tree.html
share/doc/rsvg-2.0/recommendations-assets.html
share/doc/rsvg-2.0/right-insensitive.png
share/doc/rsvg-2.0/right.png
share/doc/rsvg-2.0/rsvg-2.0.devhelp2
+share/doc/rsvg-2.0/rsvg-Deprecated-functions-to-render-to-GdkPixbuf.html
+share/doc/rsvg-2.0/rsvg-Deprecated-functions-to-render-with-Cairo.html
+share/doc/rsvg-2.0/rsvg-Using-RSVG-with-Cairo.html
share/doc/rsvg-2.0/rsvg-Using-RSVG-with-GIO.html
-share/doc/rsvg-2.0/rsvg-Using-RSVG-with-GdkPixbuf.html
-share/doc/rsvg-2.0/rsvg-Using-RSVG-with-cairo.html
-share/doc/rsvg-2.0/rsvg-Version-check-and-feature-tests.html
+share/doc/rsvg-2.0/rsvg-Version-checks.html
share/doc/rsvg-2.0/rsvg.html
share/doc/rsvg-2.0/style.css
share/doc/rsvg-2.0/up-insensitive.png
share/doc/rsvg-2.0/up.png
share/gir-1.0/Rsvg-2.0.gir
-share/locale/es/LC_MESSAGES/librsvg.mo
share/thumbnailers/librsvg.thumbnailer
share/vala/vapi/librsvg-2.0.vapi
@postexec %D/bin/gdk-pixbuf-query-loaders > /dev/null 2>&1 && %D/bin/gdk-pixbuf-query-loaders > %D/lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders.cache 2>/dev/null || /usr/bin/true