aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 14:15:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 14:15:03 +0000
commit44e9f64a275cdae1f2dd4bd1a517f48f9e075a81 (patch)
treec4ea42245d0b053c1a31462b408d6990c18047e0 /graphics
parent9c8b302188158c6ba8db4af427c7bcb6b2c9452c (diff)
downloadports-44e9f64a275cdae1f2dd4bd1a517f48f9e075a81.tar.gz
ports-44e9f64a275cdae1f2dd4bd1a517f48f9e075a81.zip
Convert LIB_DEPENDS for ports depending on boost
Notes
Notes: svn path=/head/; revision=336262
Diffstat (limited to 'graphics')
-rw-r--r--graphics/enblend/Makefile14
-rw-r--r--graphics/hugin/Makefile18
-rw-r--r--graphics/k3d/Makefile30
3 files changed, 31 insertions, 31 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index a315bd4822ae..98998d4c210c 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -13,13 +13,13 @@ COMMENT= Tool for image blending with multiresolution splines
BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo \
OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- lcms2:${PORTSDIR}/graphics/lcms2 \
- xmi:${PORTSDIR}/graphics/plotutils \
- tiff:${PORTSDIR}/graphics/tiff \
- boost_filesystem:${PORTSDIR}/devel/boost-libs \
- vigraimpex:${PORTSDIR}/graphics/vigra \
- gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libxmi.so:${PORTSDIR}/graphics/plotutils \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libvigraimpex.so:${PORTSDIR}/graphics/vigra \
+ libgsl.so:${PORTSDIR}/math/gsl
RUN_DEPENDS= OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
USE_AUTOTOOLS= automake:env autoconf:env
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 67d768f31483..21c42cd5af4a 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -10,15 +10,15 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
MAINTAINER= vd@FreeBSD.org
COMMENT= A GUI for Panorama Tools, to stitch panoramic images
-LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
- Imath:${PORTSDIR}/graphics/ilmbase \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- exiv2.12:${PORTSDIR}/graphics/exiv2 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- lensfun:${PORTSDIR}/graphics/lensfun \
- pano13:${PORTSDIR}/graphics/libpano13 \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libImath.so:${PORTSDIR}/graphics/ilmbase \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblensfun.so:${PORTSDIR}/graphics/lensfun \
+ libpano13.so:${PORTSDIR}/graphics/libpano13 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20 \
tclap>=1.2.1:${PORTSDIR}/devel/tclap
# gmake is really needed at _runtime_. Do not remove it from this list.
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index 7daff492ec15..c623bc6fb87a 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -16,15 +16,15 @@ LICENSE= GPLv2
BROKEN= Fails to configure
BUILD_DEPENDS= ${LOCALBASE}/include/gmm/gmm.h:${PORTSDIR}/math/gmm++
-LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs \
- execinfo:${PORTSDIR}/devel/libexecinfo \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- expat:${PORTSDIR}/textproc/expat2 \
- gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext \
- gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext \
+ libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
OPTIONS_DEFINE= 3DS COMPIZ GNOME PERFTOOLS GTS IMAGEMAGICK OPENEXR
3DS_DESC= 3ds_io plugin module
@@ -58,7 +58,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:M3DS}
-LIB_DEPENDS+= 3ds-1:${PORTSDIR}/graphics/lib3ds
+LIB_DEPENDS+= lib3ds-1.so:${PORTSDIR}/graphics/lib3ds
PLIST_SUB+= 3DS=""
.else
CMAKE_ARGS+= -DK3D_BUILD_3DS_IO_MODULE:BOOL=OFF
@@ -66,7 +66,7 @@ PLIST_SUB+= 3DS="@comment "
.endif
.if ${PORT_OPTIONS:MCOMPIZ}
-LIB_DEPENDS+= dbus-glib:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= libdbus-glib.so:${PORTSDIR}/devel/dbus-glib
PLIST_SUB+= COMPIZ=""
.else
CMAKE_ARGS+= -DK3D_BUILD_COMPIZ_MODULE:BOOL=OFF
@@ -82,7 +82,7 @@ PLIST_SUB+= GNOME="@comment "
.endif
.if ${PORT_OPTIONS:MPERFTOOLS}
-LIB_DEPENDS+= profiler:${PORTSDIR}/devel/google-perftools
+LIB_DEPENDS+= libprofiler.so:${PORTSDIR}/devel/google-perftools
PLIST_SUB+= PERFTOOLS=""
.else
CMAKE_ARGS+= -DK3D_BUILD_GOOGLE_PERFTOOLS_MODULE:BOOL=OFF
@@ -90,7 +90,7 @@ PLIST_SUB+= PERFTOOLS="@comment "
.endif
.if ${PORT_OPTIONS:MGTS}
-LIB_DEPENDS+= gts:${PORTSDIR}/graphics/gts
+LIB_DEPENDS+= libgts.so:${PORTSDIR}/graphics/gts
PLIST_SUB+= GTS=""
.else
CMAKE_ARGS+= -DK3D_BUILD_GTS_MODULE:BOOL=OFF
@@ -98,7 +98,7 @@ PLIST_SUB+= GTS="@comment "
.endif
.if ${PORT_OPTIONS:MIMAGEMAGICK}
-LIB_DEPENDS+= MagickCore:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= libMagickCore.so:${PORTSDIR}/graphics/ImageMagick
PLIST_SUB+= IMAGEMAGICK=""
.else
CMAKE_ARGS+= -DK3D_BUILD_IMAGEMAGICK_IO_MODULE:BOOL=OFF
@@ -106,7 +106,7 @@ PLIST_SUB+= IMAGEMAGICK="@comment "
.endif
.if ${PORT_OPTIONS:MOPENEXR}
-LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
PLIST_SUB+= OPENEXR=""
.else
CMAKE_ARGS+= -DK3D_BUILD_OPENEXR_IO_MODULE:BOOL=OFF