aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-09-13 05:56:27 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-09-13 05:56:27 +0000
commit4a3cd37d68ce1abe2aaac0a58f2905fd9a16416c (patch)
tree8e44f9812859aae12d16eac42cbab0716c5ba1d4 /graphics
parenteb4ff4867900e5e98cb15e18eef39ddc65d72d1a (diff)
downloadports-4a3cd37d68ce1abe2aaac0a58f2905fd9a16416c.tar.gz
ports-4a3cd37d68ce1abe2aaac0a58f2905fd9a16416c.zip
graphics/dssim: add new port
This tool computes (dis)similarity between two or more PNG images using an algorithm approximating human vision. Comparison is done in L*a*b* color space (D65 white point, sRGB gamma) using a multi-scale variant of the SSIM algorithm. Features: - Supports alpha channel - Supports gamma correction - No OpenCV or MATLAB needed: - DSSIM version 1.x uses C (C99) and libpng or Cocoa on macOS. - DSSIM version 2.x is easy to build with Rust https://kornel.ski/dssim
Notes
Notes: svn path=/head/; revision=548452
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/dssim/Makefile31
-rw-r--r--graphics/dssim/distinfo3
-rw-r--r--graphics/dssim/pkg-descr12
-rw-r--r--graphics/dssim/pkg-plist6
5 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 01ccba42c033..63b3bde8b71b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -141,6 +141,7 @@
SUBDIR += drm-legacy-kmod
SUBDIR += drm_info
SUBDIR += dspdfviewer
+ SUBDIR += dssim
SUBDIR += duhdraw
SUBDIR += dynamechs
SUBDIR += ebsynth
diff --git a/graphics/dssim/Makefile b/graphics/dssim/Makefile
new file mode 100644
index 000000000000..64f34d5550ad
--- /dev/null
+++ b/graphics/dssim/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= dssim
+DISTVERSION= 1.3.3-15
+DISTVERSIONSUFFIX= -gcb6b383
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Image similarity comparison simulating human perception
+
+LICENSE= AGPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpng.so:graphics/png
+
+USES= meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= kornelski
+
+OPTIONS_DEFINE= JPEG
+OPTIONS_DEFAULT=JPEG
+
+JPEG_USES= jpeg
+JPEG_MESON_ENABLED= jpeg
+
+post-patch:
+# Extract (snapshot) version from the port instead of meson.build
+ @${REINPLACE_CMD} "/^[[:space:]]*version : /s/'.*'/'${PORTVERSION}'/" \
+ ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/graphics/dssim/distinfo b/graphics/dssim/distinfo
new file mode 100644
index 000000000000..4ee6e9e7f030
--- /dev/null
+++ b/graphics/dssim/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1599972446
+SHA256 (kornelski-dssim-1.3.3-15-gcb6b383_GH0.tar.gz) = e4e7a89bd0b154e3ca8c54659047b73a696b521a5b127a36f662847d3da4a2be
+SIZE (kornelski-dssim-1.3.3-15-gcb6b383_GH0.tar.gz) = 36273
diff --git a/graphics/dssim/pkg-descr b/graphics/dssim/pkg-descr
new file mode 100644
index 000000000000..13f730d04440
--- /dev/null
+++ b/graphics/dssim/pkg-descr
@@ -0,0 +1,12 @@
+This tool computes (dis)similarity between two or more PNG images
+using an algorithm approximating human vision.
+
+Comparison is done in L*a*b* color space (D65 white point, sRGB gamma)
+using a multi-scale variant of the SSIM algorithm.
+
+Features:
+- Supports alpha channel
+- Supports gamma correction
+- No OpenCV or MATLAB needed: uses C (C99) and libpng
+
+WWW: https://kornel.ski/dssim
diff --git a/graphics/dssim/pkg-plist b/graphics/dssim/pkg-plist
new file mode 100644
index 000000000000..a98fff5fb1fb
--- /dev/null
+++ b/graphics/dssim/pkg-plist
@@ -0,0 +1,6 @@
+bin/dssim
+include/dssim.h
+lib/libdssim-lib.so
+lib/libdssim-lib.so.1
+lib/libdssim-lib.so.1.1
+libdata/pkgconfig/dssim.pc