aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-10 12:15:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-10 12:15:05 +0000
commit4a95deb63e8eb898869e8e2d61656e081b58b240 (patch)
tree0327ab4e05ba98cef17e51aa5d2caa00cce4bb27 /graphics
parentc44dbdddff3baa74c3501074c98f31eaf17e5242 (diff)
downloadports-4a95deb63e8eb898869e8e2d61656e081b58b240.tar.gz
ports-4a95deb63e8eb898869e8e2d61656e081b58b240.zip
- Enable TOOLS by default
- Fix build with TOOLS on 9.x - While here, cosmetic fixes PR: 212045 Submitted by: pkubaj@anongoth.pl (maintainer)
Notes
Notes: svn path=/head/; revision=421687
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tesseract/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/graphics/tesseract/Makefile b/graphics/tesseract/Makefile
index 111624ab483e..8eb49d18efe6 100644
--- a/graphics/tesseract/Makefile
+++ b/graphics/tesseract/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tesseract
PORTVERSION= 3.04.01
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= pkubaj@anongoth.pl
@@ -28,18 +29,19 @@ PORTEXAMPLES= eurotext.tif phototest.tif
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DOCS EXAMPLES TOOLS
+OPTIONS_DEFAULT=TOOLS
OPTIONS_SUB= yes
TOOLS_DESC= Include training tools
TOOLS_LIB_DEPENDS=libicui18n.so:devel/icu \
libfontconfig.so:x11-fonts/fontconfig
-TOOLS_USES= pkgconfig
+TOOLS_USES= compiler:c++11-lib pkgconfig
TOOLS_USE= GNOME=cairo,glib20,pango
post-patch:
@${REINPLACE_CMD} -e 's|-O3 -DNDEBUG||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.in
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
post-build-TOOLS-on:
@cd ${WRKSRC} && ${MAKE} training
@@ -47,10 +49,12 @@ post-build-TOOLS-on:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} testing/eurotext.tif \
+ cd ${WRKSRC} && ${INSTALL_DATA} testing/eurotext.tif \
testing/phototest.tif ${STAGEDIR}${EXAMPLESDIR}
+
post-install-TOOLS-on:
@cd ${WRKSRC} && ${MAKE} DESTDIR=${STAGEDIR} training-install