aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-17 08:56:59 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-17 08:56:59 +0000
commit6b56da54fd8ef3acbd3ce34fbe93e1f6d4faee4b (patch)
tree949543711f0b1d55d31a6b9de3fffd2f6da61216 /graphics
parentc6fb4c349d01dc41a94ff7cfc68bd1ae2d8cb443 (diff)
downloadports-6b56da54fd8ef3acbd3ce34fbe93e1f6d4faee4b.tar.gz
ports-6b56da54fd8ef3acbd3ce34fbe93e1f6d4faee4b.zip
Update to 0.91. Changes: adds support for the USB versions; adds
CUPS support. I was hoping to test this on 5.x (where my own hpoj device currently lives) but I forgot about the unrelated compile problem (ffs conflict). I will undertake to add that to my list of things to do since it also affects cqcam which I also use. (I will happily accept any pointers to anyone who has solved this problem in some other port). PR: ports/60064 Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de> (maintainer)
Notes
Notes: svn path=/head/; revision=96026
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hpoj/Makefile22
-rw-r--r--graphics/hpoj/distinfo2
-rw-r--r--graphics/hpoj/pkg-descr2
-rw-r--r--graphics/hpoj/pkg-plist1
4 files changed, 20 insertions, 7 deletions
diff --git a/graphics/hpoj/Makefile b/graphics/hpoj/Makefile
index 7a05055f3da7..533b5af04555 100644
--- a/graphics/hpoj/Makefile
+++ b/graphics/hpoj/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= hpoj
-PORTVERSION= 0.90
-PORTREVISION= 1
+PORTVERSION= 0.91
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hpoj
@@ -18,9 +17,22 @@ MAINTAINER= stolz@i2.informatik.rwth-aachen.de
COMMENT= "HP OfficeJet Linux driver; printing, scanning, and photo-card access"
LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends \
- snmp.4:${PORTSDIR}/net/net-snmp4
+ snmp.4:${PORTSDIR}/net/net-snmp4 \
+ usb:${PORTSDIR}/devel/libusb
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+.if !defined(WITHOUT_CUPS)
+WITH_CUPS= yes
+.endif
+
+.if defined(WITH_CUPS)
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+CONFIGURE_ARGS+=--with-cups-backend=${LOCALBASE}/libexec/cups/backend
+PLIST_SUB+= CUPS=""
+.else
+PLIST_SUB+= CUPS="@comment "
+.endif
+
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
@@ -53,12 +65,14 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib ${PTHREAD_CFLAGS}"
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -lcipher -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.ifdef(WITHOUT_X11)
-CONFIGURE_ARGS= --without-qt
+CONFIGURE_ARGS+= --without-qt
.endif
pre-fetch:
@${ECHO} You can disable building \'xojpanel\' and avoid the dependency on X11 and QT3 \
by restarting the build with WITHOUT_X11
+ @${ECHO} You can disable CUPS support with WITHOUT_CUPS
+
post-patch:
.for f in doc/info-devname.html doc/libptal.html doc/ptal-init.html doc/setup-photo-details.html \
doc/setup-print-details.html lib/ptal/ptal.c scripts/ptal-init.in
diff --git a/graphics/hpoj/distinfo b/graphics/hpoj/distinfo
index 5c7d5a23d3cd..57b72f74f9e8 100644
--- a/graphics/hpoj/distinfo
+++ b/graphics/hpoj/distinfo
@@ -1 +1 @@
-MD5 (hpoj-0.90.tgz) = dd76385c20bccabf6f5446b1004d8372
+MD5 (hpoj-0.91.tgz) = 0e083aeab9b00495aa433fa9465456e0
diff --git a/graphics/hpoj/pkg-descr b/graphics/hpoj/pkg-descr
index daead8c0142c..30df50301e79 100644
--- a/graphics/hpoj/pkg-descr
+++ b/graphics/hpoj/pkg-descr
@@ -3,8 +3,6 @@ develop Linux support for most Hewlett-Packard OfficeJet,
PSC, LaserJet, and PhotoSmart printer multi-function
peripherals (MFPs), which depending on the model can print,
scan, copy, fax, and/or access digital camera memory cards.
-Only the parallel port and JetDirect (no USB!) are supported
-under FreeBSD.
Includes a xsane plugin.
diff --git a/graphics/hpoj/pkg-plist b/graphics/hpoj/pkg-plist
index 314d43d95a64..8b4d453946bc 100644
--- a/graphics/hpoj/pkg-plist
+++ b/graphics/hpoj/pkg-plist
@@ -20,6 +20,7 @@ lib/libsane-hpoj.so.1
include/hpojip.h
include/ptal.h
etc/rc.d/ptal-init.sh.sample
+%%CUPS%%libexec/cups/backend/ptal
%%PORTDOCS%%share/doc/hpoj/COPYING
%%PORTDOCS%%share/doc/hpoj/LICENSE
%%PORTDOCS%%share/doc/hpoj/LICENSE.OpenSSL