aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-14 00:17:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-14 00:17:15 +0000
commit6e0cfa00e05423f3755fd45078b98f8fc340c806 (patch)
treec2cee741e9cbcef42cc985d2ce28dc0c6b6e5f87 /graphics
parent99b685a330b333843ab39bb7bf8acbaf73b65b17 (diff)
downloadports-6e0cfa00e05423f3755fd45078b98f8fc340c806.tar.gz
ports-6e0cfa00e05423f3755fd45078b98f8fc340c806.zip
Add robot, a data plotting and analysis tool for XView toolkit.
PR: ports/57871 Submitted by: Pedro F. Giffuni <giffunip@yahoo.com>
Notes
Notes: svn path=/head/; revision=95762
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/robot/Makefile47
-rw-r--r--graphics/robot/distinfo1
-rw-r--r--graphics/robot/files/ARK+Makefile28
-rw-r--r--graphics/robot/files/patch-ARK+Makefile27
-rw-r--r--graphics/robot/files/patch-Makefile28
-rw-r--r--graphics/robot/files/patch-Robot+Makefile126
-rw-r--r--graphics/robot/files/patch-Robot+main.c35
-rw-r--r--graphics/robot/files/patch-Robot+register.c14
-rw-r--r--graphics/robot/pkg-descr14
-rw-r--r--graphics/robot/pkg-plist22
11 files changed, 343 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f5f7fd3efddb..652c9f84caad 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -334,6 +334,7 @@
SUBDIR += rayshade
SUBDIR += reallyslick
SUBDIR += renderpark
+ SUBDIR += robot
SUBDIR += ruby-evas
SUBDIR += ruby-gd
SUBDIR += ruby-gdchart
diff --git a/graphics/robot/Makefile b/graphics/robot/Makefile
new file mode 100644
index 000000000000..80aec2fb7414
--- /dev/null
+++ b/graphics/robot/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: robot
+# Date created: 11 October 2003
+# Whom: Pedro F. Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= robot
+PORTVERSION= 4.93.89
+CATEGORIES= graphics
+MASTER_SITES= ftp://lheaftp.gsfc.nasa.gov/pub/corbet/robot/
+DISTNAME= robot-beta
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Graph plotting and data analysis program using OpenLook
+
+BUILD_DEPENDS= fsplit:${PORTSDIR}/devel/fortran-utils
+LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
+
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+MAKE_ENV+= OPENWINHOME=${X11BASE}
+WEB_BROWSER?= mozilla
+
+pre-build:
+ @${REINPLACE_CMD} -e 's+netscape+${WEB_BROWSER}+ ' \
+ ${WRKSRC}/Robot/Makefile
+
+MANL= robot.l
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Robot/robot ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib/help
+ ${INSTALL_DATA} ${WRKSRC}/Docs/robot.info ${PREFIX}/lib/help
+ ${INSTALL_MAN} ${WRKSRC}/Docs/robot.man ${PREFIX}/man/manl/robot.l
+.ifndef NOPORTDOCS
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Docs/RobotManual.ps ${DOCSDIR}
+ @${GZIP_CMD} ${DOCSDIR}/RobotManual.ps
+ @${REINPLACE_CMD} -e 's+/usr/bin+${PREFIX}/bin+ ' \
+ ${WRKSRC}/Demos/*.rob
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Demos/*.rob ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/robot/distinfo b/graphics/robot/distinfo
new file mode 100644
index 000000000000..0c0b70bac7c4
--- /dev/null
+++ b/graphics/robot/distinfo
@@ -0,0 +1 @@
+MD5 (robot-beta.tar.gz) = ded1147f41e643c792d4b1d792737571
diff --git a/graphics/robot/files/ARK+Makefile b/graphics/robot/files/ARK+Makefile
new file mode 100644
index 000000000000..3826237b26c2
--- /dev/null
+++ b/graphics/robot/files/ARK+Makefile
@@ -0,0 +1,28 @@
+--- ARK/Makefile.orig Fri Oct 10 15:12:44 2003
++++ ARK/Makefile Sat Oct 11 13:04:21 2003
+@@ -1,12 +1,12 @@
+ #CC = gcc -ansi
+-CC = gcc
++CC ?= cc
+ #CC = cc
+-FC = f77
++FC ?= f77
+ #FC = g77
+
+ INCLUDE = ${OPENWINHOME}/include
+ #CFLAGS = -Wall
+-CFLAGS = -O
++#CFLAGS += -O
+ #CFLAGS = -g
+
+
+@@ -15,7 +15,8 @@
+ all: arkcplot.o ARKfort.o libark.a Makefile
+
+ arkcplot.o: arkcplot.c kana.h kana2.h
+- $(CC) -c $(CFLAGS) arkcplot.c -I$(INCLUDE) $(OS) -DLPR=\"$(LPR)\"
++ $(CC) -c $(CFLAGS) -I$(INCLUDE) $(OS) -DLPR=\"$(LPR)\" arkcplot.c
++
+ ARKfort.o: ARKfort.f axecom comfil typecom
+ $(FC) -c $(CFLAGS) ARKfort.f
+
diff --git a/graphics/robot/files/patch-ARK+Makefile b/graphics/robot/files/patch-ARK+Makefile
new file mode 100644
index 000000000000..f96c25506e70
--- /dev/null
+++ b/graphics/robot/files/patch-ARK+Makefile
@@ -0,0 +1,27 @@
+--- ARK/Makefile.orig Sat Oct 11 14:58:54 2003
++++ ARK/Makefile Sat Oct 11 15:00:04 2003
+@@ -1,12 +1,12 @@
+ #CC = gcc -ansi
+-CC = gcc
++#CC ?= cc
+ #CC = cc
+-FC = f77
++#FC ?= f77
+ #FC = g77
+
+ INCLUDE = ${OPENWINHOME}/include
+ #CFLAGS = -Wall
+-CFLAGS = -O
++#CFLAGS += -O
+ #CFLAGS = -g
+
+
+@@ -17,7 +17,7 @@
+ arkcplot.o: arkcplot.c kana.h kana2.h
+ $(CC) -c $(CFLAGS) arkcplot.c -I$(INCLUDE) $(OS) -DLPR=\"$(LPR)\"
+ ARKfort.o: ARKfort.f axecom comfil typecom
+- $(FC) -c $(CFLAGS) ARKfort.f
++ $(FC) -c $(FFLAGS) ARKfort.f
+
+ libark.a: ARKfort.o arkcplot.o
+ ar rv $@ $?
diff --git a/graphics/robot/files/patch-Makefile b/graphics/robot/files/patch-Makefile
new file mode 100644
index 000000000000..ef5ae5a5e7d2
--- /dev/null
+++ b/graphics/robot/files/patch-Makefile
@@ -0,0 +1,28 @@
+--- Makefile.orig Fri Oct 10 15:14:19 2003
++++ Makefile Fri Oct 10 17:32:56 2003
+@@ -3,7 +3,7 @@
+ #
+ # The default is to use a FORTRAN compiler
+ all:
+- (cd Robot; make)
++ (cd Robot; ${MAKE})
+ # This is if you are going to use f2c instead of a FORTRAN compiler
+ f2c:
+ (cd Robot; make -f makefile.f2c)
+@@ -21,11 +21,11 @@
+ (cd Robot; make solaris)
+
+ clean:
+- (cd Robot; make clean)
+- (cd Fitsio; make clean)
+- (cd ARK; make clean)
+- (cd ARKc; make clean)
+- (cd Fitsioc; make clean)
++ (cd Robot; ${MAKE} clean)
++ (cd Fitsio; ${MAKE} clean)
++ (cd ARK; ${MAKE} clean)
++ (cd ARKc; ${MAKE} clean)
++ (cd Fitsioc; ${MAKE} clean)
+
+ # gets rid of even more than "clean" -e.g. 'C' files created by
+ # f2c
diff --git a/graphics/robot/files/patch-Robot+Makefile b/graphics/robot/files/patch-Robot+Makefile
new file mode 100644
index 000000000000..6639d720a2af
--- /dev/null
+++ b/graphics/robot/files/patch-Robot+Makefile
@@ -0,0 +1,126 @@
+--- Robot/Makefile.orig Wed Apr 23 17:04:37 2003
++++ Robot/Makefile Sat Oct 11 15:31:37 2003
+@@ -7,7 +7,7 @@
+
+ ARRAYSIZE = 64000
+
+-# Where will Robot try and look for help about itself with (e.g.) netscape?
++# Where will Robot try and look for help about itself with (e.g.) mozilla?
+ WEB_HELP = http://www.robotx.cx/
+
+ # and give option to use a different browser if really wanted
+@@ -15,28 +15,28 @@
+
+
+ # define system utilities - i.e. mail and print
+-MAILER = /bin/mail
++MAILER = /usr/bin/mail
+ # Either lpr, lp, or enscript/genscript may be used to print
+-#LPR = /usr/ucb/lpr
++#LPR = /usr/bin/lpr
+ #LPR = /bin/lp
+ LPR = lpr
+
+ # installation directory - this is used both if a "make install" is
+ # done and also used to add path to robot at top of log files
+-INSTDIR = $(HOME)/bin/
++INSTDIR = ${PREFIX}/bin/
+ #INSTDIR = /usr/local/bin
+
+
+ # define compilers
+ #CC = cc
+-CC = gcc
++CC ?= cc
+ #FC = g77
+-FC = f77
++FC ?= f77
+ # define compile options here if required,
+ # e.g. debug
+ # CFLAGS = -g
+ # or optimize (if you have enough swap space)
+- CFLAGS = -O
++CFLAGS += -O
+ # or nothing at all
+ # CFLAGS =
+
+@@ -45,7 +45,6 @@
+ # Check array boundaries
+ # FFLAGS = -C
+
+-
+ # specify here the directory where the openwindow include
+ # files are kept
+ # INCLUDE = /usr/local/openwin/include
+@@ -63,15 +62,15 @@
+ #F77LIB = -lF77
+
+ #X library - may need to edit if location different
+-XLIB = -L/usr/X11R6/lib -lX11
++XLIB = -L${X11BASE}/lib -lX11
+
+ # location of the FITS library
+ FITSDIR = ../Fitsio/
+ FITSLIB = $(FITSDIR)libfits.a
+
+ # if USA is defined we make some attempt to use USA spellings
+-LANGUAGE = -DUSA
+-#LANGUAGE = -DUK
++#LANGUAGE = -DUSA
++LANGUAGE = -DUK #UK is more international
+
+
+ # This specifies the location of the graphics routines in
+@@ -79,7 +78,7 @@
+ ARKDIR = ../ARK/
+ ARKLIB = $(ARKDIR)libark.a
+ # place to put the robot.info file
+-HELPDIR = /home/heasfs/corbet/help
++HELPDIR = ${PREFIX}/lib/X11/help
+
+ OBJS = robot.o subroutines.o subroutines2.o subroutines3.o \
+ user.o main.o rfitsf.o rfitsc.o fits3d.o york.o classify.o \
+@@ -109,11 +108,11 @@
+ "OLLIBS=$(OPENWINHOME)/lib/libxview.so $(OPENWINHOME)/lib/libolgx.so"
+
+ FITSLIB:
+- (cd $(FITSDIR); make libfits.a)
++ (cd $(FITSDIR); ${MAKE} libfits.a)
+ ARKLIB:
+- (cd $(ARKDIR); make libark.a "OS=$(OS)" "LPR=$(LPR)")
++ (cd $(ARKDIR); ${MAKE} libark.a "OS=$(OS)" "LPR=$(LPR)")
+ robot.o: robot.f robcom msizcom fitcom
+- $(FC) -c -Nx300 $(CFLAGS) $(FFLAGS) robot.f
++ $(FC) -c $(CFLAGS) $(FFLAGS) robot.f
+ subroutines.o: subroutines.f robcom fitcom
+ $(FC) -c $(CFLAGS) $(FFLAGS) subroutines.f
+ subroutines2.o: subroutines2.f robcom msizcom fitcom
+@@ -121,7 +120,7 @@
+ subroutines3.o: subroutines3.f robcom msizcom
+ $(FC) -c $(CFLAGS) $(FFLAGS) subroutines3.f
+ nr.o: nr.f robcom
+- $(FC) -c $(CFLAGS) nr.f
++ $(FC) -c $(FFLAGS) nr.f
+ main.o: main.c robot.h patchlevel.h
+ $(CC) -c $(CFLAGS) main.c -I$(INCLUDE) $(LANGUAGE) $(OS) -DARRAYSIZE=$(ARRAYSIZE) -DINSTDIR=\"$(INSTDIR)\" -DWEB_HELP=\"$(WEB_HELP)\"
+ colors.o: colors.c
+@@ -155,15 +154,15 @@
+ math.o: math.c
+ $(CC) -c $(CFLAGS) math.c
+ user.o: user.f
+- $(FC) -c $(CFLAGS) user.f
++ $(FC) -c $(FFLAGS) user.f
+ york.o: york.f robcom
+- $(FC) -c $(CFLAGS) york.f
++ $(FC) -c $(FFLAGS) york.f
+ rfitsf.o: rfitsf.f robcom
+- $(FC) -c $(CFLAGS) rfitsf.f
++ $(FC) -c $(FFLAGS) rfitsf.f
+ rfitsc.o: rfitsc.c
+ $(CC) -c $(CFLAGS) rfitsc.c
+ fits3d.o: fits3d.f robcom
+- $(FC) -c $(CFLAGS) fits3d.f
++ $(FC) -c $(FFLAGS) fits3d.f
+ classify.o: classify.c
+ $(CC) -c $(CFLAGS) classify.c
+ backup:
diff --git a/graphics/robot/files/patch-Robot+main.c b/graphics/robot/files/patch-Robot+main.c
new file mode 100644
index 000000000000..52638a9c2962
--- /dev/null
+++ b/graphics/robot/files/patch-Robot+main.c
@@ -0,0 +1,35 @@
+--- Robot/main.c.orig Sat Oct 11 13:14:19 2003
++++ Robot/main.c Sat Oct 11 13:22:51 2003
+@@ -539,20 +539,19 @@
+ || streq(argv[i], "--help") ){
+ printf("Robot version %-1.2f patch %d\n\n",
+ VERSION, PATCHLEVEL);
+- printf("robot (generic-tool-options)\n\
+--arraysize [size of arrays, default is %d]\n\
+--plotscale [scale factor]\n\
+--portrait\n\
+--landscape (default)\n\
+--notol (not Open-look - adds some extra quit buttons)\n\
+--stdin (reads commands from standard input instead of GUI)\n\
+--v (print version number and quit)\n\
+--help/-h (prints this information and quits)\n\
+-(optional command file name)\n\n\
++ printf("robot (generic-tool-options)\n");
++printf("-arraysize [size of arrays, default is %d]\n");
++printf("-plotscale [scale factor]\n");
++printf("-portrait\n");
++printf("-landscape (default)\n");
++printf("-notol (not Open-look - adds some extra quit buttons)\n");
++printf("-stdin (reads commands from standard input instead of GUI)\n");
++printf("-v (print version number and quit)\n");
++printf("-help/-h (prints this information and quits)\n");
++printf("(optional command file name)\n\n");
+
+-For more information see help available in the program under\n\
+-the \"About\" option or visit:\n\
+-%s\n", msize, WEB_HELP);
++printf("For more information see help available in the program under\n");
++printf("the \"About\" option or visit:\n\%s\n", msize, WEB_HELP);
+ fstop_();
+ }
+
diff --git a/graphics/robot/files/patch-Robot+register.c b/graphics/robot/files/patch-Robot+register.c
new file mode 100644
index 000000000000..9fb5927fcdb2
--- /dev/null
+++ b/graphics/robot/files/patch-Robot+register.c
@@ -0,0 +1,14 @@
+--- Robot/register.c.orig Tue Oct 7 14:47:40 2003
++++ Robot/register.c Tue Oct 7 14:49:02 2003
+@@ -16,7 +16,11 @@
+
+ #include <stdio.h>
+ #include <sys/utsname.h>
++#ifndef __STDC__
+ #include <malloc.h>
++#else
++#include <stdlib.h>
++#endif
+
+ #include <xview/xview.h>
+ #include <xview/frame.h>
diff --git a/graphics/robot/pkg-descr b/graphics/robot/pkg-descr
new file mode 100644
index 000000000000..e14cb5e2a4ae
--- /dev/null
+++ b/graphics/robot/pkg-descr
@@ -0,0 +1,14 @@
+Robot is a general purpose open-source plotting and data analysis program.
+The main documentation is contained in the file Docs/RobotManual.ps.
+
+If you publish a paper in a journal which includes a graph produced by
+Robot I'd be grateful if you could send me a reprint.
+If you wish to cite this program you may reference: Corbet, R.H.D.,
+Larkin, C. & Nousek, J.A. Proceedings of "Astronomical Data Analysis and
+Software Systems", Tucson, November, 1991. Astronomical Society of the
+Pacific Conference Series, 1992, Vol. 25, 106. (ISBN 0-937707-44-9)
+
+______
+Robin Corbet
+
+WWW: http://www.robotx.cx/
diff --git a/graphics/robot/pkg-plist b/graphics/robot/pkg-plist
new file mode 100644
index 000000000000..f71a3d3044c3
--- /dev/null
+++ b/graphics/robot/pkg-plist
@@ -0,0 +1,22 @@
+bin/robot
+lib/help/robot.info
+%%PORTDOCS%%%%DOCSDIR%%/RobotManual.ps.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/3d_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/anime_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/axes_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/color_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/fit1_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/fit1b_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/fit2_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/fit3_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/font_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/insert_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/japan_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/logplot_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/mix_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/simple_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/sinplot_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/style_demo.rob
+%%PORTDOCS%%%%EXAMPLESDIR%%/title_demo.rob
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%