aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-09-14 07:49:50 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-09-14 07:49:50 +0000
commit70851ba4626ae45fcedcf86724bb884f6c9f3291 (patch)
tree14404f46c1c05196140a35390cd1cced47281afe /graphics
parentcdc024ef7e090840c62eaacab5305bc54554eb5e (diff)
downloadports-70851ba4626ae45fcedcf86724bb884f6c9f3291.tar.gz
ports-70851ba4626ae45fcedcf86724bb884f6c9f3291.zip
graphics/piglit: Update to latest upstream
Update to upstream. Patches comes from a MR opened upstream. Remove opencl dependancy, I haven't try it yet and will be dealt with in a futur update. Remove wayland option, wayland is always needed now. piglit is a test suite and we want to test everything, it's also not intented for users to use but only developpers. Reviewed by: x11 (zeising@) Differential Revision: https://reviews.freebsd.org/D26396
Notes
Notes: svn path=/head/; revision=548592
Diffstat (limited to 'graphics')
-rw-r--r--graphics/piglit/Makefile59
-rw-r--r--graphics/piglit/distinfo20
-rw-r--r--graphics/piglit/files/patch-CMakeLists.txt11
-rw-r--r--graphics/piglit/files/patch-tests_egl_egl-context-priority.c13
-rw-r--r--graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-in-block.shader__test16
-rw-r--r--graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-not-in-block.shader__test16
-rw-r--r--graphics/piglit/files/pkg-message.in2
-rw-r--r--graphics/piglit/pkg-plist40
8 files changed, 75 insertions, 102 deletions
diff --git a/graphics/piglit/Makefile b/graphics/piglit/Makefile
index 0d36e899b856..4a1ed8454986 100644
--- a/graphics/piglit/Makefile
+++ b/graphics/piglit/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= piglit
-PORTVERSION= 20180910
-PORTREVISION= 3
+PORTVERSION= 20200910
CATEGORIES= graphics
MAINTAINER= x11@FreeBSD.org
@@ -13,35 +12,43 @@ LICENSE= MIT GPLv2 GPLv3 LGPL20
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-09-15
-
-BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl \
- ${PYNUMPY} \
+BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-LIB_DEPENDS= libcaca.so:graphics/libcaca \
- libdrm.so:graphics/libdrm \
- libOpenCL.so:devel/ocl-icd \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ vulkan-headers>0:devel/vulkan-headers \
+ wayland-protocols>=0:graphics/wayland-protocols
+LIB_DEPENDS= libdrm.so:graphics/libdrm \
libpng.so:graphics/png \
- libwaffle-1.so:graphics/waffle
+ libvulkan.so:graphics/vulkan-loader \
+ libwaffle-1.so:graphics/waffle \
+ libwayland-egl.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-USE_GITHUB= yes
-GH_ACCOUNT= dumbbell
-GH_PROJECT= piglit
-GH_TAGNAME= a0db4427446ab50882a721ae3084fa26cc9e751a
-
-USES= cmake compiler:c11 gl pkgconfig python:2.7 shebangfix xorg
+USE_GITLAB= yes
+GL_SITE= https://gitlab.freedesktop.org
+GL_ACCOUNT= mesa
+GL_PROJECT= piglit
+GL_COMMIT= 136a7f5fa0703603be1ffb338abe4865e76a8058
+
+PATCH_SITES= https://gitlab.freedesktop.org/mesa/piglit/-/commit/
+PATCH_DIST_STRIP= -p1
+PATCHFILES+= 7f1916da04fc.patch # https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/383
+PATCHFILES+= c6a4d8aa8e68.patch # https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/383
+PATCHFILES+= 0443b6a18648.patch # https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/383
+PATCHFILES+= 96d8ddd0a658.patch # https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/383
+PATCHFILES+= d5f4cfd3b0da.patch # https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/383
+PATCHFILES+= 64c468c6c7e3.patch # https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/383
+PATCHFILES+= 681e86f53c2e.patch # https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/383
+
+USES= cmake compiler:c11 gl pkgconfig python:3.5+ shebangfix xorg
USE_GL= egl gbm gl glu
USE_XORG= x11 xcb xext xrender
SHEBANG_FILES= piglit
-CMAKE_ARGS+= -DPIGLIT_BUILD_CL_TESTS:BOOL=ON
-
-CMAKE_ARGS+= -DCMAKE_POLICY_DEFAULT_CMP0056:STRING=NEW
+CMAKE_ON= PIGLIT_BUILD_GLES2_TESTS PIGLIT_BUILD_GLES3_TESTS
LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES= pkg-message
@@ -49,14 +56,6 @@ SUB_FILES= pkg-message
DATADIR= ${PREFIX}/lib/piglit
PORTDATA= *
-OPTIONS_DEFINE= DOCS WAYLAND
-OPTIONS_DEFAULT=WAYLAND
-
-WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
- libxkbcommon.so:x11/libxkbcommon
-
-post-patch-WAYLAND-off:
- @${REINPLACE_CMD} -e '/pkg_check_modules.*wayland/d' \
- ${WRKSRC}/CMakeLists.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/piglit/distinfo b/graphics/piglit/distinfo
index 5b6e4e55c7bc..254bce73976d 100644
--- a/graphics/piglit/distinfo
+++ b/graphics/piglit/distinfo
@@ -1,3 +1,17 @@
-TIMESTAMP = 1536577804
-SHA256 (dumbbell-piglit-20180910-a0db4427446ab50882a721ae3084fa26cc9e751a_GH0.tar.gz) = 68dd9a924438dd0a7b12d2f003340c7726523c333b6da86ee6ee33f99d4840da
-SIZE (dumbbell-piglit-20180910-a0db4427446ab50882a721ae3084fa26cc9e751a_GH0.tar.gz) = 24171368
+TIMESTAMP = 1599721915
+SHA256 (mesa-piglit-136a7f5fa0703603be1ffb338abe4865e76a8058_GL0.tar.gz) = ead4e41d9aeb694eeb2a0790a7415446e421e41dd72d1fa899a50db6c4195c59
+SIZE (mesa-piglit-136a7f5fa0703603be1ffb338abe4865e76a8058_GL0.tar.gz) = 24433616
+SHA256 (7f1916da04fc.patch) = 78a30b68c59cc9aaf6bbcccfde2d12e9f43d4e49153c8710dc99362c81d8ca17
+SIZE (7f1916da04fc.patch) = 774
+SHA256 (c6a4d8aa8e68.patch) = 6bccb2b4f1beba22e842b5883f7b1ec0fa53e971dc96d1a51a9d7fe66970e01e
+SIZE (c6a4d8aa8e68.patch) = 840
+SHA256 (0443b6a18648.patch) = bf74233898eeb709e0c79f9603d0be5b857d16fbac66ac7069033f7cf2eb7c8a
+SIZE (0443b6a18648.patch) = 718
+SHA256 (96d8ddd0a658.patch) = d6c362350f727066a6b03a9e12fbdb09ea3cc2df45bac8196c63b25d827d51eb
+SIZE (96d8ddd0a658.patch) = 928
+SHA256 (d5f4cfd3b0da.patch) = 5fdbd103f3a8a5e64c6ea49c1476b414323568bd8f2f33aea475be69cf956b3a
+SIZE (d5f4cfd3b0da.patch) = 1100
+SHA256 (64c468c6c7e3.patch) = 478ef23ccf707bb01536505509e6a09f97ab8a9c076fdd833972d626df4a8795
+SIZE (64c468c6c7e3.patch) = 760
+SHA256 (681e86f53c2e.patch) = 9a118396d6b7c893105354ab3b8e5c684b4e3683f87bbcaae9ccd74b63c21286
+SIZE (681e86f53c2e.patch) = 854
diff --git a/graphics/piglit/files/patch-CMakeLists.txt b/graphics/piglit/files/patch-CMakeLists.txt
deleted file mode 100644
index e4839f9a88cf..000000000000
--- a/graphics/piglit/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2017-09-22 14:56:21 UTC
-+++ CMakeLists.txt
-@@ -222,8 +222,6 @@ IF(PIGLIT_BUILD_GLX_TESTS)
- pkg_check_modules(GLPROTO REQUIRED glproto)
- ENDIF()
-
--set(Python_ADDITIONAL_VERSIONS
-- 3.7 3.6 3.5 3.4 2.7)
- find_package(PythonInterp REQUIRED)
- find_package(PythonSix 1.5.2 REQUIRED)
- find_package(PythonNumpy 1.7.0 REQUIRED)
diff --git a/graphics/piglit/files/patch-tests_egl_egl-context-priority.c b/graphics/piglit/files/patch-tests_egl_egl-context-priority.c
deleted file mode 100644
index 582e14edc55f..000000000000
--- a/graphics/piglit/files/patch-tests_egl_egl-context-priority.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- tests/egl/egl-context-priority.c.orig 2019-12-26 13:24:57 UTC
-+++ tests/egl/egl-context-priority.c
-@@ -24,6 +24,10 @@
- #include "piglit-util-egl.h"
- #include "piglit-util-gl.h"
-
-+#ifndef EGL_NO_CONFIG_MESA
-+#define EGL_NO_CONFIG_MESA ((EGLConfig)0)
-+#endif
-+
- /**
- * @file egl-context-priority.c
- *
diff --git a/graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-in-block.shader__test b/graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-in-block.shader__test
deleted file mode 100644
index bf5f71efc997..000000000000
--- a/graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-in-block.shader__test
+++ /dev/null
@@ -1,16 +0,0 @@
---- tests/spec/oes_geometry_shader/sso_validation/user-defined-gs-input-in-block.shader_test.orig 2016-08-09 20:28:45 UTC
-+++ tests/spec/oes_geometry_shader/sso_validation/user-defined-gs-input-in-block.shader_test
-@@ -1,5 +1,5 @@
- [require]
--GL ES >= 3.1
-+GL ES >= 3.0
- GLSL ES >= 3.10
- GL_OES_geometry_shader
- SSO ENABLED
-@@ -67,4 +67,4 @@ void main()
-
- [test]
- draw rect -1 -1 2 2
--probe all rgba 0.0 1.0 0.0 1.0
-\ No newline at end of file
-+probe all rgba 0.0 1.0 0.0 1.0
diff --git a/graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-not-in-block.shader__test b/graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-not-in-block.shader__test
deleted file mode 100644
index ace4e1f49abf..000000000000
--- a/graphics/piglit/files/patch-tests_spec_oes__geometry__shader_sso__validation_user-defined-gs-input-not-in-block.shader__test
+++ /dev/null
@@ -1,16 +0,0 @@
---- tests/spec/oes_geometry_shader/sso_validation/user-defined-gs-input-not-in-block.shader_test.orig 2016-08-09 20:28:45 UTC
-+++ tests/spec/oes_geometry_shader/sso_validation/user-defined-gs-input-not-in-block.shader_test
-@@ -1,5 +1,5 @@
- [require]
--GL ES >= 3.1
-+GL ES >= 3.0
- GLSL ES >= 3.10
- GL_OES_geometry_shader
- SSO ENABLED
-@@ -62,4 +62,4 @@ void main()
-
- [test]
- draw rect -1 -1 2 2
--probe all rgba 0.0 1.0 0.0 1.0
-\ No newline at end of file
-+probe all rgba 0.0 1.0 0.0 1.0
diff --git a/graphics/piglit/files/pkg-message.in b/graphics/piglit/files/pkg-message.in
index ef2bc27a0824..e6430095af56 100644
--- a/graphics/piglit/files/pkg-message.in
+++ b/graphics/piglit/files/pkg-message.in
@@ -10,7 +10,7 @@ Instructions to use Piglit are available in:
%%DOCSDIR%%/README.md
The same documentation is also available online:
- http://cgit.freedesktop.org/piglit/tree/README
+ https://gitlab.freedesktop.org/mesa/piglit/-/blob/master/README.md
EOM
}
]
diff --git a/graphics/piglit/pkg-plist b/graphics/piglit/pkg-plist
index 642b5de5ce81..47e4c52cace3 100644
--- a/graphics/piglit/pkg-plist
+++ b/graphics/piglit/pkg-plist
@@ -2,13 +2,19 @@ bin/piglit
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/RELEASE
-@dir %%DATADIR%%/generated_tests/modules
+@dir %%DATADIR%%/framework/__pycache__
+@dir %%DATADIR%%/framework/test/__pycache__
+@dir %%DATADIR%%/generated_tests/__pycache__
+@dir %%DATADIR%%/generated_tests/modules/__pycache__
+@dir %%DATADIR%%/generated_tests/templates/__pycache__
@dir %%DATADIR%%/generated_tests/templates/gen_builtin_packing_tests
@dir %%DATADIR%%/generated_tests/templates/gen_const_builtin_equal_tests
@dir %%DATADIR%%/generated_tests/templates/gen_conversion
@dir %%DATADIR%%/generated_tests/templates/gen_extensions_defined
@dir %%DATADIR%%/generated_tests/templates/gen_flat_interpolation_qualifier
+@dir %%DATADIR%%/generated_tests/templates/gen_gpu_shader4_tests
@dir %%DATADIR%%/generated_tests/templates/gen_inout_fp64
+@dir %%DATADIR%%/generated_tests/templates/gen_intel_shader_integer_functions2_tests
@dir %%DATADIR%%/generated_tests/templates/gen_interpolation_tests
@dir %%DATADIR%%/generated_tests/templates/gen_non-lvalue_tests
@dir %%DATADIR%%/generated_tests/templates/gen_outerproduct_invalid_params
@@ -23,11 +29,14 @@ bin/piglit
@dir %%DATADIR%%/generated_tests/templates/gen_vp_tex
@dir %%DATADIR%%/generated_tests/templates/gen_vs_in_fp64
@dir %%DATADIR%%/generated_tests/templates/interpolation-qualifier-built-in-variable
+@dir %%DATADIR%%/tests/__pycache__
@dir %%DATADIR%%/tests/cl/api
@dir %%DATADIR%%/tests/cl/custom
@dir %%DATADIR%%/tests/cl/interop
+@dir %%DATADIR%%/tests/egl/spec/egl-1.4
@dir %%DATADIR%%/tests/egl/spec/egl_chromium_sync_control
@dir %%DATADIR%%/tests/egl/spec/egl_ext_client_extensions
+@dir %%DATADIR%%/tests/egl/spec/egl_ext_device_base
@dir %%DATADIR%%/tests/egl/spec/egl_ext_device_drm
@dir %%DATADIR%%/tests/egl/spec/egl_ext_device_enumeration
@dir %%DATADIR%%/tests/egl/spec/egl_ext_device_query
@@ -40,20 +49,19 @@ bin/piglit
@dir %%DATADIR%%/tests/egl/spec/egl_khr_surfaceless_context
@dir %%DATADIR%%/tests/egl/spec/egl_mesa_device_software
@dir %%DATADIR%%/tests/egl/spec/egl_mesa_platform_surfaceless
-@dir %%DATADIR%%/tests/egl/spec/egl-1.4
+@dir %%DATADIR%%/tests/egl/spec/egl_mesa_query_driver
@dir %%DATADIR%%/tests/fbo
@dir %%DATADIR%%/tests/general
@dir %%DATADIR%%/tests/glx
@dir %%DATADIR%%/tests/hiz
@dir %%DATADIR%%/tests/perf
+@dir %%DATADIR%%/tests/py_modules/__pycache__
@dir %%DATADIR%%/tests/security
@dir %%DATADIR%%/tests/spec/amd_depth_clamp_separate
@dir %%DATADIR%%/tests/spec/amd_framebuffer_multisample_advanced
@dir %%DATADIR%%/tests/spec/amd_performance_monitor
@dir %%DATADIR%%/tests/spec/amd_pinned_memory
@dir %%DATADIR%%/tests/spec/amd_seamless_cubemap_per_texture
-@dir %%DATADIR%%/tests/spec/amd_vertex_shader_layer
-@dir %%DATADIR%%/tests/spec/amd_vertex_shader_viewport_index
@dir %%DATADIR%%/tests/spec/arb_base_instance
@dir %%DATADIR%%/tests/spec/arb_blend_func_extended/api
@dir %%DATADIR%%/tests/spec/arb_blend_func_extended/execution
@@ -73,12 +81,10 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/arb_draw_indirect
@dir %%DATADIR%%/tests/spec/arb_es2_compatibility
@dir %%DATADIR%%/tests/spec/arb_es3_compatibility
-@dir %%DATADIR%%/tests/spec/arb_fragment_shader_interlock
@dir %%DATADIR%%/tests/spec/arb_framebuffer_no_attachments
@dir %%DATADIR%%/tests/spec/arb_framebuffer_object
@dir %%DATADIR%%/tests/spec/arb_framebuffer_srgb
@dir %%DATADIR%%/tests/spec/arb_geometry_shader4/execution/program-parameter
-@dir %%DATADIR%%/tests/spec/arb_get_program_binary
@dir %%DATADIR%%/tests/spec/arb_get_texture_sub_image
@dir %%DATADIR%%/tests/spec/arb_gpu_shader_fp64/shader_storage
@dir %%DATADIR%%/tests/spec/arb_indirect_parameters
@@ -96,7 +102,6 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/arb_point_sprite
@dir %%DATADIR%%/tests/spec/arb_post_depth_coverage
@dir %%DATADIR%%/tests/spec/arb_program_interface_query
-@dir %%DATADIR%%/tests/spec/arb_provoking_vertex
@dir %%DATADIR%%/tests/spec/arb_query_buffer_object
@dir %%DATADIR%%/tests/spec/arb_robustness
@dir %%DATADIR%%/tests/spec/arb_sample_locations
@@ -121,9 +126,9 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/arb_texture_storage_multisample
@dir %%DATADIR%%/tests/spec/arb_texture_view
@dir %%DATADIR%%/tests/spec/arb_timer_query
-@dir %%DATADIR%%/tests/spec/arb_transform_feedback_overflow_query
@dir %%DATADIR%%/tests/spec/arb_transform_feedback2
@dir %%DATADIR%%/tests/spec/arb_transform_feedback3
+@dir %%DATADIR%%/tests/spec/arb_transform_feedback_overflow_query
@dir %%DATADIR%%/tests/spec/arb_vertex_array_bgra
@dir %%DATADIR%%/tests/spec/arb_vertex_array_object
@dir %%DATADIR%%/tests/spec/arb_vertex_buffer_object
@@ -133,8 +138,12 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/ati_draw_buffers
@dir %%DATADIR%%/tests/spec/ati_envmap_bumpmap
@dir %%DATADIR%%/tests/spec/ati_fragment_shader
+@dir %%DATADIR%%/tests/spec/ext_color_buffer_float
@dir %%DATADIR%%/tests/spec/ext_depth_bounds_test
+@dir %%DATADIR%%/tests/spec/ext_direct_state_access
@dir %%DATADIR%%/tests/spec/ext_disjoint_timer_query
+@dir %%DATADIR%%/tests/spec/ext_draw_instanced
+@dir %%DATADIR%%/tests/spec/ext_external_objects_fd
@dir %%DATADIR%%/tests/spec/ext_fog_coord
@dir %%DATADIR%%/tests/spec/ext_frag_depth
@dir %%DATADIR%%/tests/spec/ext_framebuffer_blit
@@ -142,15 +151,14 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/ext_framebuffer_multisample_blit_scaled
@dir %%DATADIR%%/tests/spec/ext_framebuffer_object
@dir %%DATADIR%%/tests/spec/ext_image_dma_buf_import
-@dir %%DATADIR%%/tests/spec/ext_memory_object
-@dir %%DATADIR%%/tests/spec/ext_memory_object_fd
@dir %%DATADIR%%/tests/spec/ext_occlusion_query_boolean
@dir %%DATADIR%%/tests/spec/ext_packed_depth_stencil
@dir %%DATADIR%%/tests/spec/ext_packed_float
@dir %%DATADIR%%/tests/spec/ext_polygon_offset_clamp
@dir %%DATADIR%%/tests/spec/ext_render_snorm
-@dir %%DATADIR%%/tests/spec/ext_semaphore
-@dir %%DATADIR%%/tests/spec/ext_semaphore_fd
+@dir %%DATADIR%%/tests/spec/ext_shader_image_load_store
+@dir %%DATADIR%%/tests/spec/ext_texture_compression_bptc
+@dir %%DATADIR%%/tests/spec/ext_texture_compression_rgtc
@dir %%DATADIR%%/tests/spec/ext_texture_env_combine
@dir %%DATADIR%%/tests/spec/ext_texture_format_bgra8888
@dir %%DATADIR%%/tests/spec/ext_texture_integer
@@ -171,6 +179,7 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/gl-3.0/api
@dir %%DATADIR%%/tests/spec/gl-3.2/layered-rendering
@dir %%DATADIR%%/tests/spec/gl-3.3
+@dir %%DATADIR%%/tests/spec/gl-4.1
@dir %%DATADIR%%/tests/spec/gl-4.3
@dir %%DATADIR%%/tests/spec/gl-4.4
@dir %%DATADIR%%/tests/spec/gl-4.5
@@ -185,9 +194,14 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/glx_oml_sync_control
@dir %%DATADIR%%/tests/spec/intel_blackhole_render
@dir %%DATADIR%%/tests/spec/intel_conservative_rasterization
+@dir %%DATADIR%%/tests/spec/intel_performance_query
@dir %%DATADIR%%/tests/spec/khr_debug
+@dir %%DATADIR%%/tests/spec/khr_parallel_shader_compile
@dir %%DATADIR%%/tests/spec/mesa_pack_invert
+@dir %%DATADIR%%/tests/spec/nv_alpha_to_coverage_dither_control
@dir %%DATADIR%%/tests/spec/nv_conditional_render
+@dir %%DATADIR%%/tests/spec/nv_copy_depth_to_color
+@dir %%DATADIR%%/tests/spec/nv_copy_image
@dir %%DATADIR%%/tests/spec/nv_fog_distance
@dir %%DATADIR%%/tests/spec/nv_image_formats
@dir %%DATADIR%%/tests/spec/nv_texture_barrier
@@ -195,9 +209,11 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/oes_compressed_paletted_texture
@dir %%DATADIR%%/tests/spec/oes_draw_elements_base_vertex
@dir %%DATADIR%%/tests/spec/oes_draw_texture
+@dir %%DATADIR%%/tests/spec/oes_egl_image_external_essl3
@dir %%DATADIR%%/tests/spec/oes_fixed_point
@dir %%DATADIR%%/tests/spec/oes_matrix_get
@dir %%DATADIR%%/tests/spec/oes_required_internalformat
@dir %%DATADIR%%/tests/spec/oes_texture_float
@dir %%DATADIR%%/tests/texturing/shaders
+@dir %%DATADIR%%/tests/util/msvc
@dir %%DATADIR%%/tests/wgl