aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-05-20 14:06:40 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-05-20 14:06:40 +0000
commit73c7b388a8324ff8d6a21387f404f730e6296a2d (patch)
treee072d83b40c3fd59ac43ee102f1810599fa7b5cb /graphics
parentb9ac4f9edb23eb5b3711d142eef5394b693d22dc (diff)
downloadports-73c7b388a8324ff8d6a21387f404f730e6296a2d.tar.gz
ports-73c7b388a8324ff8d6a21387f404f730e6296a2d.zip
graphics/shotwell: update to 0.30.16
Diffstat (limited to 'graphics')
-rw-r--r--graphics/shotwell/Makefile3
-rw-r--r--graphics/shotwell/distinfo6
-rw-r--r--graphics/shotwell/files/patch-facedetect_meson.build10
-rw-r--r--graphics/shotwell/files/patch-facedetect_shotwell-facedetect.cpp20
4 files changed, 4 insertions, 35 deletions
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index ac8eea654f29..abc27083112e 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -1,8 +1,7 @@
# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org> et al.
PORTNAME= shotwell
-PORTVERSION= 0.30.15
-PORTREVISION= 1
+PORTVERSION= 0.30.16
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
diff --git a/graphics/shotwell/distinfo b/graphics/shotwell/distinfo
index d5b2a32b6d95..cf9d36b74150 100644
--- a/graphics/shotwell/distinfo
+++ b/graphics/shotwell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649176255
-SHA256 (shotwell-0.30.15.tar.xz) = 3a52ad60b102da0df5f74db031c45d4ccf263513c954616ee1664bf4f4e9bdc9
-SIZE (shotwell-0.30.15.tar.xz) = 6533632
+TIMESTAMP = 1653051765
+SHA256 (shotwell-0.30.16.tar.xz) = c9882cfbdad303cb8161b149acbb4c617fbe7ca9f6ab6e22d174e2447e7518fa
+SIZE (shotwell-0.30.16.tar.xz) = 6532812
diff --git a/graphics/shotwell/files/patch-facedetect_meson.build b/graphics/shotwell/files/patch-facedetect_meson.build
deleted file mode 100644
index 851dc14bb6ac..000000000000
--- a/graphics/shotwell/files/patch-facedetect_meson.build
+++ /dev/null
@@ -1,10 +0,0 @@
---- facedetect/meson.build.orig 2020-11-05 20:48:33 UTC
-+++ facedetect/meson.build
-@@ -1,6 +1,6 @@
- subproject = ('facedetect')
- add_languages('cpp')
--facedetect_dep = dependency('opencv', version : ['>= 2.3.0'], required : true)
-+facedetect_dep = dependency('opencv4', version : ['>= 4.0.0'], required : true)
- executable('shotwell-facedetect',
- 'shotwell-facedetect.cpp',
- dependencies : facedetect_dep,
diff --git a/graphics/shotwell/files/patch-facedetect_shotwell-facedetect.cpp b/graphics/shotwell/files/patch-facedetect_shotwell-facedetect.cpp
deleted file mode 100644
index 0d3aaec14f36..000000000000
--- a/graphics/shotwell/files/patch-facedetect_shotwell-facedetect.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- facedetect/shotwell-facedetect.cpp.orig 2021-02-21 15:22:50 UTC
-+++ facedetect/shotwell-facedetect.cpp
-@@ -34,7 +34,7 @@ void help() {
- void detectFaces(Mat &img, CascadeClassifier &cascade, double scale) {
-
- Mat gray;
-- cvtColor(img, gray, CV_BGR2GRAY);
-+ cvtColor(img, gray, COLOR_BGR2GRAY);
-
- Mat smallImg(cvRound(img.rows / scale), cvRound(img.cols / scale), CV_8UC1);
- Size smallImgSize = smallImg.size();
-@@ -43,7 +43,7 @@ void detectFaces(Mat &img, CascadeClassifier &cascade,
- equalizeHist(smallImg, smallImg);
-
- vector<Rect> faces;
-- cascade.detectMultiScale(smallImg, faces, 1.1, 2, CV_HAAR_SCALE_IMAGE, Size(30, 30));
-+ cascade.detectMultiScale(smallImg, faces, 1.1, 2, CASCADE_SCALE_IMAGE, Size(30, 30));
-
- int i = 0;
- for (vector<Rect>::const_iterator r = faces.begin(); r != faces.end(); r++, i++) {