aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-06 12:12:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-06 12:12:00 +0000
commit7a0f4abe2be429be794564fa0ba30727d6458ef0 (patch)
treecb47117e55d8b3cfa8e1d039d125b1106964ca6e /graphics
parent60dbc060c34744dd55726fe83163eee3d49b4efe (diff)
downloadports-7a0f4abe2be429be794564fa0ba30727d6458ef0.tar.gz
ports-7a0f4abe2be429be794564fa0ba30727d6458ef0.zip
Add an explicit dependency on pkgconf
Notes
Notes: svn path=/head/; revision=326491
Diffstat (limited to 'graphics')
-rw-r--r--graphics/edje_viewer/Makefile1
-rw-r--r--graphics/eog-plugins/Makefile3
-rw-r--r--graphics/gource/Makefile2
-rw-r--r--graphics/gstreamer-plugins-gl/Makefile9
-rw-r--r--graphics/gtimelapse/Makefile7
-rw-r--r--graphics/ocrfeeder/Makefile3
-rw-r--r--graphics/passepartout/Makefile9
-rw-r--r--graphics/visionworkbench/Makefile1
8 files changed, 11 insertions, 24 deletions
diff --git a/graphics/edje_viewer/Makefile b/graphics/edje_viewer/Makefile
index 385733f099fd..72029c79b0ab 100644
--- a/graphics/edje_viewer/Makefile
+++ b/graphics/edje_viewer/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= LOCAL/gblach/e17/extra/
MAINTAINER= gblach@FreeBSD.org
COMMENT= A simple viewer for .edj files
+USES= pkgconfig
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
index a5a54da0ffa9..081953eb11e4 100644
--- a/graphics/eog-plugins/Makefile
+++ b/graphics/eog-plugins/Makefile
@@ -17,11 +17,10 @@ LIB_DEPENDS= gdata.7:${PORTSDIR}/devel/libgdata
RUN_DEPENDS= eog:${PORTSDIR}/graphics/eog
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GL= gl
USE_GNOME= gnomeprefix intlhack gtk20
WANT_GNOME= yes
-USES= gettext pathfix
+USES= gettext pathfix gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/gource/Makefile b/graphics/gource/Makefile
index 88791b4615a5..ba32786f38f5 100644
--- a/graphics/gource/Makefile
+++ b/graphics/gource/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
GNU_CONFIGURE= yes
USE_GCC= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
MANCOMPRESSED= yes
CONFIGURE_ARGS+=--with-boost-system=boost_system \
diff --git a/graphics/gstreamer-plugins-gl/Makefile b/graphics/gstreamer-plugins-gl/Makefile
index 3d4d7f92b8a1..aab54eb9554b 100644
--- a/graphics/gstreamer-plugins-gl/Makefile
+++ b/graphics/gstreamer-plugins-gl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gstreamer-plugins-gl
-# Date created: 6 Sep 2010
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gstreamer-plugins-gl
PORTVERSION= 0.10.3
@@ -19,9 +15,8 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GSTREAMER= yes
USE_XORG= ice x11
USE_GL= gl glu glew
diff --git a/graphics/gtimelapse/Makefile b/graphics/gtimelapse/Makefile
index 686a97a8e064..6ac5f080f773 100644
--- a/graphics/gtimelapse/Makefile
+++ b/graphics/gtimelapse/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gTimelapse
-# Date created: 29 Aug 2011
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gtimelapse
DISTVERSION= 0.1
@@ -20,6 +16,7 @@ LIB_DEPENDS= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
+USES= pkgconfig
USE_WX= 2.8+
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/ocrfeeder/Makefile b/graphics/ocrfeeder/Makefile
index 76ac9de63aaa..ed64b7124528 100644
--- a/graphics/ocrfeeder/Makefile
+++ b/graphics/ocrfeeder/Makefile
@@ -25,10 +25,9 @@ MAN1= ocrfeeder-cli.1 ocrfeeder.1
USE_XZ= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_PYTHON= yes
USE_GNOME= pygtk2 pygnomeextras
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GHOSTSCRIPT=yes
.include <bsd.port.options.mk>
diff --git a/graphics/passepartout/Makefile b/graphics/passepartout/Makefile
index c9c768ebf7d8..4f6f1c4477bb 100644
--- a/graphics/passepartout/Makefile
+++ b/graphics/passepartout/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: passepartout
-# Date created: 11st Sep 2003
-# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
-#
+# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/passepartout/Makefile,v 1.4 2006/09/30 15:31:05 ahze Exp $
-#
PORTNAME= passepartout
PORTVERSION= 0.7.1
@@ -24,8 +20,7 @@ LIB_DEPENDS= xml\\+\\+-2.6.2:${PORTSDIR}/textproc/libxml++26 \
RUN_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gmake pkgconfig
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/visionworkbench/Makefile b/graphics/visionworkbench/Makefile
index 9854a4696e6f..ebcd59f00028 100644
--- a/graphics/visionworkbench/Makefile
+++ b/graphics/visionworkbench/Makefile
@@ -18,6 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_QT4= moc_build qmake_build
USE_FORTRAN= yes
USE_LDCONFIG= yes