aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2005-02-05 04:59:26 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2005-02-05 04:59:26 +0000
commit870baf2a9ac76ec39ea9fa066418657fb53ede54 (patch)
tree49251f8ea7663d5f4d431ea8b3f43c4eaf180b23 /graphics
parentbba475b325efa2e3cc7a22fefe97cff615fa7a3a (diff)
downloadports-870baf2a9ac76ec39ea9fa066418657fb53ede54.tar.gz
ports-870baf2a9ac76ec39ea9fa066418657fb53ede54.zip
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been removed, since no one seems to appreciate the partially working solution. Good news is that the pthread support of lang/ruby18 is now enabled by default for newer systems, which means the ruby interpreter is linked with libpthread. This will allow threaded extension libraries to run and work properly on those systems. The --march=cputype flag is disabled because it gets ruby to malfunction and fail to build. I don't know if the problem is in libpthread or in gcc. (It really makes me wonder if they had actually tested before asking me to do this somewhat risky change ;-)
Notes
Notes: svn path=/head/; revision=128068
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ruby-opengl/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/ruby-opengl/Makefile b/graphics/ruby-opengl/Makefile
index 74e631dd456a..9cdac7bdae85 100644
--- a/graphics/ruby-opengl/Makefile
+++ b/graphics/ruby-opengl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opengl
PORTVERSION= 0.32b
+PORTREVISION= 1
CATEGORIES= graphics ruby
MASTER_SITES= http://www2.giganet.net/~yoshi/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -22,12 +23,15 @@ USE_RUBY_EXTCONF= yes
USE_MESA= yes
-RUBY_WITH_PTHREAD= yes
-
WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
INSTALL_TARGET= site-install
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502102
+BROKEN= "Systems prior to FreeBSD 502102 are out of support"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -37,4 +41,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>