aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-01-14 03:25:59 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-01-14 03:25:59 +0000
commit931cc491b1456f0717be51ef2570a48a9d78c1ec (patch)
tree285998cfe8f5adc4752f41e92ee71ecc359d0679 /graphics
parentde71fae136d34f3f975c8bc03db2c1d8ce741f25 (diff)
downloadports-931cc491b1456f0717be51ef2570a48a9d78c1ec.tar.gz
ports-931cc491b1456f0717be51ef2570a48a9d78c1ec.zip
Add new dcraw-m port, a variant of dcraw that
adds auto-rotate to exported thumbnails, and also add adjustment for camera timezone offset. PR: ports/177490 Submitted by: Waitman Gobble
Notes
Notes: svn path=/head/; revision=339660
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/dcraw-m/Makefile44
-rw-r--r--graphics/dcraw-m/distinfo2
-rw-r--r--graphics/dcraw-m/pkg-descr13
4 files changed, 60 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bbb12298e564..2ac0b98c0f33 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -113,6 +113,7 @@
SUBDIR += dc20ctrl
SUBDIR += dc20pack
SUBDIR += dcraw
+ SUBDIR += dcraw-m
SUBDIR += deegree-csw
SUBDIR += deegree-igeoportal
SUBDIR += deegree-wcs
diff --git a/graphics/dcraw-m/Makefile b/graphics/dcraw-m/Makefile
new file mode 100644
index 000000000000..9e9b535fee90
--- /dev/null
+++ b/graphics/dcraw-m/Makefile
@@ -0,0 +1,44 @@
+# Created by: "Waitman Gobble" <uzimac@da3m0n8t3r.com>
+# $FreeBSD$
+
+PORTNAME= dcraw-m
+PORTVERSION= 9.17
+CATEGORIES= graphics
+MASTER_SITES= https://dx.burplex.com/dcraw-m/ \
+ http://www.waitman.net/dcraw-m/
+
+MAINTAINER= waitman@waitman.net
+COMMENT= Modified Decoder for RAW files from digital cameras
+
+LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libMagickWand.so:${PORTSDIR}/graphics/ImageMagick
+
+PLIST_FILES= bin/dcraw-m
+
+OPTIONS_DEFINE= OPTIMIZE_O3 OPTIMIZE_O4
+OPTIMIZE_O3_DESC= Use O3 with clang (O4 not working)
+OPTIMIZE_O4_DESC= Use O4 with gcc
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPTIMIZE_O3}
+CFLAGS+= -O3
+.else
+.if ${PORT_OPTIONS:MOPTIMIZE_O4}
+CFLAGS+= -O4
+.endif
+.endif
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ImageMagick
+LDFLAGS+= -L${LOCALBASE}/lib -lm -ljasper -ljpeg -llcms -lMagickWand
+
+do-build:
+ cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/graphics/dcraw-m/distinfo b/graphics/dcraw-m/distinfo
new file mode 100644
index 000000000000..b5f201aa490f
--- /dev/null
+++ b/graphics/dcraw-m/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dcraw-m-9.17.tar.gz) = 1b727e9b51e9aacae3d0ce3bf7d805f014b43baf371715351ae46c46c2e90269
+SIZE (dcraw-m-9.17.tar.gz) = 88589
diff --git a/graphics/dcraw-m/pkg-descr b/graphics/dcraw-m/pkg-descr
new file mode 100644
index 000000000000..206de06094ba
--- /dev/null
+++ b/graphics/dcraw-m/pkg-descr
@@ -0,0 +1,13 @@
+dcraw is an ANSI C program that decodes any raw image from any digital camera
+on any computer running any operating system. It's become a standard tool
+within and without the Open Source world. It's small (about 3000 lines),
+portable (standard C libraries only), free (both "gratis" and "libre"), and
+when used skillfully, produces better-quality output than the tools provided by
+the camera vendor.
+
+This version is modified to add auto-rotate to exported thumbnails, and also
+add adjustment for camera timezone offset.
+
+WWW: http://www.cybercom.net/~dcoffin/dcraw/
+WWW: https://dx.burplex.com/bin/autorot.html
+WWW: https://dx.burplex.com/bin/photohack.html