aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-03-09 16:39:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-03-09 18:47:17 +0000
commit95691f2eb1a8722a47078f4222c3c8739ffb922e (patch)
tree5341912e1bf57d52ab0ee774d30b4327acd2657d /graphics
parent82e3dfd43d3d194507cda8393b01660803913e2b (diff)
downloadports-95691f2eb1a8722a47078f4222c3c8739ffb922e.tar.gz
ports-95691f2eb1a8722a47078f4222c3c8739ffb922e.zip
graphics/cxxplot: Update 0.3.0-2 → 0.3.1
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cxxplot/Makefile10
-rw-r--r--graphics/cxxplot/distinfo6
-rw-r--r--graphics/cxxplot/files/patch-CMakeLists.txt38
-rw-r--r--graphics/cxxplot/pkg-plist42
4 files changed, 65 insertions, 31 deletions
diff --git a/graphics/cxxplot/Makefile b/graphics/cxxplot/Makefile
index 69ee281c35ec..cf45d54c0d28 100644
--- a/graphics/cxxplot/Makefile
+++ b/graphics/cxxplot/Makefile
@@ -1,7 +1,6 @@
PORTNAME= cxxplot
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.0-2
-DISTVERSIONSUFFIX= -g750b54b
+DISTVERSION= 0.3.1
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
@@ -16,16 +15,17 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BROKEN_FreeBSD_12= build error: 'concepts' file not found
.endif
-USES= cmake:testing compiler:c++20-lang gl qt:5
-USE_QT= core gui opengl printsupport widgets buildtools:build qmake:build
+USES= cmake:testing compiler:c++20-lang gl qt:6
+USE_QT= base tools:build
USE_GL= gl opengl
USE_GITHUB= yes
GH_ACCOUNT= USNavalResearchLaboratory
CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_TESTING_TARGET=
-do-test: # 'make test' opens a lot of windows
+post-test: # 'make test' opens a lot of windows
.for name in 01_test 02_test 03_test 04_test 05_test 06_test_csv 07_test_image
@${ECHO} "==> Running the test ${name}"
@${TEST_WRKSRC}/tests/${name}/libcxxplot_${name:C/test_.*/test/}
diff --git a/graphics/cxxplot/distinfo b/graphics/cxxplot/distinfo
index 45c22a2ce1af..d0e9740fd326 100644
--- a/graphics/cxxplot/distinfo
+++ b/graphics/cxxplot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1667983462
-SHA256 (USNavalResearchLaboratory-cxxplot-v0.3.0-2-g750b54b_GH0.tar.gz) = 4d4d3aa5e9076589b29a578a0fa10af14ce71b5ba690c1361b696f33e1cad53c
-SIZE (USNavalResearchLaboratory-cxxplot-v0.3.0-2-g750b54b_GH0.tar.gz) = 4385268
+TIMESTAMP = 1678379779
+SHA256 (USNavalResearchLaboratory-cxxplot-v0.3.1_GH0.tar.gz) = 8075f3a8f6353de48f98386a3bd616517a51052f4e6e15ff09558525e05f1920
+SIZE (USNavalResearchLaboratory-cxxplot-v0.3.1_GH0.tar.gz) = 4385376
diff --git a/graphics/cxxplot/files/patch-CMakeLists.txt b/graphics/cxxplot/files/patch-CMakeLists.txt
index b4b8fd7841c9..10631789c78f 100644
--- a/graphics/cxxplot/files/patch-CMakeLists.txt
+++ b/graphics/cxxplot/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2022-04-04 11:38:46 UTC
+--- CMakeLists.txt.orig 2023-03-09 12:51:28 UTC
+++ CMakeLists.txt
@@ -164,7 +164,7 @@ target_link_libraries( cxxplot
@@ -9,7 +9,41 @@
)
# Install, export targets, cmake config and version
-@@ -224,9 +224,10 @@ install(
+@@ -172,8 +172,8 @@ include( GNUInstallDirs )
+
+ install( TARGETS cxxplot
+ EXPORT cxxplotTargets
+- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CXXPLOT_DIR_WITH_VERSION}
+- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CXXPLOT_DIR_WITH_VERSION}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ )
+@@ -203,7 +203,7 @@ install(
+ FILES
+ ${CXXPLOT_PUBLIC_HDR}
+ DESTINATION
+- ${CMAKE_INSTALL_INCLUDEDIR}/${CXXPLOT_DIR_WITH_VERSION}/cxxplot
++ ${CMAKE_INSTALL_INCLUDEDIR}/cxxplot
+ )
+
+ install(EXPORT cxxplotTargets
+@@ -212,7 +212,7 @@ install(EXPORT cxxplotTargets
+ NAMESPACE
+ cxxplot::
+ DESTINATION
+- ${CMAKE_INSTALL_LIBDIR}/cmake/${CXXPLOT_DIR_WITH_VERSION}
++ ${CMAKE_INSTALL_LIBDIR}/cmake/cxxplot
+ )
+
+ install(
+@@ -220,13 +220,14 @@ install(
+ ${CMAKE_BINARY_DIR}/cmake/cxxplotConfig.cmake
+ ${CMAKE_BINARY_DIR}/cmake/cxxplotConfigVersion.cmake
+ DESTINATION
+- ${CMAKE_INSTALL_LIBDIR}/cmake/${CXXPLOT_DIR_WITH_VERSION}
++ ${CMAKE_INSTALL_LIBDIR}/cmake/cxxplot
)
# tests/examples
diff --git a/graphics/cxxplot/pkg-plist b/graphics/cxxplot/pkg-plist
index f4d459feae48..34b22cccf6ba 100644
--- a/graphics/cxxplot/pkg-plist
+++ b/graphics/cxxplot/pkg-plist
@@ -1,21 +1,21 @@
-include/cxxplot-0.3.0/cxxplot/align.hpp
-include/cxxplot-0.3.0/cxxplot/color.hpp
-include/cxxplot-0.3.0/cxxplot/concepts.hpp
-include/cxxplot-0.3.0/cxxplot/cxxplot
-include/cxxplot-0.3.0/cxxplot/execution.hpp
-include/cxxplot-0.3.0/cxxplot/figure.hpp
-include/cxxplot-0.3.0/cxxplot/gettersetter.hpp
-include/cxxplot-0.3.0/cxxplot/graph.hpp
-include/cxxplot-0.3.0/cxxplot/image.hpp
-include/cxxplot-0.3.0/cxxplot/named_parameter.hpp
-include/cxxplot-0.3.0/cxxplot/point2d.hpp
-include/cxxplot-0.3.0/cxxplot/range.hpp
-include/cxxplot-0.3.0/cxxplot/styles.hpp
-include/cxxplot-0.3.0/cxxplot/typetraits.hpp
-include/cxxplot-0.3.0/cxxplot/utils.hpp
-include/cxxplot-0.3.0/cxxplot/window.hpp
-lib/cmake/cxxplot-0.3.0/cxxplotConfig.cmake
-lib/cmake/cxxplot-0.3.0/cxxplotConfigVersion.cmake
-lib/cmake/cxxplot-0.3.0/cxxplotTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/cxxplot-0.3.0/cxxplotTargets.cmake
-lib/cxxplot-0.3.0/libcxxplot.so
+include/cxxplot/align.hpp
+include/cxxplot/color.hpp
+include/cxxplot/concepts.hpp
+include/cxxplot/cxxplot
+include/cxxplot/execution.hpp
+include/cxxplot/figure.hpp
+include/cxxplot/gettersetter.hpp
+include/cxxplot/graph.hpp
+include/cxxplot/image.hpp
+include/cxxplot/named_parameter.hpp
+include/cxxplot/point2d.hpp
+include/cxxplot/range.hpp
+include/cxxplot/styles.hpp
+include/cxxplot/typetraits.hpp
+include/cxxplot/utils.hpp
+include/cxxplot/window.hpp
+lib/cmake/cxxplot/cxxplotConfig.cmake
+lib/cmake/cxxplot/cxxplotConfigVersion.cmake
+lib/cmake/cxxplot/cxxplotTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/cxxplot/cxxplotTargets.cmake
+lib/libcxxplot.so