aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-17 01:19:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-17 01:19:38 +0000
commit979a27271fc1a53ad029f8fc444172a41782fad8 (patch)
tree5f670b506e23ed3db8831c1eb1c3551b62654bd7 /graphics
parentbdb0707174cb705ea4073c06ee4ecbf887e99022 (diff)
downloadports-979a27271fc1a53ad029f8fc444172a41782fad8.tar.gz
ports-979a27271fc1a53ad029f8fc444172a41782fad8.zip
- Support staging
- Convert USE_GMAKE to USES - Use new LIB_DEPENDS syntax - Don't try to remove mtree directory
Notes
Notes: svn path=/head/; revision=330589
Diffstat (limited to 'graphics')
-rw-r--r--graphics/quesoglc/Makefile21
-rw-r--r--graphics/quesoglc/pkg-plist1
2 files changed, 8 insertions, 14 deletions
diff --git a/graphics/quesoglc/Makefile b/graphics/quesoglc/Makefile
index bd6df0ee4be1..11c32cbf0982 100644
--- a/graphics/quesoglc/Makefile
+++ b/graphics/quesoglc/Makefile
@@ -10,14 +10,13 @@ MASTER_SITES= SF/${PORTNAME}/QuesoGLC/${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free implementation of the OpenGL Character Renderer
-LIB_DEPENDS= fribidi:${PORTSDIR}/converters/fribidi \
- freetype:${PORTSDIR}/print/freetype2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gmake
USE_GL= gl glu glut
USE_LDCONFIG= yes
@@ -28,15 +27,11 @@ CONFIGURE_ARGS= --without-glew --with-fribidi
PORTDOCS= README
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/quesoglc/pkg-plist b/graphics/quesoglc/pkg-plist
index 9d0f2074c224..7006db2dcf42 100644
--- a/graphics/quesoglc/pkg-plist
+++ b/graphics/quesoglc/pkg-plist
@@ -4,5 +4,4 @@ lib/libGLC.la
lib/libGLC.so
lib/libGLC.so.0
libdata/pkgconfig/quesoglc.pc
-@dirrmtry libdata/pkgconfig
@dirrmtry include/GL