aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-18 23:23:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-18 23:23:22 +0000
commit984ae7395558ff2da9d6ce744d7e9f30adcb5746 (patch)
tree2d479e776390779e15f146b387c72824e50af15b /graphics
parentc58e97a933e3ec1eec15abfdacd30e0ec3c55604 (diff)
downloadports-984ae7395558ff2da9d6ce744d7e9f30adcb5746.tar.gz
ports-984ae7395558ff2da9d6ce744d7e9f30adcb5746.zip
Add py-cartopy 0.16.0
Cartopy is a Python package designed to make drawing maps for data analysis and visualisation easy. It features: - object oriented projection definitions - point, line, polygon and image transformations between projections - integration to expose advanced mapping in Matplotlib with a simple and intuitive interface - powerful vector data handling by integrating shapefile reading with Shapely capabilities WWW: https://pypi.org/project/Cartopy/ WWW: https://github.com/SciTools/cartopy
Notes
Notes: svn path=/head/; revision=470330
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-cartopy/Makefile30
-rw-r--r--graphics/py-cartopy/distinfo3
-rw-r--r--graphics/py-cartopy/pkg-descr13
4 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f306c37dd030..8c499442dec3 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -884,6 +884,7 @@
SUBDIR += py-blockdiagcontrib-cisco
SUBDIR += py-cairo
SUBDIR += py-cairocffi
+ SUBDIR += py-cartopy
SUBDIR += py-chart
SUBDIR += py-django-easy-thumbnails
SUBDIR += py-djvulibre
diff --git a/graphics/py-cartopy/Makefile b/graphics/py-cartopy/Makefile
new file mode 100644
index 000000000000..6366f7ba24c1
--- /dev/null
+++ b/graphics/py-cartopy/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cartopy
+PORTVERSION= 0.16.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Cartopy-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cartographic library with Matplotlib support for visualisation
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+BUILD_DEPENDS= geos>-3.3.3:graphics/geos \
+ proj>=4.9.0:graphics/proj \
+ ${PYNUMPY}
+LIB_DEPENDS= libgeos.so:graphics/geos \
+ libproj.so:graphics/proj
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pyshp>=1.1.4:devel/py-pyshp@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Shapely>=1.5.6:devel/py-shapely@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six@${FLAVOR}
+
+USE_PYTHON= autoplist concurrent cython distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/graphics/py-cartopy/distinfo b/graphics/py-cartopy/distinfo
new file mode 100644
index 000000000000..9a294ab7047d
--- /dev/null
+++ b/graphics/py-cartopy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521210915
+SHA256 (Cartopy-0.16.0.tar.gz) = f23dffa101f43dd91e866a49ebb5f5048be2a24ab8a921a5c07edabde746d9a4
+SIZE (Cartopy-0.16.0.tar.gz) = 8808827
diff --git a/graphics/py-cartopy/pkg-descr b/graphics/py-cartopy/pkg-descr
new file mode 100644
index 000000000000..d9ee909a724c
--- /dev/null
+++ b/graphics/py-cartopy/pkg-descr
@@ -0,0 +1,13 @@
+Cartopy is a Python package designed to make drawing maps for data analysis and
+visualisation easy.
+
+It features:
+- object oriented projection definitions
+- point, line, polygon and image transformations between projections
+- integration to expose advanced mapping in Matplotlib with a simple and
+ intuitive interface
+- powerful vector data handling by integrating shapefile reading with Shapely
+ capabilities
+
+WWW: https://pypi.org/project/Cartopy/
+WWW: https://github.com/SciTools/cartopy