aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-10 07:31:53 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-10 07:31:53 +0000
commit9985d7a8d6f75e9b2adde1a5512fbafe9a80062b (patch)
tree9b70e365189372d1ad8e0d49b1b3125b750bcec8 /graphics
parentd43a62e3b662baf515fa92091a043278bd655ef1 (diff)
downloadports-9985d7a8d6f75e9b2adde1a5512fbafe9a80062b.tar.gz
ports-9985d7a8d6f75e9b2adde1a5512fbafe9a80062b.zip
Update to latest DRI CVS. New in this update is the move of the DRI drivers
to Mesa CVS with only the build infrastructure from DRI CVS being used. This means that the Mesa 5.1 development branch is being used, where many changes have occurred related to OpenGL 1.5 support. Also mark this port ONLY_FOR_ARCHS=i386 alpha, like graphics/dri, until there's hope for other architectures.
Notes
Notes: svn path=/head/; revision=95525
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dri-devel/Makefile9
-rw-r--r--graphics/dri-devel/distinfo3
-rw-r--r--graphics/dri-devel/files/patch-FreeBSD.cf20
-rw-r--r--graphics/dri-devel/files/patch-host.def38
-rw-r--r--graphics/dri-devel/pkg-plist1
5 files changed, 28 insertions, 43 deletions
diff --git a/graphics/dri-devel/Makefile b/graphics/dri-devel/Makefile
index b242411ee41b..9d7a43c46ef6 100644
--- a/graphics/dri-devel/Makefile
+++ b/graphics/dri-devel/Makefile
@@ -6,12 +6,13 @@
#
PORTNAME= dri
-PORTVERSION= 4.3.99.12.20031111
+PORTVERSION= 5.1.p1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= anholt/dri-devel
-DISTNAME= ${PORTNAME}-20031111
+DISTFILES= ${PORTNAME}-20031209.tar.bz2 \
+ Mesa-newtree-20031209.tar.bz2
MAINTAINER= anholt@FreeBSD.org
COMMENT= OpenGL hardware acceleration drivers snapshot for XFree86
@@ -26,6 +27,8 @@ DRILIST= gamma/gamma_dri.so i810/i810_dri.so i830/i830_dri.so \
mga/mga_dri.so r128/r128_dri.so r200/r200_dri.so \
radeon/radeon_dri.so sis/sis_dri.so tdfx/tdfx_dri.so
+ONLY_FOR_ARCHS= alpha i386
+
do-configure:
@${RM} -f ${WRKSRC}/config/cf/version.def
@${RM} -f ${WRKSRC}/config/cf/date.def
@@ -42,7 +45,7 @@ pre-build:
do-install:
.for i in ${DRILIST}
- ${INSTALL_DATA} ${WRKSRC}/lib/GL/mesa/src/drv/${i} \
+ ${INSTALL_DATA} ${WRKSRC}/lib/GL/mesa/drivers/dri/${i} \
${PREFIX}/lib/modules/dri
.endfor
diff --git a/graphics/dri-devel/distinfo b/graphics/dri-devel/distinfo
index 9186f5eecd1e..a2d676708400 100644
--- a/graphics/dri-devel/distinfo
+++ b/graphics/dri-devel/distinfo
@@ -1 +1,2 @@
-MD5 (dri-20031111.tar.bz2) = 416419347b33a8cfeb890076254ec554
+MD5 (dri-20031209.tar.bz2) = 07c2d6d771aabac1b487bb89da47c4ee
+MD5 (Mesa-newtree-20031209.tar.bz2) = ef65ba41c698c6066798a3af13fe7674
diff --git a/graphics/dri-devel/files/patch-FreeBSD.cf b/graphics/dri-devel/files/patch-FreeBSD.cf
deleted file mode 100644
index 2e31659ced06..000000000000
--- a/graphics/dri-devel/files/patch-FreeBSD.cf
+++ /dev/null
@@ -1,20 +0,0 @@
---- config/cf/FreeBSD.cf.orig Thu Oct 9 02:55:57 2003
-+++ config/cf/FreeBSD.cf Tue Nov 11 17:41:44 2003
-@@ -166,6 +166,7 @@
- *
- * ld: warning: libXThrStub.so.6, needed by libX11.so, not found
- */
-+/*
- #if BuildThreadStubLibrary && (!defined(UseInstalledX11) || !UseInstalledX11)
- # define CcCmd $(CLIENTENVSETUP) cc
- # define CplusplusCmd $(CLIENTENVSETUP) c++
-@@ -173,6 +174,9 @@
- # define CcCmd cc
- # define CplusplusCmd c++
- #endif
-+*/
-+#define CcCmd ${FBSDCC}
-+#define CplusplusCmd ${FBSDCXX}
-
- #define CppCmd /usr/bin/cpp
- #define PreProcessCmd CppCmd
diff --git a/graphics/dri-devel/files/patch-host.def b/graphics/dri-devel/files/patch-host.def
index 7ed939438504..259080b860a0 100644
--- a/graphics/dri-devel/files/patch-host.def
+++ b/graphics/dri-devel/files/patch-host.def
@@ -1,29 +1,29 @@
---- config/cf/host.def.orig Wed Oct 22 16:15:12 2003
-+++ config/cf/host.def Tue Nov 11 17:48:48 2003
-@@ -8,18 +8,10 @@
+--- config/cf/host.def.orig Tue Dec 9 17:50:12 2003
++++ config/cf/host.def Tue Dec 9 23:06:33 2003
+@@ -5,7 +5,7 @@
+ #define XFree86CustomVersion "DRI trunk"
+
+ /* You need this now */
+-#define MesaSrcDir /X11R6/SourceForge/Mesanew/Mesa-newtree
++#define MesaSrcDir $(TOP)/../Mesa-newtree
+
+
/* Don't use any special flags by default, but leave this here commented out
- * so people see how to if they want
- */
--/*
--#define DefaultGcc2AxpOpt -O2 -mcpu=ev6
--#define DefaultGcc2PpcOpt -O2 -mcpu=750
--#define DefaultGcc2i386Opt -O2
--#if defined(AlphaArchitecture)
--# define LibraryCDebugFlags -O2 -mcpu=ev6
--#elif defined(PpcArchitecture)
--# define LibraryCDebugFlags -O2 -mcpu=750
--#else
--# define LibraryCDebugFlags -O2
--#endif
--*/
+@@ -24,6 +24,13 @@
+ #endif
+ */
+
+#define DefaultGcc2AxpOpt ${FBSDCFLAGS}
+#define DefaultGcc2PpcOpt ${FBSDCFLAGS}
+#define DefaultGcc2i386Opt ${FBSDCFLAGS}
+#define LibraryCDebugFlags ${FBSDCFLAGS}
-
++
++#define CcCmd ${FBSDCC}
++#define CplusplusCmd ${FBSDCXX}
#define BuildXFree86ConfigTools YES
-@@ -43,15 +35,17 @@
+
+@@ -46,15 +53,17 @@
#if defined(FreeBSDArchitecture) && defined(HasGcc3) && HasGcc3
#define NoSystemWarn -Wno-system-headers
diff --git a/graphics/dri-devel/pkg-plist b/graphics/dri-devel/pkg-plist
index d212f2c49450..6a37410a2e58 100644
--- a/graphics/dri-devel/pkg-plist
+++ b/graphics/dri-devel/pkg-plist
@@ -1,3 +1,4 @@
+lib/modules/dri/fb_dri.so
lib/modules/dri/gamma_dri.so
lib/modules/dri/i810_dri.so
lib/modules/dri/i830_dri.so