aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-02-10 12:14:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-02-10 12:14:25 +0000
commit9f9dcb6809700fd4a86bcc2e1356417ef8b9f71c (patch)
tree4798d4bb898229febc55969da05d3079236edeb6 /graphics
parent46fb1fe412ddab3291e5661b99ff681e8c7bd616 (diff)
downloadports-9f9dcb6809700fd4a86bcc2e1356417ef8b9f71c.tar.gz
ports-9f9dcb6809700fd4a86bcc2e1356417ef8b9f71c.zip
- Unbreak the build
- Take maintainership - Mark as IGNOREd for now since GUI crashes on startup
Notes
Notes: svn path=/head/; revision=128462
Diffstat (limited to 'graphics')
-rw-r--r--graphics/panorama/Makefile18
-rw-r--r--graphics/panorama/files/patch-hlapi-plugin_manager.cpp15
-rw-r--r--graphics/panorama/files/patch-hlapi-plugins_all.h26
-rw-r--r--graphics/panorama/files/patch-llapi_priority_queue.h25
-rw-r--r--graphics/panorama/files/patch-plugins_image_io_tga_tga_io.cpp16
5 files changed, 87 insertions, 13 deletions
diff --git a/graphics/panorama/Makefile b/graphics/panorama/Makefile
index e96e238bd151..bbe02ebd9a8f 100644
--- a/graphics/panorama/Makefile
+++ b/graphics/panorama/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= GNU framework for 3D graphics production
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -22,29 +22,21 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2 \
gtkmm.2:${PORTSDIR}/x11-toolkits/gtk--
-BROKEN= "Does not build"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
-
USE_BZIP2= yes
USE_BISON= yes
USE_GNOME= gnometarget gtk12
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ENV= NOPORTDOCS="${NOPORTDOCS}"
INSTALLS_SHLIB= yes
-CXX+= ${CPPFLAGS} ${LDFLAGS}
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-.include <bsd.port.pre.mk>
+IGNORE= segfaults on startup (GUI only, render binary still works)
post-patch:
@${FIND} ${WRKSRC} -name "Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-module -rpath|-module -avoid-version -rpath|g'
+ @${REINPLACE_CMD} -e 's,/etc/,/etc/panorama/,' ${WRKSRC}/programs/gui/main.cpp \
+ ${WRKSRC}/programs/render/render.cpp ${WRKSRC}/doc/config.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/panorama/files/patch-hlapi-plugin_manager.cpp b/graphics/panorama/files/patch-hlapi-plugin_manager.cpp
new file mode 100644
index 000000000000..5c44a1091c1d
--- /dev/null
+++ b/graphics/panorama/files/patch-hlapi-plugin_manager.cpp
@@ -0,0 +1,15 @@
+--- hlapi/plugin_manager.cpp.orig Thu Nov 21 01:54:16 2002
++++ hlapi/plugin_manager.cpp Wed Feb 2 18:54:59 2005
+@@ -48,6 +48,12 @@
+ void* pvHandle = NULL;
+ bool gAbsolutePath = ( rktNAME[0] == '/' );
+
++ /*
++ * Reset dlerror() since it can contain error from previous
++ * call to dlopen()/dlsym().
++ */
++ dlerror();
++
+ if ( gAbsolutePath )
+ {
+ pvHandle = dlopen (rktNAME.c_str(), RTLD_NOW | RTLD_GLOBAL);
diff --git a/graphics/panorama/files/patch-hlapi-plugins_all.h b/graphics/panorama/files/patch-hlapi-plugins_all.h
new file mode 100644
index 000000000000..e14f6bb296d0
--- /dev/null
+++ b/graphics/panorama/files/patch-hlapi-plugins_all.h
@@ -0,0 +1,26 @@
+--- hlpai/plugins_all.h.orig Thu Nov 21 01:54:16 2002
++++ hlapi/plugins_all.h Mon Jan 31 18:34:32 2005
+@@ -16,6 +16,7 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#if ( STATIC_LINK == 1 )
+ #include "plugins/atm_object/atm_const/atm_const.h"
+ #include "plugins/bsdf/cook_torrance/bsdf_cook_torrance.h"
+ #include "plugins/bsdf/lambertian/bsdf_lambertian.h"
+@@ -59,12 +60,13 @@
+ #include "plugins/object_filter/cartoon/of_cartoon.h"
+ #include "plugins/object_filter/convert_to_grey/of_convert_to_grey.h"
+ #include "plugins/renderer/raytracer/raytracer.h"
++#endif /* STATIC_LINK == 1 */
+
+-#if defined(USE_EXPERIMENTAL)
++#if ( USE_EXPERIMENTAL == 1 )
+ #include "plugins/object/abvh/abvh.h"
+ #include "plugins/object/height_field/height_field.h"
+ #include "plugins/object/lwo/lwo.h"
+ #include "plugins/object/polyhedron/polyhedron.h"
+ #include "plugins/object/subdiv/subdiv.h"
+ #include "plugins/renderer/zbuffer/zbuffer.h"
+-#endif /* defined(USE_EXPERIMENTAL) */
++#endif /* USE_EXPERIMENTAL == 1 */
diff --git a/graphics/panorama/files/patch-llapi_priority_queue.h b/graphics/panorama/files/patch-llapi_priority_queue.h
new file mode 100644
index 000000000000..f3770418fc59
--- /dev/null
+++ b/graphics/panorama/files/patch-llapi_priority_queue.h
@@ -0,0 +1,25 @@
+--- llapi/priority_queue.h.orig Sat Aug 21 19:37:55 1999
++++ llapi/priority_queue.h Tue Feb 1 17:49:59 2005
+@@ -194,17 +194,18 @@
+ void TPriorityQueue<TItem>::printDebug (void) const
+ {
+
+- cerr << TDebug::indent() << "[_TPriorityQueue_]" << endl;
++ cerr << TDebug::_indent() << "[_TPriorityQueue_]" << endl;
+
+- TDebug::push();
++ TDebug::_push();
+
+ for (size_t J = 1; ( J <= zSize ) ;J++)
+ {
++ string tString;
+ tString << atData[J] + ", " << afPriority[J];
+- cerr << TDebug::indent() << tString << endl;
++ cerr << TDebug::_indent() << tString << endl;
+ }
+
+- TDebug::pop();
++ TDebug::_pop();
+
+ } /* printDebug() */
+
diff --git a/graphics/panorama/files/patch-plugins_image_io_tga_tga_io.cpp b/graphics/panorama/files/patch-plugins_image_io_tga_tga_io.cpp
new file mode 100644
index 000000000000..333b64d0d407
--- /dev/null
+++ b/graphics/panorama/files/patch-plugins_image_io_tga_tga_io.cpp
@@ -0,0 +1,16 @@
+--- plugins/image_io/tga/tga_io.cpp.orig Thu Nov 21 01:54:18 2002
++++ plugins/image_io/tga/tga_io.cpp Tue Feb 1 17:55:53 2005
+@@ -156,11 +156,11 @@
+ bAux = sFile.get(); // Attributes
+ bAttributes = bAux;
+
+- sFile.seekg(sFile.tellg() + long(bIndentifierLength));
++ sFile.seekg(bIndentifierLength, std::ios::cur);
+
+ if ( bColorMapType ) // Ignore color map
+ {
+- sFile.seekg (sFile.tellg() + long((bSizeofMapEntry / 8) * zCountColors));
++ sFile.seekg ((bSizeofMapEntry / 8) * zCountColors, std::ios::cur);
+ }
+
+ if ( bAttributes & 0x20 ) // Check origin (upper or lower left)