aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-06 07:23:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-20 06:57:34 +0000
commita91d65363fe8aa72bdf427bb639b0fe258ee7c01 (patch)
treebff05a5e79d56100a683a17dd262f3cdbf38cf36 /graphics
parent18f78deb5310e3dc0c3283cc5893339da900640c (diff)
downloadports-a91d65363fe8aa72bdf427bb639b0fe258ee7c01.tar.gz
ports-a91d65363fe8aa72bdf427bb639b0fe258ee7c01.zip
Mk/Uses/ninja.mk: Add support for devel/samurai (D29353)
Samurai is a Ninja-compatible build tool with fewer dependencies than Ninja. Hook it to the framework via a new NINJA_DEFAULT. This also adds %p to NINJA_STATUS to make Ninja or Samurai print the percentage of completed jobs to make it easier to eyeball how much of the build is done. PR: 254678 Exp-run by: antoine
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-h3/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/graphics/py-h3/Makefile b/graphics/py-h3/Makefile
index b859669b8d85..09a9dccd838f 100644
--- a/graphics/py-h3/Makefile
+++ b/graphics/py-h3/Makefile
@@ -14,13 +14,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= cmake:devel/cmake \
h3>=${PORTVERSION:R}:graphics/h3 \
- ninja:devel/ninja \
${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
LIB_DEPENDS= libh3.so:graphics/h3
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
-USES= localbase:ldflags python:3.6+
+USES= localbase:ldflags ninja:build python:3.6+
USE_PYTHON= autoplist concurrent cython distutils
CFLAGS+= -I${LOCALBASE}/include/h3