aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-25 14:38:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-25 14:38:38 +0000
commitab7b2ea316ee38f45f56b2798925919305ac56fd (patch)
tree57a312ff978d2d0e82fd70bc18e6d6fc58bb8523 /graphics
parentbb8460f708e1c2d081cd3d4d460d50f32b267553 (diff)
downloadports-ab7b2ea316ee38f45f56b2798925919305ac56fd.tar.gz
ports-ab7b2ea316ee38f45f56b2798925919305ac56fd.zip
Update to 1.2.7.
This lets us drop USE_GCC=3.4. PR: ports/144667 Submitted by: Andrius Morkunas <hinokind@gmail.com>
Notes
Notes: svn path=/head/; revision=255059
Diffstat (limited to 'graphics')
-rw-r--r--graphics/epix/Makefile29
-rw-r--r--graphics/epix/distinfo6
-rw-r--r--graphics/epix/files/patch-newbash.sh15
-rw-r--r--graphics/epix/pkg-plist139
4 files changed, 121 insertions, 68 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index 8ff009f23c8e..5c7847c83cd5 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -7,35 +7,26 @@
#
PORTNAME= epix
-PORTVERSION= 1.0.0
-PORTREVISION= 4
+PORTVERSION= 1.2.7
CATEGORIES= graphics
MASTER_SITES= http://mathcs.holycross.edu/~ahwang/epix/
-DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= ports@FreeBSD.org
COMMENT= Creates math plots and line figures using easy-to-learn syntax
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ dvips:${PORTSDIR}/print/dvipsk-tetex \
+ latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
latex:${PORTSDIR}/print/teTeX
USE_BZIP2= yes
-USE_GCC= 3.4
-MAKE_ARGS= CXX="${CXX}" CFLAGS="${CXXFLAGS} -c" \
- prefix=${PREFIX} \
- INSTALL_PROGRAM="${INSTALL_DATA}" \
- INSTALL_BIN="${INSTALL_SCRIPT}"
-PLIST_SUB= VERSION="${PORTVERSION}"
-
-MAN1= epix.1
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/newbash.sh
- @${REINPLACE_CMD} -e 's|COPYING ||g' ${WRKSRC}/helpfiles.sh
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=--prefix="${PREFIX}" --mandir="${PREFIX}/man" \
+ --infodir="${PREFIX}/info" --with-bash=${LOCALBASE}/bin/bash
-pre-build:
- @(cd ${WRKSRC} ; ./newbash.sh)
+MAN1= elaps.1 epix.1 flix.1 laps.1
+INFO= epix
.include <bsd.port.mk>
diff --git a/graphics/epix/distinfo b/graphics/epix/distinfo
index 203fd817935e..c79b3fa83522 100644
--- a/graphics/epix/distinfo
+++ b/graphics/epix/distinfo
@@ -1,3 +1,3 @@
-MD5 (epix-1.0.0_src.tar.bz2) = 6da4c68ce0bea32fc2d069502893b85c
-SHA256 (epix-1.0.0_src.tar.bz2) = 8bc2f7404759e2a0d71b090e9af3af7ea3486c9c95073e1e5d82cdd9f73d446f
-SIZE (epix-1.0.0_src.tar.bz2) = 117612
+MD5 (epix-1.2.7.tar.bz2) = bbd83e83148f572dc64d3c737ceaa49b
+SHA256 (epix-1.2.7.tar.bz2) = b114393fd7b1457b280b66ed9ea75ce795e6c54159803ce186d573fbbf028880
+SIZE (epix-1.2.7.tar.bz2) = 494954
diff --git a/graphics/epix/files/patch-newbash.sh b/graphics/epix/files/patch-newbash.sh
deleted file mode 100644
index 4d59627268a8..000000000000
--- a/graphics/epix/files/patch-newbash.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- newbash.sh.orig Thu Aug 26 21:41:44 2004
-+++ newbash.sh Wed Nov 3 00:52:21 2004
-@@ -1,10 +1,10 @@
- #!/bin/sh
- #
- for FILE in elaps laps make_header post-uninst.sh pre-install.sh preflix \
-- prepix samples/sample.sh samples/makefigs Makefile
-+ prepix helpfiles.sh samples/sample.sh samples/makefigs Makefile
- do
- mv $FILE $FILE.orig
-- sed 's+/bin/bash+/usr/local/bin/bash+g' $FILE.orig > $FILE
-+ sed 's+/bin/bash+%%LOCALBASE%%/bin/bash+g' $FILE.orig > $FILE
- ## ^-----------------^
- ## Replace the portion from + to + of the line above with the path to
- ## bash on your system. Sample replacement line:
diff --git a/graphics/epix/pkg-plist b/graphics/epix/pkg-plist
index 06496686ffa5..c79b7ca246ab 100644
--- a/graphics/epix/pkg-plist
+++ b/graphics/epix/pkg-plist
@@ -1,36 +1,113 @@
bin/elaps
bin/epix
bin/flix
-bin/keywords
bin/laps
include/epix.h
-lib/libepix.a
-%%DATADIR%%/config/bash_completions
-%%DATADIR%%/config/epix.el
-%%DATADIR%%/config/epix.spec
-%%DATADIR%%/config/update_figs.sh
-%%DATADIR%%/notes/BUGS
-%%DATADIR%%/notes/CHANGELOG
-%%DATADIR%%/notes/INSTALL
-%%DATADIR%%/notes/POST-INSTALL
-%%DATADIR%%/notes/README
-%%DATADIR%%/notes/README-changes
-%%DATADIR%%/notes/THANKS
-%%DATADIR%%/notes/TODO
-%%DATADIR%%/samples/epix-%%VERSION%%_samples.tar
-%%DATADIR%%/tutorial/contrib/CartesianCoord.cc
-%%DATADIR%%/tutorial/contrib/CoordAxis.cc
-%%DATADIR%%/tutorial/contrib/CoordSystem.cc
-%%DATADIR%%/tutorial/contrib/DoubleLogCoord.cc
-%%DATADIR%%/tutorial/contrib/Hatch.cc
-%%DATADIR%%/tutorial/contrib/LinearAxis.cc
-%%DATADIR%%/tutorial/contrib/LogaritmicAxis.cc
-%%DATADIR%%/tutorial/contrib/Makefile
-%%DATADIR%%/tutorial/contrib/PicCommand.cc
-%%DATADIR%%/tutorial/contrib/SingleLogCoord.cc
-@dirrm %%DATADIR%%/tutorial/contrib
-@dirrm %%DATADIR%%/samples
-@dirrm %%DATADIR%%/notes
-@dirrm %%DATADIR%%/config
-@dirrmtry %%DATADIR%%/tutorial
-@dirrmtry %%DATADIR%%
+include/epix/Color.h
+include/epix/Color_Base.h
+include/epix/Color_CMY.h
+include/epix/Color_CMYK.h
+include/epix/Color_Gray.h
+include/epix/Color_Neutral.h
+include/epix/Color_RGB.h
+include/epix/Color_Sep.h
+include/epix/Color_Utils.h
+include/epix/active_screen.h
+include/epix/affine.h
+include/epix/angle_units.h
+include/epix/arrow_data.h
+include/epix/arrow_style.h
+include/epix/axis.h
+include/epix/camera.h
+include/epix/circle.h
+include/epix/clipping.h
+include/epix/constants.h
+include/epix/crop_algorithms.h
+include/epix/cropping.h
+include/epix/curves.h
+include/epix/data_bins.h
+include/epix/data_file.h
+include/epix/data_mask.h
+include/epix/deriv.h
+include/epix/domain.h
+include/epix/edge_data.h
+include/epix/eepic.h
+include/epix/enums.h
+include/epix/errors.h
+include/epix/facet.h
+include/epix/format.h
+include/epix/frac.h
+include/epix/frame.h
+include/epix/functions.h
+include/epix/geometry.h
+include/epix/glyph.h
+include/epix/halfspace.h
+include/epix/hatching.h
+include/epix/intersections.h
+include/epix/interval.h
+include/epix/label_data.h
+include/epix/label_style.h
+include/epix/legend.h
+include/epix/legend_item.h
+include/epix/legend_tile.h
+include/epix/length.h
+include/epix/lens.h
+include/epix/map.h
+include/epix/marker_style.h
+include/epix/markers.h
+include/epix/mask_diamond.h
+include/epix/mask_ellipse.h
+include/epix/mask_rectangle.h
+include/epix/paint_style.h
+include/epix/pairs.h
+include/epix/path.h
+include/epix/path_data.h
+include/epix/path_style.h
+include/epix/pen_arrow.h
+include/epix/pen_data.h
+include/epix/pen_fill.h
+include/epix/pen_line.h
+include/epix/picture.h
+include/epix/picture_data.h
+include/epix/plane.h
+include/epix/plot_algorithms.h
+include/epix/plots.h
+include/epix/pst.h
+include/epix/screen.h
+include/epix/screen_crop.h
+include/epix/screen_data.h
+include/epix/screen_mask.h
+include/epix/segment.h
+include/epix/sphere.h
+include/epix/spline.h
+include/epix/spline_data.h
+include/epix/state.h
+include/epix/surface.h
+include/epix/tikz.h
+include/epix/tile.h
+include/epix/triples.h
+include/epix/utils.h
+include/epix/verbatim.h
+lib/epix/epix-lib.sh
+lib/epix/libepix.a
+%%PORTDOCS%%%%DOCSDIR%%/config/bash_completions
+%%PORTDOCS%%%%DOCSDIR%%/config/epix.el
+%%PORTDOCS%%%%DOCSDIR%%/manual.pdf.gz
+%%PORTDOCS%%%%DOCSDIR%%/manual.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/manual_src.tar.gz
+%%PORTDOCS%%%%DOCSDIR%%/notes/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/notes/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/notes/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/notes/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/notes/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/notes/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/notes/POST-INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/notes/README
+%%PORTDOCS%%%%DOCSDIR%%/notes/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/notes/VERSION
+%%PORTDOCS%%%%DOCSDIR%%/sample_src.tar.gz
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/notes
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/config
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/epix
+@dirrm include/epix