aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2024-02-06 11:58:43 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2024-02-06 13:54:49 +0000
commitbc2df9ae4b953204916357991c7ff1c36b941663 (patch)
tree1af90c2d82955f3a4e19ab85a613abbcf9b79faa /graphics
parent25d6c9ed520199e29c4cf7e860438d44dd7cc6b0 (diff)
downloadports-bc2df9ae4b953204916357991c7ff1c36b941663.tar.gz
ports-bc2df9ae4b953204916357991c7ff1c36b941663.zip
graphics/epstool: Fix parallel build
Diffstat (limited to 'graphics')
-rw-r--r--graphics/epstool/Makefile3
-rw-r--r--graphics/epstool/files/patch-src_common.mak11
2 files changed, 12 insertions, 2 deletions
diff --git a/graphics/epstool/Makefile b/graphics/epstool/Makefile
index 12fedbe5bab0..dbcaded6b159 100644
--- a/graphics/epstool/Makefile
+++ b/graphics/epstool/Makefile
@@ -11,7 +11,7 @@ WWW= http://www.ghostgum.com.au/software/epstool.htm
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENCE
-USES= ghostscript:run gmake
+USES= dos2unix ghostscript:run gmake
MAKEFILE= makefile
MAKE_ARGS= CC="${CC}" \
CCAUX="${CC}" \
@@ -24,7 +24,6 @@ MAKE_ARGS= CC="${CC}" \
LIBPNGLIBS="" \
LINK="${CC} ${LDFLAGS}" \
MAKE="${MAKE_CMD}"
-ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/epstool \
share/man/man1/epstool.1.gz
diff --git a/graphics/epstool/files/patch-src_common.mak b/graphics/epstool/files/patch-src_common.mak
new file mode 100644
index 000000000000..6dd2b507469b
--- /dev/null
+++ b/graphics/epstool/files/patch-src_common.mak
@@ -0,0 +1,11 @@
+--- src/common.mak.orig 2024-02-06 11:23:13 UTC
++++ src/common.mak
+@@ -77,7 +77,7 @@ plapis_h=$(SRC)plapis.h
+ plapis_h=$(SRC)plapis.h
+
+
+-all: $(BEGIN) $(TARGET)
++all: $(BEGIN) .WAIT $(TARGET)
+
+ $(OD)calloc$(OBJ): $(SRC)calloc.c $(common_h)
+ $(COMP) $(FOO)calloc$(OBJ) $(CO) $(SRC)calloc.c